aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/chpp/Makefile
diff options
context:
space:
mode:
authordannyboy <dannyboy@FreeBSD.org>2000-07-08 08:26:16 +0800
committerdannyboy <dannyboy@FreeBSD.org>2000-07-08 08:26:16 +0800
commit3a954b74593f4860c60fab47148a2e82cd2e83c7 (patch)
tree4571b7b489a65a1ab0a3acccf82d7ccb4b4f37df /textproc/chpp/Makefile
parent82b36f3799013380e77c7661e3de814d5fecdf5e (diff)
downloadfreebsd-ports-gnome-3a954b74593f4860c60fab47148a2e82cd2e83c7.tar.gz
freebsd-ports-gnome-3a954b74593f4860c60fab47148a2e82cd2e83c7.tar.zst
freebsd-ports-gnome-3a954b74593f4860c60fab47148a2e82cd2e83c7.zip
Paraphrased from the PR: fixes MASTER_SITES, respects CC/CFLAGS, doesn't
install GPL COPYING, and adds a WWW line to pkg/DESCR. PR: 19764 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'textproc/chpp/Makefile')
-rw-r--r--textproc/chpp/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/textproc/chpp/Makefile b/textproc/chpp/Makefile
index d07d6e8d3513..605b28cfef78 100644
--- a/textproc/chpp/Makefile
+++ b/textproc/chpp/Makefile
@@ -8,22 +8,26 @@
PORTNAME= chpp
PORTVERSION= 0.3.5
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= andy
+MASTER_SITES= http://trick.unix.cslab.tuwien.ac.at/~chpp/files/
MAINTAINER= ports@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
+EXAMPLES_DIR= ${PREFIX}/share/examples/chpp
+DOCS_DIR= ${PREFIX}/share/doc/chpp
+
post-install:
- @ ${MKDIR} ${PREFIX}/share/examples/chpp
- @ cd ${WRKSRC}/test; tar -cf - * | \
- ( cd ${PREFIX}/share/examples/chpp; tar --unlink -xf - )
- @ ${MKDIR} ${PREFIX}/share/doc/chpp
+ @${MKDIR} ${EXAMPLES_DIR}
+ ${TAR} -C ${WRKSRC}/test -cf - . | \
+ ${TAR} -C ${EXAMPLES_DIR} --unlink -xf -
+ @find ${EXAMPLES_DIR} | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @find ${EXAMPLES_DIR} -type f | xargs ${CHMOD} ${SHAREMODE}
.if !defined(NOPORTDOCS)
-.for file in AUTHORS COPYING NEWS README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/chpp
+ @${MKDIR} ${DOCS_DIR}
+.for file in AUTHORS NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCS_DIR}
.endfor
.endif