aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/chpp/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-02 18:07:53 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-02 18:07:53 +0800
commita97dca42a31a6ca6361f6aebd86e16f4c96c1c98 (patch)
treee134599ab06225cdd3f0a68d6030abf39a2ef964 /textproc/chpp/Makefile
parent2c5cf575b1b59d5460e03ceb7514ffeed6b8f928 (diff)
downloadfreebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.tar.gz
freebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.tar.zst
freebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.zip
- Fix the build with modern GCC [1]
- Clean up Makefile, pacify portlint(1) - Use our standard FOOBARDIR macros in pkg-plist - Minor pkg-descr nit Reported by: pointyhat (logs) [1]
Diffstat (limited to 'textproc/chpp/Makefile')
-rw-r--r--textproc/chpp/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/textproc/chpp/Makefile b/textproc/chpp/Makefile
index 8d214d4bc042..b9b10896b3fc 100644
--- a/textproc/chpp/Makefile
+++ b/textproc/chpp/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: chpp
# Date created: 4 May 1999
-# Whom: Andrey Zakhvatov
+# Whom: Andrey Zakhvatov <andy@FreeBSD.org>
#
# $FreeBSD$
#
@@ -16,21 +16,22 @@ COMMENT= Non-intrusive full-featured text preprocessor
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
-EXAMPLES_DIR= ${PREFIX}/share/examples/chpp
INFO= chpp
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile"
+BROKEN= Does not compile
.endif
post-install:
- @${MKDIR} ${EXAMPLES_DIR}
+ @${MKDIR} ${EXAMPLESDIR}
${TAR} -C ${WRKSRC}/test -cf - . | \
- ${TAR} -C ${EXAMPLES_DIR} --unlink -xf -
- @${FIND} ${EXAMPLES_DIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- @${FIND} ${EXAMPLES_DIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+.if !defined(NOPORTEXAMPLES)
+ @${FIND} ${EXAMPLESDIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS NEWS README