aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/chpp/files
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-02 18:07:53 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-02 18:07:53 +0800
commita97dca42a31a6ca6361f6aebd86e16f4c96c1c98 (patch)
treee134599ab06225cdd3f0a68d6030abf39a2ef964 /textproc/chpp/files
parent2c5cf575b1b59d5460e03ceb7514ffeed6b8f928 (diff)
downloadfreebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.tar.gz
freebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.tar.zst
freebsd-ports-gnome-a97dca42a31a6ca6361f6aebd86e16f4c96c1c98.zip
- Fix the build with modern GCC [1]
- Clean up Makefile, pacify portlint(1) - Use our standard FOOBARDIR macros in pkg-plist - Minor pkg-descr nit Reported by: pointyhat (logs) [1]
Diffstat (limited to 'textproc/chpp/files')
-rw-r--r--textproc/chpp/files/patch-avl.h15
1 files changed, 15 insertions, 0 deletions
diff --git a/textproc/chpp/files/patch-avl.h b/textproc/chpp/files/patch-avl.h
new file mode 100644
index 000000000000..f9dbd16110b5
--- /dev/null
+++ b/textproc/chpp/files/patch-avl.h
@@ -0,0 +1,15 @@
+--- avl.h.orig Thu Oct 29 02:25:09 1998
++++ avl.h Mon Jul 2 16:47:44 2007
+@@ -44,7 +44,11 @@
+ } avlTree;
+
+ #define AVL_LINK(a,N) (((a) == -1) ? (N)->left : (N)->right)
+-#define AVL_LINK_SET(s,P,V) ((((s) == -1) ? (P)->left : (P)->right) = (V))
++#define AVL_LINK_SET(s,P,V) \
++ do { \
++ typeof (V) foo = (((s) == -1) ? (P)->left : (P)->right); \
++ foo = (V); \
++ } while (0)
+
+ int avlCompare (avlTree*, void*, unsigned int, avlNode*);
+ int avlBalance (avlNode*, int, avlNode**);