aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/coco/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-04-23 18:35:35 +0800
committerasami <asami@FreeBSD.org>1995-04-23 18:35:35 +0800
commit4749c5a99a2230210bfa18b700f7a274a7cc5d71 (patch)
treee96f967a7eb549ba50d0f08d27210d280bf2ff5d /textproc/coco/Makefile
parentf8b8db15068fca9815a7576e6a00e150ba1d5cdb (diff)
downloadfreebsd-ports-gnome-4749c5a99a2230210bfa18b700f7a274a7cc5d71.tar.gz
freebsd-ports-gnome-4749c5a99a2230210bfa18b700f7a274a7cc5d71.tar.zst
freebsd-ports-gnome-4749c5a99a2230210bfa18b700f7a274a7cc5d71.zip
Since thud was down all day (no offense Gary :), I finally had time to
split mule into three ports: editors/mule: no language-specific support japanese/mule-canna: Japanese support, Canna library built-in japanese/mule-wnn: Japanese support, Wnn library built-in Note that the two ports under japanese/ will overwrite some of the emacs support files. Although this itself isn't a problem, if you pkg_delete it, you will lose some files needed for emacs. (This is explained in DESCR, although god knows who reads them.) Also I've listed every single file in the PLIST.
Diffstat (limited to 'textproc/coco/Makefile')
-rw-r--r--textproc/coco/Makefile39
1 files changed, 18 insertions, 21 deletions
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index 69ffc4db5b93..b1e41c39d33e 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -3,35 +3,29 @@
# Date created: 22 November 1994
# Whom: Satoshi Asami (asami)
#
-# $Id: Makefile,v 1.16 1995/04/20 18:23:06 asami Exp $
+# $Id: Makefile,v 1.17 1995/04/22 12:39:19 asami Exp $
#
-DISTNAME= mule-2.2.2
+DISTNAME= mule-2.2
+PKGNAME= mule-2.2.2
CATEGORIES+= editors
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-DISTFILES= emacs-19.28.tar.gz
-
-# Use one of these if you are in Japan
-
-# PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
-# PATCHSITE= etlport.etl.go.jp:/pub/mule/
-
-PATCH_SITES= ftp.cs.buffalo.edu:/pub/mule/
-PATCHFILES= diff-19.28-2.2.gz patch-2.2.1.gz patch-2.2.2.gz
+MASTER_SITES= ftp://ftp.cs.buffalo.edu/pub/mule/ \
+ ftp://etlport.etl.go.jp/pub/mule/ \
+ ftp://sh.wide.ad.jp/JAPAN/mule/
+
+PATCH_SITES= ftp://ftp.cs.buffalo.edu/pub/mule/ \
+ ftp://etlport.etl.go.jp/pub/mule/ \
+ ftp://sh.wide.ad.jp/JAPAN/mule/
+PATCHFILES= patch-2.2.1.gz patch-2.2.2.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= asami@FreeBSD.ORG
-.if !exists(/usr/X11R6/lib/libwnn.a)
-DEPENDS= ${PORTSDIR}/japanese/Wnn
-.endif
-
-WRKSRC= ${WRKDIR}/emacs-19.28
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
- --wnn --wnn-libraries=/usr/X11R6/lib \
- --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+ --terminal-face
+
STRIP=
pre-build:
@@ -39,9 +33,12 @@ pre-build:
post-install:
# note that any2ps is a script
- strip ${PREFIX}/bin/mule-19.28
- strip ${PREFIX}/bin/m2ps
strip ${PREFIX}/bin/b2m
strip ${PREFIX}/bin/coco
+ strip ${PREFIX}/bin/m2ps
+ strip ${PREFIX}/bin/mule-19.28
+ gzip -9nf ${PREFIX}/man/man1/coco.1
+ gzip -9nf ${PREFIX}/man/man1/m2ps.1
+ gzip -9nf ${PREFIX}/man/man1/mule.1
.include <bsd.port.mk>