aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/code2html/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-08-16 04:33:16 +0800
committerknu <knu@FreeBSD.org>2001-08-16 04:33:16 +0800
commit58124457c3a6dd7117d6d4f3f81c0205ff4c0695 (patch)
tree2bac886c1008a0d4900a2204268e6fef08c43c02 /textproc/code2html/Makefile
parent01f54590915661a5f168e052c9c17d8b4ee4e09d (diff)
downloadfreebsd-ports-gnome-58124457c3a6dd7117d6d4f3f81c0205ff4c0695.tar.gz
freebsd-ports-gnome-58124457c3a6dd7117d6d4f3f81c0205ff4c0695.tar.zst
freebsd-ports-gnome-58124457c3a6dd7117d6d4f3f81c0205ff4c0695.zip
Conditionalize bzip2 dependencies.
Diffstat (limited to 'textproc/code2html/Makefile')
-rw-r--r--textproc/code2html/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/textproc/code2html/Makefile b/textproc/code2html/Makefile
index 9226c15c9ca6..2601f45eeed3 100644
--- a/textproc/code2html/Makefile
+++ b/textproc/code2html/Makefile
@@ -14,15 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jedgar@FreeBSD.org
+.if !exists(/usr/bin/bzip2)
RUN_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+BZIP2BASE= ${PREFIX}
+.else
+BZIP2BASE= /usr
+.endif
+
NO_BUILD= yes
MAN1= code2html.1
do-configure:
@${MV} ${WRKSRC}/code2html ${WRKSRC}/code2html.orig
- @${SED} -e 's|/usr/bin/bzip2|${PREFIX}/bin/bzip2|' \
+ @${SED} -e 's|/usr/bin/bzip2|${BZIP2BASE}/bin/bzip2|' \
-e 's|/bin/gzip|/usr/bin/gzip|' \
-e 's|/etc/code|${PREFIX}/etc/code|' \
< ${WRKSRC}/code2html.orig > ${WRKSRC}/code2html