aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/csv2latex
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-05-19 16:32:37 +0800
committerijliao <ijliao@FreeBSD.org>2003-05-19 16:32:37 +0800
commit39b3737c67466ab3ab098f6418c22e35f2af1926 (patch)
tree0565aca156ce85a8a30e881e852faaa1a8640890 /textproc/csv2latex
parent1188d3b7838c4527826005769e84df05dfcfb4fe (diff)
downloadfreebsd-ports-gnome-39b3737c67466ab3ab098f6418c22e35f2af1926.tar.gz
freebsd-ports-gnome-39b3737c67466ab3ab098f6418c22e35f2af1926.tar.zst
freebsd-ports-gnome-39b3737c67466ab3ab098f6418c22e35f2af1926.zip
add csv2latex 20030501
Converts a well formed csv file to a LaTeX document
Diffstat (limited to 'textproc/csv2latex')
-rw-r--r--textproc/csv2latex/Makefile32
-rw-r--r--textproc/csv2latex/distinfo1
-rw-r--r--textproc/csv2latex/pkg-descr4
-rw-r--r--textproc/csv2latex/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/csv2latex/Makefile b/textproc/csv2latex/Makefile
new file mode 100644
index 000000000000..6f0caf9998c2
--- /dev/null
+++ b/textproc/csv2latex/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: csv2latex
+# Date created: May 19, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= csv2latex
+PORTVERSION= 20030501
+CATEGORIES= textproc
+MASTER_SITES= http://brouits.free.fr/share/utils/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Converts a well formed csv file to a LaTeX document
+
+USE_GETOPT_LONG= yes
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= #
+EXTRACT_AFTER_ARGS= .
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${CC} ${CPPFLAGS} -o ${PORTNAME} ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/csv2latex/distinfo b/textproc/csv2latex/distinfo
new file mode 100644
index 000000000000..ebf680c913dc
--- /dev/null
+++ b/textproc/csv2latex/distinfo
@@ -0,0 +1 @@
+MD5 (csv2latex.c) = d334bf0c814e1e8c76416b495fbe71eb
diff --git a/textproc/csv2latex/pkg-descr b/textproc/csv2latex/pkg-descr
new file mode 100644
index 000000000000..fc92cebf95fe
--- /dev/null
+++ b/textproc/csv2latex/pkg-descr
@@ -0,0 +1,4 @@
+csv2latex converts a well formed csv file (as done by OpenOffice.org) to
+a LaTeX document.
+
+WWW: http://brouits.free.fr/csv2latex/
diff --git a/textproc/csv2latex/pkg-plist b/textproc/csv2latex/pkg-plist
new file mode 100644
index 000000000000..9c31a41eb805
--- /dev/null
+++ b/textproc/csv2latex/pkg-plist
@@ -0,0 +1 @@
+bin/csv2latex