aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/dblatex/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-26 19:19:33 +0800
committermiwi <miwi@FreeBSD.org>2007-02-26 19:19:33 +0800
commitb16c25f6442513787db26e297e0522fe7e637180 (patch)
treed2c733a8a3802484ec0a46ae6bd3ff6dd06a61ae /textproc/dblatex/Makefile
parentb971fc66819f8aa0409eb3acc0604cec285e3759 (diff)
downloadfreebsd-ports-gnome-b16c25f6442513787db26e297e0522fe7e637180.tar.gz
freebsd-ports-gnome-b16c25f6442513787db26e297e0522fe7e637180.tar.zst
freebsd-ports-gnome-b16c25f6442513787db26e297e0522fe7e637180.zip
Dblatex started as a DB2LaTeX clone. So, why this project? The purpose
is a bit different on these points: (1) The project is end-user oriented, that is, it tries to hide as much as possible the latex compiling stuff by providing a single clean script to produce directly DVI, PostScript and PDF output. (2) The actual output rendering is done not only by the XSL stylesheets transformation, but also by a dedicated LaTeX package. The purpose is to allow a deep LaTeX customisation without changing the XSL stylesheets. (3) Post-processing is done by Python, to make publication faster, convert the images if needed, and do the whole compilation. WWW: http://dblatex.sourceforge.net/ PR: ports/109520 Submitted by: Peter Johnson <johnson.peter at gmail.com>
Diffstat (limited to 'textproc/dblatex/Makefile')
-rw-r--r--textproc/dblatex/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/dblatex/Makefile b/textproc/dblatex/Makefile
new file mode 100644
index 000000000000..9ae1a55141f2
--- /dev/null
+++ b/textproc/dblatex/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: dblatex
+# Date created: 2007-02-25
+# Whom: Peter Johnson <johnson.peter@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dblatex
+PORTVERSION= 0.2.4
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= johnson.peter@gmail.com
+COMMENT= DocBook to LaTeX/ConTeXt Publishing
+
+RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xml/docbook/4.2/docbook.cat:${PORTSDIR}/textproc/docbook-xml \
+ etex:${PORTSDIR}/print/teTeX-base
+
+USE_BZIP2= yes
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS=yes
+PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} \
+ --catalogs=${PREFIX}/share/xml/catalog.ports
+
+PORTDOCS= manual.pdf
+
+MAN1= dblatex.1
+MANCOMPRESSED= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,share/man/man1,man/man1,g" ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>