aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/docbook-sk
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-04 16:53:10 +0800
committermarcus <marcus@FreeBSD.org>2003-11-04 16:53:10 +0800
commit2305cc21296832adba523121f8ffbeee642ba35a (patch)
treed3b3bcb0b533f170f533a92ee7108f52338d0388 /textproc/docbook-sk
parenta2bf55ce5c66adf781398a3fb0cab9c8c3e9e6b0 (diff)
downloadfreebsd-ports-gnome-2305cc21296832adba523121f8ffbeee642ba35a.tar.gz
freebsd-ports-gnome-2305cc21296832adba523121f8ffbeee642ba35a.tar.zst
freebsd-ports-gnome-2305cc21296832adba523121f8ffbeee642ba35a.zip
Convert scrollkeeper over to use the system catalog location. This helps
to unbreak gtk-doc as well as removes a ton of gross hacks to support the old location. Also, import some CVS patches from SK to fix some potential crashes when installing bad catalogs. While I tested this with a full SK database rebuild, problems may still occur. Please let me know if you encounter any issues with OMF files after this commit.
Diffstat (limited to 'textproc/docbook-sk')
-rw-r--r--textproc/docbook-sk/Makefile18
-rw-r--r--textproc/docbook-sk/pkg-plist76
2 files changed, 56 insertions, 38 deletions
diff --git a/textproc/docbook-sk/Makefile b/textproc/docbook-sk/Makefile
index dc1eed081c3c..3f91c8d50e89 100644
--- a/textproc/docbook-sk/Makefile
+++ b/textproc/docbook-sk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= docbook-sk
PORTVERSION= 4.1.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.docbook.org/xml/${PORTVERSION}/
DISTNAME= docbkx${PORTVERSION:S/.//g}
@@ -14,12 +15,21 @@ DISTNAME= docbkx${PORTVERSION:S/.//g}
MAINTAINER= gnome@FreeBSD.org
COMMENT= XML version of the DocBook DTD version controlled for ScrollKeeper
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_SUB= DTD_VERSION=${PORTVERSION}
+PLIST_SUB= DTD_VERSION=${PORTVERSION} \
+ XMLCATMGR=${XMLCATMGR} \
+ DOCBOOKDIR=${DOCBOOKDIR} \
+ CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML} \
+ CATALOG_PORTS_XML=${CATALOG_PORTS_XML}
-DOCBOOKDIR= ${PREFIX}/share/sk/${PORTNAME:S/-sk//}/${PORTVERSION}
+DOCBOOKDIR= ${PREFIX}/share/xml/${PORTNAME:S/-sk//}/${PORTVERSION}
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+CATALOG_PORTS_XML= ${PREFIX}/share/xml/catalog.ports
pre-install:
@[ -d ${DOCBOOKDIR}/ent ] || ${MKDIR} ${DOCBOOKDIR}/ent
@@ -29,4 +39,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/$$file ${DOCBOOKDIR}/$$file; \
done
+post-install:
+ @${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${DOCBOOKDIR}/docbook.cat
+ @${XMLCATMGR} -c ${CATALOG_PORTS_XML} add nextCatalog ${DOCBOOKDIR}/catalog.xml
+
.include <bsd.port.mk>
diff --git a/textproc/docbook-sk/pkg-plist b/textproc/docbook-sk/pkg-plist
index ebed68f3e469..2ee29f6034ba 100644
--- a/textproc/docbook-sk/pkg-plist
+++ b/textproc/docbook-sk/pkg-plist
@@ -1,36 +1,40 @@
-share/sk/docbook/%%DTD_VERSION%%/40chg.txt
-share/sk/docbook/%%DTD_VERSION%%/41chg.txt
-share/sk/docbook/%%DTD_VERSION%%/ChangeLog
-share/sk/docbook/%%DTD_VERSION%%/calstblx.dtd
-share/sk/docbook/%%DTD_VERSION%%/dbcentx.mod
-share/sk/docbook/%%DTD_VERSION%%/dbgenent.mod
-share/sk/docbook/%%DTD_VERSION%%/dbhierx.mod
-share/sk/docbook/%%DTD_VERSION%%/dbnotnx.mod
-share/sk/docbook/%%DTD_VERSION%%/dbpoolx.mod
-share/sk/docbook/%%DTD_VERSION%%/docbook.cat
-share/sk/docbook/%%DTD_VERSION%%/docbookx.dtd
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amsa.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amsb.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amsc.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amsn.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amso.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-amsr.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-box.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-cyr1.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-cyr2.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-dia.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-grk1.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-grk2.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-grk3.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-grk4.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-lat1.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-lat2.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-num.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-pub.ent
-share/sk/docbook/%%DTD_VERSION%%/ent/iso-tech.ent
-share/sk/docbook/%%DTD_VERSION%%/readme.txt
-share/sk/docbook/%%DTD_VERSION%%/soextblx.dtd
-@dirrm share/sk/docbook/%%DTD_VERSION%%/ent
-@dirrm share/sk/docbook/%%DTD_VERSION%%
-@dirrm share/sk/docbook
-@dirrm share/sk
+share/xml/docbook/%%DTD_VERSION%%/40chg.txt
+share/xml/docbook/%%DTD_VERSION%%/41chg.txt
+share/xml/docbook/%%DTD_VERSION%%/ChangeLog
+share/xml/docbook/%%DTD_VERSION%%/calstblx.dtd
+@unexec %%XMLCATMGR%% -c %%CATALOG_PORTS_XML%% remove %%DOCBOOKDIR%%/catalog.xmlshare/xml/docbook/%%DTD_VERSION%%/catalog.xml
+@exec %%XMLCATMGR%% -c %%CATALOG_PORTS_XML%% add nextCatalog %%DOCBOOKDIR%%/catalog.xml
+share/xml/docbook/%%DTD_VERSION%%/dbcentx.mod
+share/xml/docbook/%%DTD_VERSION%%/dbgenent.mod
+share/xml/docbook/%%DTD_VERSION%%/dbhierx.mod
+share/xml/docbook/%%DTD_VERSION%%/dbnotnx.mod
+share/xml/docbook/%%DTD_VERSION%%/dbpoolx.mod
+@unexec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% remove %%DOCBOOKDIR%%/docbook.cat
+share/xml/docbook/%%DTD_VERSION%%/docbook.cat
+@exec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% add CATALOG %%DOCBOOKDIR%%/docbook.cat
+share/xml/docbook/%%DTD_VERSION%%/docbookx.dtd
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amsa.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amsb.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amsc.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amsn.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amso.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-amsr.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-box.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-cyr1.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-cyr2.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-dia.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-grk1.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-grk2.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-grk3.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-grk4.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-lat1.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-lat2.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-num.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-pub.ent
+share/xml/docbook/%%DTD_VERSION%%/ent/iso-tech.ent
+share/xml/docbook/%%DTD_VERSION%%/readme.txt
+share/xml/docbook/%%DTD_VERSION%%/soextblx.dtd
+@dirrm share/xml/docbook/%%DTD_VERSION%%/ent
+@dirrm share/xml/docbook/%%DTD_VERSION%%
+@unexec /bin/rmdir %D/share/xml/docbook 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/share/xml 2>/dev/null || /usr/bin/true