aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/docbook-xsl/Makefile
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2003-12-16 07:06:12 +0800
committerdes <des@FreeBSD.org>2003-12-16 07:06:12 +0800
commitfe856aabbc8a0d1a603bb54b4c8dca2188e9eb08 (patch)
treea49f30dd5a451116ecabddfc58574fce7d0b3373 /textproc/docbook-xsl/Makefile
parenteb5f20b485497aeb8f60fd31b5eb8b7f31a8a88e (diff)
downloadfreebsd-ports-gnome-fe856aabbc8a0d1a603bb54b4c8dca2188e9eb08.tar.gz
freebsd-ports-gnome-fe856aabbc8a0d1a603bb54b4c8dca2188e9eb08.tar.zst
freebsd-ports-gnome-fe856aabbc8a0d1a603bb54b4c8dca2188e9eb08.zip
Upgrade to 1.63.0, and tidy up a little.
Diffstat (limited to 'textproc/docbook-xsl/Makefile')
-rw-r--r--textproc/docbook-xsl/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/textproc/docbook-xsl/Makefile b/textproc/docbook-xsl/Makefile
index a1d675d8cc60..7cc5ff7e71e6 100644
--- a/textproc/docbook-xsl/Makefile
+++ b/textproc/docbook-xsl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= docbook-xsl
-PORTVERSION= 1.62.4
+PORTVERSION= 1.63.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= docbook
@@ -22,8 +22,8 @@ INSTDIR= share/xsl/docbook
PINSTDIR= ${PREFIX}/${INSTDIR}
COPYDIRS= common fo extensions html htmlhelp images \
javahelp lib manpages params template xhtml
-PKGINSTALL= ${WRKSRC}/pkg-install
-PKGDEINSTALL= ${WRKSRC}/pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
NO_BUILD= yes
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
@@ -32,6 +32,14 @@ CATALOG_PORTS= ${XMLDIR}/catalog.ports
post-extract:
${FIND} ${WRKSRC} -name '.#*' -delete
+post-configure:
+ @${SED} -e 's,@INSTDIR@,${INSTDIR},g ; \
+ s,@XMLCATMGR@,${XMLCATMGR},g ; \
+ s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
+ < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
+ @${SED} -e 's,@XMLCATMGR@,${XMLCATMGR},g ; \
+ s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
+ < ${FILESDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
do-install:
.ifndef NOPORTDOCS
${MKDIR} ${DOCSDIR}
@@ -43,14 +51,7 @@ do-install:
${TAR} -xf - -C${PINSTDIR})
post-install:
- @${SED} -e 's,@INSTDIR@,${INSTDIR},g ; \
- s,@XMLCATMGR@,${XMLCATMGR},g ; \
- s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
- < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
- @${SED} -e 's,@XMLCATMGR@,${XMLCATMGR},g ; \
- s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
- < ${FILESDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${ENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>