aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/docproj
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2004-08-21 01:34:16 +0800
committerhrs <hrs@FreeBSD.org>2004-08-21 01:34:16 +0800
commit74c774ae6d36fe3f0cff5fa2d4640000e92ec021 (patch)
tree6ffe7dafeed0ecdf3bc50d7e28a44c6122f16b8c /textproc/docproj
parentc18696b0c7291ab64ac4049947643cf13f06421f (diff)
downloadfreebsd-ports-gnome-74c774ae6d36fe3f0cff5fa2d4640000e92ec021.tar.gz
freebsd-ports-gnome-74c774ae6d36fe3f0cff5fa2d4640000e92ec021.tar.zst
freebsd-ports-gnome-74c774ae6d36fe3f0cff5fa2d4640000e92ec021.zip
- Fix dependencies.
- Use WITH_JADETEX instead of JADETEX. - Use USE_GHOSTSCRIPT. Reviewed by: doceng
Diffstat (limited to 'textproc/docproj')
-rw-r--r--textproc/docproj/Makefile81
-rw-r--r--textproc/docproj/files/JADETEX12
-rw-r--r--textproc/docproj/pkg-plist1
3 files changed, 57 insertions, 37 deletions
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 0710323d1737..485134c8ac3e 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= docproj
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= textproc
MASTER_SITES= # empty
DISTFILES= # empty
+EXTRACT_ONLY= # empty
MAINTAINER= doceng@freebsd.org
COMMENT= The "meta-port" for the FreeBSD Documentation Project
@@ -17,48 +18,68 @@ COMMENT= The "meta-port" for the FreeBSD Documentation Project
# This dependency list should be kept in sync with the list of
# required ports in src/release/Makefile.inc.docports.
-RUN_DEPENDS= instant:${PORTSDIR}/textproc/sgmlformat \
+RUN_DEPENDS= links:${PORTSDIR}/www/links1 \
+ pngtopnm:${PORTSDIR}/graphics/netpbm \
+ scr2png:${PORTSDIR}/graphics/scr2png \
+ scr2txt:${PORTSDIR}/textproc/scr2txt \
tidy:${PORTSDIR}/www/tidy \
- ${PREFIX}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
- ${PREFIX}/share/sgml/html/catalog:${PORTSDIR}/textproc/html \
- ${PREFIX}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
- ${PREFIX}/share/sgml/docbook/4.1/docbook.dtd:${PORTSDIR}/textproc/docbook-410 \
- ${PREFIX}/share/sgml/iso8879:${PORTSDIR}/textproc/iso8879 \
- ${PREFIX}/share/xml/dtd/xhtml/xhtml.soc:${PORTSDIR}/textproc/xhtml \
- ${PREFIX}/bin/peps:${PORTSDIR}/graphics/peps \
- ${PREFIX}/bin/pngtopnm:${PORTSDIR}/graphics/netpbm \
- ${PREFIX}/bin/links:${PORTSDIR}/www/links1 \
- ${PREFIX}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
- ${PREFIX}/bin/scr2png:${PORTSDIR}/graphics/scr2png \
- ${PREFIX}/bin/scr2txt:${PORTSDIR}/textproc/scr2txt \
- ${PREFIX}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
- ${PREFIX}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
-
-.if defined(WITH_OPENJADE) || ${MACHINE_ARCH} != "i386"
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/sgml/docbook/dsssl/modular:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ ${LOCALBASE}/share/sgml/html/catalog:${PORTSDIR}/textproc/html \
+ ${LOCALBASE}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
+ ${LOCALBASE}/share/sgml/docbook/4.1/docbook.dtd:${PORTSDIR}/textproc/docbook-410 \
+ ${LOCALBASE}/share/sgml/iso8879:${PORTSDIR}/textproc/iso8879 \
+ ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:${PORTSDIR}/textproc/xhtml \
+ ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENJADE) || ${ARCH} != "i386"
RUN_DEPENDS+= openjade:${PORTSDIR}/textproc/openjade
.else
RUN_DEPENDS+= jade:${PORTSDIR}/textproc/jade
.endif
-.if !defined(JADETEX)
-IS_INTERACTIVE= "user must set JADETEX variable to 'yes' or 'no'"
+.if defined(JADETEX)
+WITH_JADETEX= ${JADETEX}
.endif
+WITH_JADETEX?=
+
+.if defined(WITH_JADETEX) && ${WITH_JADETEX} == yes
+RUN_DEPENDS+= ${LOCALBASE}/share/texmf/web2c/jadetex.fmt:${PORTSDIR}/print/jadetex
+.endif
+
+NO_BUILD= yes
+USE_GHOSTSCRIPT= yes
+PLIST_FILES= #empty
-JADETEX?=
+WITHOUT_X11= yes
+DEPENDS_ARGS+= BATCH=yes WITHOUT_X11=${WITHOUT_X11}
-.if empty(JADETEX) && (make(build) || make(install))
-.BEGIN:
+IS_INTERACTIVE= "user must set WITH_JADETEX variable to 'yes' or 'no'"
+
+message-jadetex:
@${CAT} ${FILESDIR}/JADETEX
@${FALSE}
-.endif
+message-gs:
+ @${ECHO_MSG} "NOTICE: Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one."
+ @${ECHO_MSG} ""
-.if ${JADETEX} == yes
-RUN_DEPENDS+= ${PREFIX}/share/texmf/web2c/jadetex.fmt:${PORTSDIR}/print/jadetex
-.endif
+# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.
+# (XXX: incomplete yet)
+minimaldocports:
+ @${ECHO_CMD} "MINIMALDOCPORTS= \\"
+ @${MAKE} all-depends-list | ${SED} -e 's,^${PORTSDIR}/, ,' -e 's,$$, \\,'
-EXTRACT_ONLY= # empty
-NO_BUILD= yes
+.if empty(WITH_JADETEX) && !make(deinstall)
+pre-everything:: message-jadetex
+.endif
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+pre-everything:: message-gs
+.endif
do-install: # empty
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/docproj/files/JADETEX b/textproc/docproj/files/JADETEX
index f2f7379f5536..f040c4a8cf4f 100644
--- a/textproc/docproj/files/JADETEX
+++ b/textproc/docproj/files/JADETEX
@@ -2,16 +2,16 @@ This port will try and ensure that the tools used by the FreeBSD
Documentation Project are installed on your system so you can convert
documentation from SGML to other formats.
-One of these components is JadeTeX, which depends on TeTeX. The source
-for TeTeX is larger than 30MB, and may be a very long download for you.
+One of these components is JadeTeX, which depends on teTeX. The source
+for teTeX is larger than 30MB, and may be a very long download for you.
If you do not want to produce PostScript and PDF formats from the
documentation then you do not need JadeTeX, and you should set the
-variable "JADETEX" to "no". If you do want to produce PostScript and
-PDF output then set "JADETEX" to yes.
+variable "WITH_JADETEX" to "no". If you do want to produce PostScript and
+PDF output then set "WITH_JADETEX" to yes.
For example;
- make JADETEX=no
- make JADETEX=yes
+ make WITH_JADETEX=no
+ make WITH_JADETEX=yes
diff --git a/textproc/docproj/pkg-plist b/textproc/docproj/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/textproc/docproj/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty
es #40727 ] if the query text is either shorter than the cachedChris Toshok2003-04-091-5/+9 * kill an old e_utf8_gtk usageMike Kestner2003-04-091-1/+0 * Remove color specifications from the druid so it will use theme colors.Dan Winship2003-04-082-30/+8 * [ fixes #7103 ] init style_set. and add the signal.Chris Toshok2003-04-085-97/+152 * [ fixes bug #40901 ] HIG-ify the ldap server edit dialog's button layout.Chris Toshok2003-04-081-13/+13 * [ fixes bug #39763 ] verb callback for EditCopy (cut_cb): verb callbackChris Toshok2003-04-081-0/+160 * change the ok/cancel button layout to be higified.Chris Toshok2003-04-081-5/+11 * [ last portion of #40046 fix ] ifdef this out to quiet the compiler.Chris Toshok2003-04-081-141/+35 * Clean up server names.Dan Winship2003-04-082-19/+17 * set "handle_popup" on the field to be TRUE if it's got focus, FALSE ifChris Toshok2003-04-041-0/+5 * set the im_context on the field's EText. (e_minicard_label_event): removeChris Toshok2003-04-041-46/+1 * [ fixes bug #40715 ] add this callback, to unref the book/free the closureChris Toshok2003-04-043-20/+39 * add EVOLUTION_IMAGESDIRChris Toshok2003-04-031-0/+3 * change all this around so that we populate the existing popup. This meansChris Toshok2003-04-033-179/+122 * add NONE:OBJECTChris Toshok2003-04-033-0/+23 * Remove folder-selector button initialization. (e_select_names_new):Dan Winship2003-03-315-61/+63 * [ fixes bug #39381 (again) ] add "GtkWidget *button" first arg, so weChris Toshok2003-03-311-1/+1 * [ fix the contact editor so that the only time the address is parsed isChris Toshok2003-03-291-36/+30 * [ fixes bug #34651 ] strcmp -> g_utf8_collate. (update_query): encode theChris Toshok2003-03-271-6/+13 * [ fixes bug #34085 ] only successfully complete the drag if they dropped aChris Toshok2003-03-271-11/+17 * $evolution_uidir -> $evolutionuidirChris Toshok2003-03-271-1/+1 * set the dialog to "Visible: No" so it doesn't flash when we bring it up.Chris Toshok2003-03-241-254/+289 * [ fixes bug #40026 ] add EContactEditor arg, and block/unblock signalsChris Toshok2003-03-241-9/+16 * nuke.Chris Toshok2003-03-244-49/+73 * [ fixes bug #31786 ] fix some gtk warnings. (set_advanced_button_state):Chris Toshok2003-03-242-3248/+23 * [ fixes bug #32113 ] add include_email arg to e_destination_get_textrep.Chris Toshok2003-03-236-12/+12 * up the column count by one for the underline.Chris Toshok2003-03-191-1/+5 * fix use of deprecated gtk_menu_append. (card_picker_selection_changed):Chris Toshok2003-03-191-54/+31 * [ Fixes addressbook bug #39730 ] add response ids to the search baseChris Toshok2003-03-192-55/+28 * use alternating-row-colors="false"Chris Toshok2003-03-193-61/+24 * disconnect/keep track of search result signal id. (e_select_names_init):Not Zed2003-03-182-5/+28 * use set_entry_changed_signal_email for the email entry so the email getsChris Toshok2003-03-141-1/+10 * [ fixes bug #20210 ] change "Edit Contact Info" to "View Contact Info", asChris Toshok2003-03-131-2/+2 * [ fixes bug #39507 ] new function, sync the models after we do a search.Chris Toshok2003-03-121-0/+12 * fix compiler warnings about deprecated functions.Chris Toshok2003-03-125-77/+41 * re-enable in build, include e-destination.h. For #39256.Not Zed2003-03-101-2/+1 * Likewise. Likewise. Likewise. Likewise. Likewise. (ebook_create):Ettore Perazzoli2003-03-075-7/+6 * removed. (owner_unset_cb): Basically a noop, the shell does the quit, weNot Zed2003-03-051-10/+3 * Fixes #37881JP Rosevear2003-03-051-1/+1 * reflect prior column additionJP Rosevear2003-03-053-2/+3 * (e_select_names_new): Don't set the "modal" property throughEttore Perazzoli2003-03-041-1/+3 * (create_minicard_view): No needEttore Perazzoli2003-03-041-5/+1 * (e_select_names_init): Instead of using gtk_widget_unparent(),Ettore Perazzoli2003-03-041-2/+2 * Build libecontacteditor as an uninstalled shared library.Dan Winship2003-03-016-21/+21 * Remove these from here; talking to the mailer doesn't really belong at theDan Winship2003-03-017-8/+314 * use g_signal_connect here, not swapped... although since we pass theChris Toshok2003-02-285-10/+26 * if we fail to activate factories for a given protocol, return.Chris Toshok2003-02-271-62/+14 * Make libversit a shared library, update stuff for that, and clean upDan Winship2003-02-223-21/+5 * Make libemiscwidgets, libefilterbar, and libetimezonedialog dynamicDan Winship2003-02-212-5/+5 * revert previous changeDan Winship2003-02-206-20/+20 * oopsDan Winship2003-02-201-1/+1 * Build the subparts as (noinst) shared libraries rather than staticDan Winship2003-02-206-19/+19 * Make parent_class static.Dan Winship2003-02-203-3/+3 * ignore more generated stuffChris Toshok2003-02-201-0/+1 * [ fix #38074 ] first arg is a GtkWidget. duh.Chris Toshok2003-02-201-1/+1 * (INCLUDES): Use $(evolutionuidir)Ettore Perazzoli2003-02-201-1/+1 * if we can complete solely from our cached cards, callChris Toshok2003-02-181-0/+8 * plug memory leak (always free val).Chris Toshok2003-02-171-2/+2 * indent properly.Chris Toshok2003-02-171-12/+12 * disconnect search_started and search_result. (addressbook_compare): ifChris Toshok2003-02-173-55/+98 * [ fixes bug #33066 ] new function (set_entry_changed_signals): callChris Toshok2003-02-112-46/+74 * gone. (match_initials): gone. (book_query_sexp): remove the primaryChris Toshok2003-02-101-47/+17 * lots of changes here. should be a big performance gain. god i hope this isChris Toshok2003-02-101-228/+104 * [ huge change, all for 1 little performance problem :) fixes #18207 ] useChris Toshok2003-02-084-59/+69 * check the status, not the book, and unref the book here.Chris Toshok2003-02-076-61/+39 * Use different tmp file names so these rules can be executed in parallelEttore Perazzoli2003-02-071-5/+6 * s/PACKAGE/GETTEXT_PACKAGE/ in gettext initDan Winship2003-02-071-2/+2 * Remove cruft, rename ICONSDIR to IMAGESDIR. (serverdir, gladedir): RemoveDan Winship2003-02-064-35/+29 * Remove cruft. (serverdir, gladedir, etspecdir): Remove definitionsDan Winship2003-02-064-10/+2 * Remove cruft. (gladedir, etspecdir): Remove definitions. (glade_DATA):Dan Winship2003-02-067-31/+30 * Remove cruft. Define in terms of privdatadirDan Winship2003-02-062-3/+1 * Remove cruft, s/ICONSDIR/IMAGESDIR/ (gladedir, etspecdir): RemoveDan Winship2003-02-063-12/+7 * Remove some cruft. rename ICONSDIR to IMAGESDIR. (images_DATA): InstallDan Winship2003-02-065-32/+22 * Replace deprecated glade_gnome_init() with glade_init().Dan Winship2003-02-062-2/+2 * updated for e scroll frame --> gtk scrolled windowRadek Doulik2003-02-052-10/+10 * [ pull forward Jack Jia's fix for #34900 ] use a weak ref for the fileChris Toshok2003-02-041-9/+4 * pull forward Jack Jia's fix for #33672, but convert it to use unlinkChris Toshok2003-02-041-13/+16 * add a scrolled window (SHADOW_IN) around the address textview.Chris Toshok2003-01-281-25/+36 * rename the category entry to entry-categories.Chris Toshok2003-01-272-3/+13 * i need to sleep more.Chris Toshok2003-01-261-1/+0 * need to assign this here or else the lib doesn't get built.Chris Toshok2003-01-261-0/+1 * Remove definition; this is now in configure.in. Likewise. Likewise.Ettore Perazzoli2003-01-253-4/+0 * [ fixes bug #34898 ] handle modifications to email addresses in contactSean Gao2003-01-241-0/+27 * Remove definition; no need to set it here since it's now defined inEttore Perazzoli2003-01-241-1/+0 * Define componentdir instead of COMPONENT_DIR. Set it toEttore Perazzoli2003-01-241-2/+0 * Version using $(BASE_VERSION). (etspecdir): Likewise. (iconsdir):Ettore Perazzoli2003-01-2311-109/+109 * applied patch from Frederic Crozat <fcrozat@mandrakesoft.com>Radek Doulik2003-01-221-18/+18 * Change dialog from Yes/No/Cancel to Discard/Cancel/Save to match the HIG.Ettore Perazzoli2003-01-159-14/+14 * Add $(schema_DATA).Ettore Perazzoli2003-01-151-3/+4 * try to load the uri again if it failed previously. (book_open_cb): setChris Toshok2003-01-101-2/+27 * #include gtklabel.h, fixes an unresolved symbol.Chris Toshok2003-01-101-0/+1 * call e_select_names_bonobo_construct on the newly created object.Chris Toshok2003-01-101-0/+2 * addressbook-config.etspec is gone.Chris Toshok2003-01-104-6353/+5991 * fix parameter types here (this signal isn't generated from an ETable.)Chris Toshok2003-01-105-1/+5 * remove the select names stuff (the Related Contacts button/entry.)Chris Toshok2003-01-103-2537/+2285 * comment out the factory oaf_server, and change the location of theChris Toshok2003-01-103-6/+18 * oops, don't include e-treeview-selection-model.h unless we're building theChris Toshok2003-01-091-1/+1 * add in the schema entry for minimum_query_length.Chris Toshok2003-01-091-0/+11 * add E_ADDRESSBOOK_VIEW_TREEVIEW to the enum, ifdef'ed out.Chris Toshok2003-01-093-18/+159 * add parent arg.Chris Toshok2003-01-097-1/+1063 * $(datadir)/evolution/images instead of $(datadir)/images/evolution.Ettore Perazzoli2003-01-094-22/+22 * remove idldir definition. (It's defined in configure.in now)Dan Winship2003-01-061-2/+0 * [ fixes the non-ui portion of #36183 ] use the entry'sChris Toshok2003-01-024-15/+47 * One more typoAndrew V. Samoilov2002-12-271-1/+1 * Typo fixedAndrew V. Samoilov2002-12-271-1/+1 * (addressbook_config_control_new): Made it return anEttore Perazzoli2002-12-202-2/+4 * [ fixes bug #34897 ] don't free the return of e_card_simple_get_const, asChris Toshok2002-12-191-1/+1 * convert the clist in here to a GtkTreeView. your guess is as good as mineChris Toshok2002-12-191-38/+62 * g_string_sprintfa -> g_string_append_printf. (create_alphabet): same.Chris Toshok2002-12-192-7/+7 * drop use of "font" arg. (get_left_width): use pango to calculate thisChris Toshok2002-12-1922-120/+114 * oops, use strcmp, not !strcmp here.Chris Toshok2002-12-181-1/+1 * (addressbook_config_control_new): UseEttore Perazzoli2002-12-171-1/+1 * Don't #include <e-util/e-html-utils.h>Jeffrey Stedfast2002-12-171-2/+0 * GObject-ize this.Chris Toshok2002-12-102-75/+51 * pass "Addressbook" to e_passwords*. (addressbook_authenticate): same.Chris Toshok2002-12-101-3/+3 * remove PENDING_PORT_WORK. (addressbook_search_activated): same.Chris Toshok2002-12-102-8/+1 * Forgot to commit this new file.Ettore Perazzoli2002-12-101-0/+67 * #define MINICARD_CONTROL_ID.Ettore Perazzoli2002-12-101-0/+3 * connect ::response to gtk_widget_destroy so the dialog goes away.Chris Toshok2002-12-092-4/+7 * this uses pango now. (addressbook_height): same.Chris Toshok2002-12-091-23/+12 * #include <string.h>.Ettore Perazzoli2002-12-0719-327/+92 * Use collate for sorting rather than the normal string sort. This fixes bugJeffrey Stedfast2002-12-061-1/+1 * gnomedialog -> gtkdialog stuff. print dialog is a gtkdialog now.Not Zed2002-12-023-3/+6 * the detail is supposed to go after the signal id, not at the end of theChris Toshok2002-11-301-1/+1 * [ roll forward from 1.2 branch, partial fix for #31763 ] add the FindChris Toshok2002-11-291-393/+422 * remove the button_press_event handler (that did nothing). this makes it soChris Toshok2002-11-291-9/+0 * add include for gtkstock.h.Chris Toshok2002-11-276-19/+31 * remove redundant setting of y2.Chris Toshok2002-11-275-13/+11 * use new schema for completion/uris. (uris_listener): same.Chris Toshok2002-11-275-77/+116 * ignore server.inChris Toshok2002-11-261-0/+1 * show the etable. (addressbook_add_server_druid): show_all before returningChris Toshok2002-11-251-1/+2 * [ roll forward from the 1.2 branch. fixes #25540, part of #29630, as wellChris Toshok2002-11-256-982/+1146 * roll forward the scope fix.Chris Toshok2002-11-211-1/+1 * roll forward the fix for the contact editor.Chris Toshok2002-11-211-0/+5 * Pass type to bonobo_ctonrol_set_property, and also NULL terminate theNot Zed2002-11-212-2/+2 * gui/component/select-names/GNOME_Evolution_Addressbook_SelectNames.server.Ettore Perazzoli2002-11-202-5/+7 * show the custom table.Chris Toshok2002-11-191-0/+1 * remove the cast to (int) - column_width is a double.Chris Toshok2002-11-193-11/+11 * oops, missed some "oaf"'s.Chris Toshok2002-11-181-1/+1 * sink the popup. (e_contact_editor_build_email_ui): same.Chris Toshok2002-11-172-0/+8 * ignore .server.inChris Toshok2002-11-171-0/+1 * Added rule to generate GNOME_Evolution_Addressbook.server.in fromEttore Perazzoli2002-11-165-507/+450 * Use bonobo_main_quitRodney Dawes2002-11-161-1/+1 * clean this up a tad.Chris Toshok2002-11-155-133/+28 * push_in = FALSE, no clue why... :) (_arrow_pressed): callChris Toshok2002-11-136-23/+20 * change signature to that of a weak ref notify function. (main): ::destroyChris Toshok2002-11-1218-609/+497 * change around a little, still ifdefed though.Chris Toshok2002-11-125-204/+57 * guard against multiple invocations. (remove_book_view): same.Chris Toshok2002-11-095-19/+41 * oops, missed these casts.Chris Toshok2002-11-093-10/+5 * port work.Chris Toshok2002-11-0915-347/+418 * parent class is GObjectClass.Chris Toshok2002-11-099-68/+140 * convert to glade-2Chris Toshok2002-11-084-297/+301 * port work.Chris Toshok2002-11-088-278/+233 * prepend /apps/Evolution to config db paths.Chris Toshok2002-11-081-3/+3 * more porting work.Chris Toshok2002-11-0812-3744/+3735 * add lots of libs back in since they're building now.Chris Toshok2002-11-089-138/+138