aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/elasticsearch5
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-12-02 20:01:12 +0800
committertj <tj@FreeBSD.org>2016-12-02 20:01:12 +0800
commitf12052ecbf190cc7c682c11d83faf94e9a8e5a8c (patch)
tree666ca3e26f5715f1281fcc7f648cc439a5ebf004 /textproc/elasticsearch5
parent8f4d478e0d67ed7e9570dc79cf876a62a43a852b (diff)
downloadfreebsd-ports-gnome-f12052ecbf190cc7c682c11d83faf94e9a8e5a8c.tar.gz
freebsd-ports-gnome-f12052ecbf190cc7c682c11d83faf94e9a8e5a8c.tar.zst
freebsd-ports-gnome-f12052ecbf190cc7c682c11d83faf94e9a8e5a8c.zip
* Update to 5.0.2
* Fix using jvm.options file * Add errors to rc script when using legacy rc.conf options PR: 214572, 214983 Submitted by: purpleritza@gmail.com Reported by: purpleritza@gmail.com, Mark.Martinec@ijs.si
Diffstat (limited to 'textproc/elasticsearch5')
-rw-r--r--textproc/elasticsearch5/Makefile5
-rw-r--r--textproc/elasticsearch5/distinfo6
-rw-r--r--textproc/elasticsearch5/files/elasticsearch.in23
-rw-r--r--textproc/elasticsearch5/files/patch-bin_elasticsearch11
-rw-r--r--textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh2
-rw-r--r--textproc/elasticsearch5/files/patch-config_elasticsearch.yml2
-rw-r--r--textproc/elasticsearch5/pkg-plist3
7 files changed, 35 insertions, 17 deletions
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
index b8cfc2ea79fe..94fd63733bbc 100644
--- a/textproc/elasticsearch5/Makefile
+++ b/textproc/elasticsearch5/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 5.0.0
+PORTVERSION= 5.0.2
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -30,7 +30,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-LUCENEVER= 6.2.0
+LUCENEVER= 6.2.1
CONFIG_FILES= elasticsearch.yml log4j2.properties jvm.options
BINS= elasticsearch.in.sh \
elasticsearch \
@@ -62,6 +62,7 @@ PLIST_SUB= SEARCHUSER=${SEARCHUSER} \
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
diff --git a/textproc/elasticsearch5/distinfo b/textproc/elasticsearch5/distinfo
index 970b601ca0de..53e95872a0ed 100644
--- a/textproc/elasticsearch5/distinfo
+++ b/textproc/elasticsearch5/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478218577
-SHA256 (elasticsearch-5.0.0.tar.gz) = a866534f0fa7428e980c985d712024feef1dee04709add6e360fc7b73bb1e7ae
-SIZE (elasticsearch-5.0.0.tar.gz) = 32968292
+TIMESTAMP = 1480613915
+SHA256 (elasticsearch-5.0.2.tar.gz) = bbe761788570d344801cb91a8ba700465deb10601751007da791743e9308cb83
+SIZE (elasticsearch-5.0.2.tar.gz) = 32951077
diff --git a/textproc/elasticsearch5/files/elasticsearch.in b/textproc/elasticsearch5/files/elasticsearch.in
index 8074bd2cf786..7bdf454fcf53 100644
--- a/textproc/elasticsearch5/files/elasticsearch.in
+++ b/textproc/elasticsearch5/files/elasticsearch.in
@@ -17,9 +17,6 @@
# Set it to required group.
# elasticsearch_config (path): Set to /usr/local/etc/elasticsearch/elasticsearch.yml by default.
# Set it to the config file location.
-# elasticsearch_min_mem (num): Minumum JVM heap size, 256m by default.
-# elasticsearch_max_mem (num): Maximum JVM heap size, 1g by default.
-# elasticsearch_props (args): Additional java properties or arguments.
# elasticsearch_tmp (path): Set to /var/tmp/elasticsearch by default.
# Set it to the path to be used for temp files.
#
@@ -119,16 +116,13 @@ if [ -n "$2" ]; then
exit 1
fi
required_files="${elasticsearch_config}/elasticsearch.yml"
+ required_files="${elasticsearch_config}/jvm.options"
eval elasticsearch_enable="\${elasticsearch_${profile}_enable:-${elasticsearch_enable}}"
- eval elasticsearch_props="\${elasticsearch_${profile}_props:-${elasticsearch_props}}"
- eval elasticsearch_min_mem="\${elasticsearch_${profile}_min_mem:-${elasticsearch_min_mem}}"
- eval elasticsearch_max_mem="\${elasticsearchlimits_${profile}_enable:-${elasticsearch_max_mem}}"
- eval elasticsearch_tmp="\${elasticsearchlimits_${profile}_args:-${elasticsearch_tmp}}"
+ eval elasticsearch_tmp="\${elasticsearch_${profile}_args:-${elasticsearch_tmp}}"
else
echo "$0: extra argument ignored"
fi
else
- eval elasticsearch_envvars=${envvars}
if [ "x${elasticsearch_profiles}" != "x" -a "x$1" != "x" ]; then
for profile in ${elasticsearch_profiles}; do
eval _enable="\${elasticsearch_${profile}_enable}"
@@ -164,4 +158,17 @@ else
fi
fi
+if [ "x${elasticsearch_mem_min}" != "x" ]; then
+ echo "The elasticsearch_mem_min variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+if [ "x${elasticsearch_mem_max}" != "x" ]; then
+ echo "The elasticsearch_mem_max variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+if [ "x${elasticsearch_props}" != "x" ]; then
+ echo "The elasticsearch_props variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+
run_rc_command "$1"
diff --git a/textproc/elasticsearch5/files/patch-bin_elasticsearch b/textproc/elasticsearch5/files/patch-bin_elasticsearch
new file mode 100644
index 000000000000..f777ad03d55c
--- /dev/null
+++ b/textproc/elasticsearch5/files/patch-bin_elasticsearch
@@ -0,0 +1,11 @@
+--- bin/elasticsearch.orig 2016-12-02 11:42:56 UTC
++++ bin/elasticsearch
+@@ -112,7 +112,7 @@ ES_HOME=`cd "$ES_HOME"; pwd`
+
+ if [ -z "$ES_JVM_OPTIONS" ]; then
+ for jvm_options in "$ES_HOME"/config/jvm.options \
+- /etc/elasticsearch/jvm.options; do
++ %%PREFIX%%/etc/elasticsearch/jvm.options; do
+ if [ -r "$jvm_options" ]; then
+ ES_JVM_OPTIONS=$jvm_options
+ break
diff --git a/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh b/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh
index 2608186764b6..3a95104c81ca 100644
--- a/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh
+++ b/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh
@@ -1,4 +1,4 @@
---- bin/elasticsearch.in.sh.orig 2016-10-26 04:35:54 UTC
+--- bin/elasticsearch.in.sh.orig 2016-11-24 10:05:27 UTC
+++ bin/elasticsearch.in.sh
@@ -1,5 +1,19 @@
#!/bin/bash
diff --git a/textproc/elasticsearch5/files/patch-config_elasticsearch.yml b/textproc/elasticsearch5/files/patch-config_elasticsearch.yml
index a20c30e446a9..3ba976999d32 100644
--- a/textproc/elasticsearch5/files/patch-config_elasticsearch.yml
+++ b/textproc/elasticsearch5/files/patch-config_elasticsearch.yml
@@ -1,4 +1,4 @@
---- config/elasticsearch.yml.orig 2016-10-26 04:35:54 UTC
+--- config/elasticsearch.yml.orig 2016-11-24 10:05:27 UTC
+++ config/elasticsearch.yml
@@ -31,10 +31,15 @@
# Path to directory where to store the data (separate multiple locations by comma):
diff --git a/textproc/elasticsearch5/pkg-plist b/textproc/elasticsearch5/pkg-plist
index 0eb96afb3167..68939a1a4cae 100644
--- a/textproc/elasticsearch5/pkg-plist
+++ b/textproc/elasticsearch5/pkg-plist
@@ -12,8 +12,7 @@ lib/elasticsearch/lib/jackson-dataformat-cbor-2.8.1.jar
lib/elasticsearch/lib/jackson-dataformat-smile-2.8.1.jar
lib/elasticsearch/lib/jackson-dataformat-yaml-2.8.1.jar
lib/elasticsearch/lib/jna-4.2.2.jar
-lib/elasticsearch/lib/joda-convert-1.2.jar
-lib/elasticsearch/lib/joda-time-2.9.4.jar
+lib/elasticsearch/lib/joda-time-2.9.5.jar
lib/elasticsearch/lib/jopt-simple-5.0.2.jar
lib/elasticsearch/lib/jts-1.13.jar
lib/elasticsearch/lib/log4j-1.2-api-2.6.2.jar