aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/enchant
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-01-18 06:40:59 +0800
committeradamw <adamw@FreeBSD.org>2004-01-18 06:40:59 +0800
commit1b876c48852d3c8ea853134deae96db98bd1e185 (patch)
tree0067e6d15e8be397f1c2e82dc9dfa6cf38909ce6 /textproc/enchant
parent7d5f5a02259adb8bbb530b2e65fe6315f8db9918 (diff)
downloadfreebsd-ports-gnome-1b876c48852d3c8ea853134deae96db98bd1e185.tar.gz
freebsd-ports-gnome-1b876c48852d3c8ea853134deae96db98bd1e185.tar.zst
freebsd-ports-gnome-1b876c48852d3c8ea853134deae96db98bd1e185.zip
{a,h,i}spell libs are only installed if you build enchant with support for them.
So, conditionalize their registration within pkg-plist. Hurrrrrr... I should have caught that earlier...
Diffstat (limited to 'textproc/enchant')
-rw-r--r--textproc/enchant/Makefile13
-rw-r--r--textproc/enchant/pkg-plist15
2 files changed, 19 insertions, 9 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index 66b42df5d9d9..acf7351c213e 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -7,7 +7,7 @@
PORTNAME= enchant
PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= abiword
@@ -16,8 +16,6 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Dictionary/spellchecking framework
-LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell
-
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -43,14 +41,23 @@ WITH_HSPELL= yes
.if defined(WITH_ASPELL)
LIB_DEPENDS+= pspell.15:${PORTSDIR}/textproc/aspell
+PLIST_SUB+= ASPELL=""
+.else
+PLIST_SUB+= ASPELL="@comment "
.endif
.if defined(WITH_ISPELL)
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+PLIST_SUB+= ISPELL=""
+.else
+PLIST_SUB+= ISPELL="@comment "
.endif
.if defined(WITH_HSPELL)
BUILD_DEPENDS+= hspell:${PORTSDIR}/hebrew/hspell
+PLIST_SUB+= HSPELL=""
+.else
+PLIST_SUB+= HSPELL="@comment "
.endif
pre-everything::
diff --git a/textproc/enchant/pkg-plist b/textproc/enchant/pkg-plist
index 518f34dd89b9..388332f012c8 100644
--- a/textproc/enchant/pkg-plist
+++ b/textproc/enchant/pkg-plist
@@ -3,12 +3,15 @@ bin/enchant-lsmod
include/enchant/enchant++.h
include/enchant/enchant-provider.h
include/enchant/enchant.h
-lib/enchant/libenchant_aspell.a
-lib/enchant/libenchant_aspell.so
-lib/enchant/libenchant_aspell.so.2
-lib/enchant/libenchant_ispell.a
-lib/enchant/libenchant_ispell.so
-lib/enchant/libenchant_ispell.so.2
+%%ASPELL%%lib/enchant/libenchant_aspell.a
+%%ASPELL%%lib/enchant/libenchant_aspell.so
+%%ASPELL%%lib/enchant/libenchant_aspell.so.2
+%%HSPELL%%lib/enchant/libenchant_hspell.a
+%%HSPELL%%lib/enchant/libenchant_hspell.so
+%%HSPELL%%lib/enchant/libenchant_hspell.so.2
+%%ISPELL%%lib/enchant/libenchant_ispell.a
+%%ISPELL%%lib/enchant/libenchant_ispell.so
+%%ISPELL%%lib/enchant/libenchant_ispell.so.2
lib/enchant/libenchant_myspell.a
lib/enchant/libenchant_myspell.so
lib/enchant/libenchant_myspell.so.2