aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/es-hyphen
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-29 21:13:17 +0800
commite7533864e7a7574c2d1b20a6b10f81c0561e4621 (patch)
tree709c0318625f1fe2eca8e12b791e969926c96e91 /textproc/es-hyphen
parent3bc9ecccbd8279e4254d8eade21cc1a1837decfb (diff)
downloadfreebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.gz
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.tar.zst
freebsd-ports-gnome-e7533864e7a7574c2d1b20a6b10f81c0561e4621.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Diffstat (limited to 'textproc/es-hyphen')
-rw-r--r--textproc/es-hyphen/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/textproc/es-hyphen/Makefile b/textproc/es-hyphen/Makefile
index d28205dfb01f..bf11db825c74 100644
--- a/textproc/es-hyphen/Makefile
+++ b/textproc/es-hyphen/Makefile
@@ -5,10 +5,12 @@
# $FreeBSD$
#
-PORTNAME= es-hyphen
+PORTNAME= hyphen
PORTVERSION= 2005.11.18
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://ftp.osuosl.org/pub/openoffice/contrib/dictionaries/
+PKGNAMEPREFIX= es-
DISTNAME= hyph_es_ES
MAINTAINER= office@FreeBSD.org
@@ -17,21 +19,20 @@ COMMENT= Spanish hyphenation rules
USE_ZIP= yes
NO_BUILD= yes
+PLIST_FILES= %%DATADIR%%/hyph_es_ES.dic
+PLIST_DIRSTRY= %%DATADIR%%
+
ESALIASES= es_AR es_BO es_CL es_CO es_CR es_CU es_DO es_EC es_GT es_HN \
es_MX es_NI es_PA es_PE es_PR es_PY es_SV es_US es_UY es_VE
-
-PLIST_FILES= share/hyphen/hyph_es_ES.dic
.for ALIAS in ${ESALIASES}
-PLIST_FILES+= share/hyphen/hyph_${ALIAS}.dic
+PLIST_FILES+= %%DATADIR%%/hyph_${ALIAS}.dic
.endfor
-PLIST_DIRS= share/hyphen
do-install:
- @${MKDIR} ${PREFIX}/share/hyphen
- @${INSTALL_DATA} ${WRKDIR}/hyph_es_ES.dic ${PREFIX}/share/hyphen
- @cd ${PREFIX}/share/hyphen; \
- for alias in ${ESALIASES}; do \
- ${LN} -s hyph_es_ES.dic hyph_$${alias}.dic ; \
- done
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKDIR}/hyph_es_ES.dic ${DATADIR}/
+.for ALIAS in ${ESALIASES}
+ ${LN} -s hyph_es_ES.dic ${DATADIR}/hyph_${ALIAS}.dic
+.endfor
.include <bsd.port.mk>