aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/estraier
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-12-08 11:15:26 +0800
committerahze <ahze@FreeBSD.org>2004-12-08 11:15:26 +0800
commita0ef591f14b9d4c93c549a1fcf25b31eb60e19f5 (patch)
treefadc48cb3ce8a834e24a108d58e8c0d5c1711243 /textproc/estraier
parente0aa05017fa8fbe359b99af219d6d6240f0dc379 (diff)
downloadfreebsd-ports-gnome-a0ef591f14b9d4c93c549a1fcf25b31eb60e19f5.tar.gz
freebsd-ports-gnome-a0ef591f14b9d4c93c549a1fcf25b31eb60e19f5.tar.zst
freebsd-ports-gnome-a0ef591f14b9d4c93c549a1fcf25b31eb60e19f5.zip
- Chase SHLIB in qdbm
- Disable mecab support by default and only use on >5.x
Diffstat (limited to 'textproc/estraier')
-rw-r--r--textproc/estraier/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index 7ad27203f7b2..f7339966a3af 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -7,6 +7,7 @@
PORTNAME= estraier
PORTVERSION= 1.2.25
+PORTREVISION= 1
CATEGORIES= japanese textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ahze@FreeBSD.org
COMMENT= A full-text search system for personal use
-LIB_DEPENDS= qdbm.3:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS= qdbm.4:${PORTSDIR}/databases/qdbm
USE_ICONV= yes
@@ -25,11 +26,11 @@ CONFIGURE_ARGS= --with-sysqdbm \
--enable-dlfilter \
--enable-devel
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/include ${PTHREAD_LIBS}"
OPTIONS= CHASEN "Japanese Morphological Analysis Support" On \
- MECAB "Part-of-Speech and Morphological Analyzer" On \
+ MECAB "Part-of-Speech and Morphological Analyzer" Off \
KAKASI "Language processing filter/converter" On
.include <bsd.port.pre.mk>
@@ -40,11 +41,13 @@ LIB_DEPENDS+= chasen.0:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if ${ARCH} == i386 && !defined(WITHOUT_MECAB)
+.if ${OSVERSION} > 500000
+.if ${ARCH} == i386 && defined(WITH_MECAB)
LIB_DEPENDS+= mecab.0:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+= --enable-mecab
.endif
+.endif
.if !defined(WITHOUT_KAKASI)
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi