aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/expat2
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-12-08 09:34:32 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-12-08 09:34:32 +0800
commit888eca4ce63a3e351995d79ce710f9d09c1ca1d5 (patch)
treede173588188ccd03ad26037a5b79a109c29afbd4 /textproc/expat2
parentc05fafaf6da7e17c5271b2e060f106b88d97d618 (diff)
downloadfreebsd-ports-gnome-888eca4ce63a3e351995d79ce710f9d09c1ca1d5.tar.gz
freebsd-ports-gnome-888eca4ce63a3e351995d79ce710f9d09c1ca1d5.tar.zst
freebsd-ports-gnome-888eca4ce63a3e351995d79ce710f9d09c1ca1d5.zip
- Apply 2 patches from CVS.
Security: CVE-2009-3560, CVE-2009-3720 (DoS) Obtained from: http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmlparse.c?r1=1.164&r2=1.165 http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?r1=1.13&r2=1.15&view=patch
Diffstat (limited to 'textproc/expat2')
-rw-r--r--textproc/expat2/Makefile1
-rw-r--r--textproc/expat2/files/patch-xmlparse.c10
-rw-r--r--textproc/expat2/files/patch-xmltok_impl.c11
3 files changed, 22 insertions, 0 deletions
diff --git a/textproc/expat2/Makefile b/textproc/expat2/Makefile
index e5fada6b1365..9c8586b4ed06 100644
--- a/textproc/expat2/Makefile
+++ b/textproc/expat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= expat
PORTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF
diff --git a/textproc/expat2/files/patch-xmlparse.c b/textproc/expat2/files/patch-xmlparse.c
new file mode 100644
index 000000000000..e9992dd199ef
--- /dev/null
+++ b/textproc/expat2/files/patch-xmlparse.c
@@ -0,0 +1,10 @@
+--- lib/xmlparse.c.orig 2009-12-08 10:20:08.866482591 +0900
++++ lib/xmlparse.c 2009-12-08 10:20:23.038667874 +0900
+@@ -3725,7 +3725,6 @@
+ return XML_ERROR_NO_ELEMENTS;
+ default:
+ tok = -tok;
+- next = end;
+ break;
+ }
+ }
diff --git a/textproc/expat2/files/patch-xmltok_impl.c b/textproc/expat2/files/patch-xmltok_impl.c
new file mode 100644
index 000000000000..ec6ab41b30dd
--- /dev/null
+++ b/textproc/expat2/files/patch-xmltok_impl.c
@@ -0,0 +1,11 @@
+--- lib/xmltok_impl.c.orig 2009-12-08 10:16:58.047943029 +0900
++++ lib/xmltok_impl.c 2009-12-08 10:17:13.228143919 +0900
+@@ -1744,7 +1744,7 @@
+ const char *end,
+ POSITION *pos)
+ {
+- while (ptr != end) {
++ while (ptr < end) {
+ switch (BYTE_TYPE(enc, ptr)) {
+ #define LEAD_CASE(n) \
+ case BT_LEAD ## n: \