aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/foiltex
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-11-11 03:54:12 +0800
committerglewis <glewis@FreeBSD.org>2003-11-11 03:54:12 +0800
commitf27c6406f737d7d2a5c80715bbd1339a745cccca (patch)
treedc70335d301bb1dd514d9b47548b65a9da40112f /textproc/foiltex
parent415e76c42c6d7817722fc40b27cc20a6287961b1 (diff)
downloadfreebsd-ports-gnome-f27c6406f737d7d2a5c80715bbd1339a745cccca.tar.gz
freebsd-ports-gnome-f27c6406f737d7d2a5c80715bbd1339a745cccca.tar.zst
freebsd-ports-gnome-f27c6406f737d7d2a5c80715bbd1339a745cccca.zip
. Add a port of foiltex:
The FoilTeX is a collection of LaTeX files for making foils. A number of features are built-in including large sans serif font as normal font, options for setting normalsize at 20pt (default), 17pt, 25pt or 30pt, new macros for starting new foils, for special environments like Theorem and Proof, simple macros to control the headline and footline. WWW: http://www.ctan.org/tex-archive/nonfree/macros/latex/contrib/foiltex/ PR: 54372 Submitted by: Stefan Walter <sw@gegenunendlich.de>
Diffstat (limited to 'textproc/foiltex')
-rw-r--r--textproc/foiltex/Makefile63
-rw-r--r--textproc/foiltex/distinfo2
-rw-r--r--textproc/foiltex/pkg-descr7
-rw-r--r--textproc/foiltex/pkg-install14
-rw-r--r--textproc/foiltex/pkg-plist14
5 files changed, 100 insertions, 0 deletions
diff --git a/textproc/foiltex/Makefile b/textproc/foiltex/Makefile
new file mode 100644
index 000000000000..fcd103d30e89
--- /dev/null
+++ b/textproc/foiltex/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: foiltex
+# Date created: 07 November 2003
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= foiltex
+PORTVERSION= 2.1.4a
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= nonfree/macros/latex/contrib/${PORTNAME}
+DISTFILES= foiltex.dtx foiltex.ins
+EXTRACT_ONLY= # empty
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= A collection of LaTeX files for making foils
+
+EXTRACT_DEPENDS=latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_CDROM= redistribution on a not-for-profit basis only
+
+NO_WRKSUBDIR= yes
+
+LATEX_CMD= ${LOCALBASE}/bin/latex
+
+FOIL_DIR= ${PREFIX}/share/texmf/tex/latex/${PORTNAME}
+DOC_FILES= ${WRKDIR}/foiltex.dtx ${WRKDIR}/foiltex.dvi
+EXAMPLE_FILES= ${WRKDIR}/sampfoil.tex
+FOIL_FILES= ${WRKDIR}/foil17.clo ${WRKDIR}/foil20.clo \
+ ${WRKDIR}/foil25.clo ${WRKDIR}/foil30.clo \
+ ${WRKDIR}/foils.cls ${WRKDIR}/foils.sty \
+ ${WRKDIR}/foilshrt.clo ${WRKDIR}/fltfonts.def
+PLIST_SUB= FOIL_DIR="${FOIL_DIR:S,^${PREFIX}/,,}"
+
+do-build:
+ @${CP} ${DISTDIR}/foiltex.ins ${WRKDIR}/foiltex.ins
+ @${CP} ${DISTDIR}/foiltex.dtx ${WRKDIR}/foiltex.dtx
+ @cd ${WRKDIR} && ${LATEX_CMD} foiltex.ins && \
+ ${LATEX_CMD} foiltex.dtx && \
+ ${LATEX_CMD} foiltex.dtx && \
+ ${LATEX_CMD} foiltex.dtx
+
+do-install:
+# install docs and example file?
+.if !defined(NOPORTDOCS)
+# install docs...
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOC_FILES} ${DOCSDIR}
+# ...and examples
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${EXAMPLE_FILES} ${EXAMPLESDIR}
+.endif
+# install data files
+ @${MKDIR} ${FOIL_DIR}
+ @${INSTALL_DATA} ${FOIL_FILES} ${FOIL_DIR}
+
+post-install:
+ ${SETENV} LOCALBASE=${LOCALBASE} ${SH} ${PKGDIR}/pkg-install \
+ ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/textproc/foiltex/distinfo b/textproc/foiltex/distinfo
new file mode 100644
index 000000000000..818928161886
--- /dev/null
+++ b/textproc/foiltex/distinfo
@@ -0,0 +1,2 @@
+MD5 (foiltex.dtx) = 52be74b74f9bd3a7c14b64abe013ff0b
+MD5 (foiltex.ins) = a3a0a5fd301af99b54289db83a881982
diff --git a/textproc/foiltex/pkg-descr b/textproc/foiltex/pkg-descr
new file mode 100644
index 000000000000..92d3281ad539
--- /dev/null
+++ b/textproc/foiltex/pkg-descr
@@ -0,0 +1,7 @@
+The FoilTeX is a collection of LaTeX files for making foils. A number
+of features are built-in including large sans serif font as normal font,
+options for setting normalsize at 20pt (default), 17pt, 25pt or 30pt,
+new macros for starting new foils, for special environments like Theorem
+and Proof, simple macros to control the headline and footline.
+
+WWW: http://www.ctan.org/tex-archive/nonfree/macros/latex/contrib/foiltex/
diff --git a/textproc/foiltex/pkg-install b/textproc/foiltex/pkg-install
new file mode 100644
index 000000000000..a97a81c62211
--- /dev/null
+++ b/textproc/foiltex/pkg-install
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+[ -z "${LOCALBASE}" ] && LOCALBASE=/usr/local
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "Updating content cache to let LaTeX know about the new style files:"
+ if [ -x ${LOCALBASE}/bin/mktexlsr ]; then
+ ${LOCALBASE}/bin/mktexlsr
+ else
+ echo "Could not find mktexlsr. Please run it manually to update"
+ echo "LaTeX's content cache, or you won't be able to use the"
+ echo "new style files."
+ fi
+fi
diff --git a/textproc/foiltex/pkg-plist b/textproc/foiltex/pkg-plist
new file mode 100644
index 000000000000..b52a4b62b4f2
--- /dev/null
+++ b/textproc/foiltex/pkg-plist
@@ -0,0 +1,14 @@
+%%PORTDOCS%%%%DOCSDIR%%/foiltex.dtx
+%%PORTDOCS%%%%DOCSDIR%%/foiltex.dvi
+%%PORTDOCS%%%%EXAMPLESDIR%%/sampfoil.tex
+%%FOIL_DIR%%/foil17.clo
+%%FOIL_DIR%%/foil20.clo
+%%FOIL_DIR%%/foil25.clo
+%%FOIL_DIR%%/foil30.clo
+%%FOIL_DIR%%/foils.cls
+%%FOIL_DIR%%/foils.sty
+%%FOIL_DIR%%/foilshrt.clo
+%%FOIL_DIR%%/fltfonts.def
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%FOIL_DIR%%