aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gtkspell
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-08-20 04:08:57 +0800
committermarcus <marcus@FreeBSD.org>2002-08-20 04:08:57 +0800
commit91f91bbd3dcea76b3121cb693d663fb63c1fdb4a (patch)
tree3c1de5551e66e4629fe79b2d2470550fb9449f08 /textproc/gtkspell
parentf925737f884542a6398a41e4927a54614e7ef589 (diff)
downloadfreebsd-ports-gnome-91f91bbd3dcea76b3121cb693d663fb63c1fdb4a.tar.gz
freebsd-ports-gnome-91f91bbd3dcea76b3121cb693d663fb63c1fdb4a.tar.zst
freebsd-ports-gnome-91f91bbd3dcea76b3121cb693d663fb63c1fdb4a.zip
Add gtkspell2, a GTK+ 2 spell checking component. There is a gtkspell
out there for GTK+ 1.2, but it doesn't appear to be in the tree. If for some reason, it ever gets imported, this port won't collide with it.
Diffstat (limited to 'textproc/gtkspell')
-rw-r--r--textproc/gtkspell/Makefile33
-rw-r--r--textproc/gtkspell/distinfo1
-rw-r--r--textproc/gtkspell/files/patch-configure10
-rw-r--r--textproc/gtkspell/pkg-comment1
-rw-r--r--textproc/gtkspell/pkg-descr5
-rw-r--r--textproc/gtkspell/pkg-plist7
6 files changed, 57 insertions, 0 deletions
diff --git a/textproc/gtkspell/Makefile b/textproc/gtkspell/Makefile
new file mode 100644
index 000000000000..663ffaca9be9
--- /dev/null
+++ b/textproc/gtkspell/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gtkspell2
+# Date created: 19 Aug 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkspell2
+PORTVERSION= 2.0.2
+CATEGORIES= textproc gnome
+MASTER_SITES= http://gtkspell.sourceforge.net/download/
+DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ pspell.4:${PORTSDIR}/textproc/pspell
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/gtkspell/distinfo b/textproc/gtkspell/distinfo
new file mode 100644
index 000000000000..0b1c252de066
--- /dev/null
+++ b/textproc/gtkspell/distinfo
@@ -0,0 +1 @@
+MD5 (gtkspell-2.0.2.tar.gz) = 385daba9bebfdc7fdbdf524e07deb920
diff --git a/textproc/gtkspell/files/patch-configure b/textproc/gtkspell/files/patch-configure
new file mode 100644
index 000000000000..6bb2a668556f
--- /dev/null
+++ b/textproc/gtkspell/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Mon Aug 19 13:43:43 2002
++++ configure Mon Aug 19 13:43:59 2002
+@@ -7524,6 +7524,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/textproc/gtkspell/pkg-comment b/textproc/gtkspell/pkg-comment
new file mode 100644
index 000000000000..a5d57d42aa68
--- /dev/null
+++ b/textproc/gtkspell/pkg-comment
@@ -0,0 +1 @@
+A GTK+ 2 spell checking component
diff --git a/textproc/gtkspell/pkg-descr b/textproc/gtkspell/pkg-descr
new file mode 100644
index 000000000000..05f8488a91d8
--- /dev/null
+++ b/textproc/gtkspell/pkg-descr
@@ -0,0 +1,5 @@
+GtkSpell provides MSWord/MacOSX-style highlighting of misspelled words in a
+GtkTextView widget as you type. Right-clicking a misspelled word pops up a menu
+of suggested replacements.
+
+WWW: http://gtkspell.sourceforge.net/
diff --git a/textproc/gtkspell/pkg-plist b/textproc/gtkspell/pkg-plist
new file mode 100644
index 000000000000..c8b3c009f40e
--- /dev/null
+++ b/textproc/gtkspell/pkg-plist
@@ -0,0 +1,7 @@
+include/gtkspell-2.0/gtkspell/gtkspell.h
+lib/libgtkspell.a
+lib/libgtkspell.so
+lib/libgtkspell.so.0
+libdata/pkgconfig/gtkspell-2.0.pc
+@dirrm include/gtkspell-2.0/gtkspell
+@dirrm include/gtkspell-2.0