aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gutenmark/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-07 23:35:06 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-07 23:35:06 +0800
commitabd83650ad789d7ec9057ae79a2554dc3f04f9a5 (patch)
tree48fc2ef73bf0ae908459fcf098c017b8fed4d576 /textproc/gutenmark/Makefile
parented7c3ebe2d5e2218d5269bc634386eaca1110314 (diff)
downloadfreebsd-ports-gnome-abd83650ad789d7ec9057ae79a2554dc3f04f9a5.tar.gz
freebsd-ports-gnome-abd83650ad789d7ec9057ae79a2554dc3f04f9a5.tar.zst
freebsd-ports-gnome-abd83650ad789d7ec9057ae79a2554dc3f04f9a5.zip
add gutenmark 20011228
Attractively formatting Project Gutenberg texts
Diffstat (limited to 'textproc/gutenmark/Makefile')
-rw-r--r--textproc/gutenmark/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/gutenmark/Makefile b/textproc/gutenmark/Makefile
new file mode 100644
index 000000000000..6b6a82db8c5a
--- /dev/null
+++ b/textproc/gutenmark/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: GutenMark
+# Date created: Jun 7, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= gutenmark
+PORTVERSION= 20011228
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.sandroid.org/GutenMark/SoftwareSnapshots/
+DISTNAME= GutenMark_source_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/GutenMark-source
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+post-patch:
+ @${PERL} -pi -e "s,cc,${CC},g ; s,-O3 -Wall,${CFLAGS},g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/GutenMark ${PREFIX}/bin
+
+.include <bsd.port.mk>