aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gxmlviewer/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-11-12 01:11:25 +0800
committerijliao <ijliao@FreeBSD.org>2001-11-12 01:11:25 +0800
commitdcc5cab4f87848fa5632c83e01dca716ce423c13 (patch)
tree589ee97f785326a44d416e83cacb4f5b3700a52e /textproc/gxmlviewer/Makefile
parentc1652baa8bdc128c688bce118c6e23eaaa27db71 (diff)
downloadfreebsd-ports-gnome-dcc5cab4f87848fa5632c83e01dca716ce423c13.tar.gz
freebsd-ports-gnome-dcc5cab4f87848fa5632c83e01dca716ce423c13.tar.zst
freebsd-ports-gnome-dcc5cab4f87848fa5632c83e01dca716ce423c13.zip
add gxmlviewer
An xmlviewer with a netscape plugin, and now a bonobo control as well
Diffstat (limited to 'textproc/gxmlviewer/Makefile')
-rw-r--r--textproc/gxmlviewer/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/gxmlviewer/Makefile b/textproc/gxmlviewer/Makefile
new file mode 100644
index 000000000000..312562c28f1d
--- /dev/null
+++ b/textproc/gxmlviewer/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: gxmlviewer
+# Date created: Nov 8, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gxmlviewer
+PORTVERSION= 1.3.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>