aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/highlight
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-08-11 07:39:33 +0800
committeradamw <adamw@FreeBSD.org>2003-08-11 07:39:33 +0800
commit4d8ac919c1bfae4652e08c1af37dea3eb44d2e2e (patch)
tree1ec3ca9e04deda68d338b86a757c78c30f1eb761 /textproc/highlight
parentce849804e54ffc08bd79d92e7d639e6eea87054c (diff)
downloadfreebsd-ports-gnome-4d8ac919c1bfae4652e08c1af37dea3eb44d2e2e.tar.gz
freebsd-ports-gnome-4d8ac919c1bfae4652e08c1af37dea3eb44d2e2e.tar.zst
freebsd-ports-gnome-4d8ac919c1bfae4652e08c1af37dea3eb44d2e2e.zip
Add highlight.
highlight is a customizable source code highlighter. It supports a myriad of output formats, and an even greater myriad of recognized source code formats, and even supports themes. highlight can output to HTML, XHTML, RTF, LaTeX and TeX, and can markup many input formats, including: Ada 95, Agda, AMPL, Aspect, Assembler, Amtrix, Avenue, (G)AWK, Bash, BlitzBasic, BMS, C, C++, C#, ClearBasic, Clipper, COBOL, CSS, DOS-Batch, Eiffel, Euphoria, Express, Fortran, Haskell, HTML, HTTPD, IDL, INI, Jasmin, Java, JavaScript, LaTeX, LDIF, Lotus Script, Lua, Make, Maya, Matlab, Modelica, Modula 3, (Object) Pascal, Paradox, PATROL, Perl, PHP, Pike, PL/1, PL/SQL, POV Ray, Progress, Python, Rexx, Ruby, Small, Spin, Sybase, VHDL, Visual Basic, and XML. phew!
Diffstat (limited to 'textproc/highlight')
-rw-r--r--textproc/highlight/Makefile49
-rw-r--r--textproc/highlight/distinfo1
-rw-r--r--textproc/highlight/pkg-descr16
-rw-r--r--textproc/highlight/pkg-plist134
4 files changed, 200 insertions, 0 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
new file mode 100644
index 000000000000..19887d5f69b8
--- /dev/null
+++ b/textproc/highlight/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: highlight
+# Date created: 05 August 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= highlight
+PORTVERSION= 2.0d7 #someday, people will stick to numbers and decimal points
+CATEGORIES= textproc
+MASTER_SITES= http://www.andre-simon.de/zip/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/d/-/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Customizable syntax highlighter
+
+WRKSRC= ${WRKDIR}/${PORTNAME}2
+
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.if !defined(NOPORTDOCS)
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/highlight|${DATADIR}|' \
+ ${WRKSRC}/${PORTNAME}/datadir.cpp
+
+do-install:
+ cd ${WRKSRC} && ${GMAKE} ${INSTALL_TARGET}
+ ${MKDIR} ${DATADIR} ${EXAMPLESDIR} ${DOCSDIR}
+ ${MKDIR} ${DATADIR}/helpmsg ${DATADIR}/langDefs ${DATADIR}/themes
+ ${INSTALL_DATA} ${WRKSRC}/helpmsg/* ${DATADIR}/helpmsg
+ ${INSTALL_DATA} ${WRKSRC}/langDefs/*.lang ${DATADIR}/langDefs
+ ${INSTALL_DATA} ${WRKSRC}/langDefs/extensions.conf ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/themes/* ${DATADIR}/themes
+ ${INSTALL_DATA} ${WRKSRC}/cgi/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1}.gz ${MANPREFIX}/man/man1
+.for i in AUTHORS README ChangeLog COPYING INSTALL
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif # !defined(NOPORTDOCS)
+
+.include <bsd.port.mk>
diff --git a/textproc/highlight/distinfo b/textproc/highlight/distinfo
new file mode 100644
index 000000000000..dc301f9e07b6
--- /dev/null
+++ b/textproc/highlight/distinfo
@@ -0,0 +1 @@
+MD5 (highlight-2.0-7.tar.gz) = b7926c7726bc335c2cc16e275de37537
diff --git a/textproc/highlight/pkg-descr b/textproc/highlight/pkg-descr
new file mode 100644
index 000000000000..8701b69b9875
--- /dev/null
+++ b/textproc/highlight/pkg-descr
@@ -0,0 +1,16 @@
+highlight is a customizable source code highlighter. It supports a
+myriad of output formats, and an even greater myriad of recognized
+source code formats, and even supports themes.
+
+highlight can output to HTML, XHTML, RTF, LaTeX and TeX, and can
+markup many input formats, including:
+
+Ada 95, Agda, AMPL, Aspect, Assembler, Amtrix, Avenue, (G)AWK, Bash,
+BlitzBasic, BMS, C, C++, C#, ClearBasic, Clipper, COBOL, CSS, DOS-Batch,
+Eiffel, Euphoria, Express, Fortran, Haskell, HTML, HTTPD, IDL, INI,
+Jasmin, Java, JavaScript, LaTeX, LDIF, Lotus Script, Lua, Make, Maya,
+Matlab, Modelica, Modula 3, (Object) Pascal, Paradox, PATROL, Perl, PHP,
+Pike, PL/1, PL/SQL, POV Ray, Progress, Python, Rexx, Ruby, Small, Spin,
+Sybase, VHDL, Visual Basic, and XML.
+
+WWW: http://www.andre-simon.de/
diff --git a/textproc/highlight/pkg-plist b/textproc/highlight/pkg-plist
new file mode 100644
index 000000000000..e321933d878f
--- /dev/null
+++ b/textproc/highlight/pkg-plist
@@ -0,0 +1,134 @@
+bin/highlight
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/README_CGI
+%%EXAMPLESDIR%%/highlight.cgi
+%%DATADIR%%/extensions.conf
+%%DATADIR%%/helpmsg/de.help
+%%DATADIR%%/helpmsg/en.help
+%%DATADIR%%/helpmsg/fr.help
+%%DATADIR%%/langDefs/4th.lang
+%%DATADIR%%/langDefs/ada.lang
+%%DATADIR%%/langDefs/agda.lang
+%%DATADIR%%/langDefs/ampl.lang
+%%DATADIR%%/langDefs/amtrix.lang
+%%DATADIR%%/langDefs/asm.lang
+%%DATADIR%%/langDefs/aspect.lang
+%%DATADIR%%/langDefs/avenue.lang
+%%DATADIR%%/langDefs/awk.lang
+%%DATADIR%%/langDefs/bat.lang
+%%DATADIR%%/langDefs/bb.lang
+%%DATADIR%%/langDefs/bms.lang
+%%DATADIR%%/langDefs/c.lang
+%%DATADIR%%/langDefs/cb.lang
+%%DATADIR%%/langDefs/clipper.lang
+%%DATADIR%%/langDefs/clp.lang
+%%DATADIR%%/langDefs/cob.lang
+%%DATADIR%%/langDefs/cs.lang
+%%DATADIR%%/langDefs/css.lang
+%%DATADIR%%/langDefs/e.lang
+%%DATADIR%%/langDefs/euphoria.lang
+%%DATADIR%%/langDefs/exp.lang
+%%DATADIR%%/langDefs/fortran.lang
+%%DATADIR%%/langDefs/haskell.lang
+%%DATADIR%%/langDefs/httpd.lang
+%%DATADIR%%/langDefs/idl.lang
+%%DATADIR%%/langDefs/ini.lang
+%%DATADIR%%/langDefs/j.lang
+%%DATADIR%%/langDefs/java.lang
+%%DATADIR%%/langDefs/js.lang
+%%DATADIR%%/langDefs/ldif.lang
+%%DATADIR%%/langDefs/ls.lang
+%%DATADIR%%/langDefs/lua.lang
+%%DATADIR%%/langDefs/m.lang
+%%DATADIR%%/langDefs/make.lang
+%%DATADIR%%/langDefs/mel.lang
+%%DATADIR%%/langDefs/mo.lang
+%%DATADIR%%/langDefs/mod3.lang
+%%DATADIR%%/langDefs/pas.lang
+%%DATADIR%%/langDefs/php.lang
+%%DATADIR%%/langDefs/pike.lang
+%%DATADIR%%/langDefs/pl.lang
+%%DATADIR%%/langDefs/pl1.lang
+%%DATADIR%%/langDefs/pov.lang
+%%DATADIR%%/langDefs/progress.lang
+%%DATADIR%%/langDefs/psl.lang
+%%DATADIR%%/langDefs/py.lang
+%%DATADIR%%/langDefs/rb.lang
+%%DATADIR%%/langDefs/rexx.lang
+%%DATADIR%%/langDefs/sc.lang
+%%DATADIR%%/langDefs/sh.lang
+%%DATADIR%%/langDefs/sma.lang
+%%DATADIR%%/langDefs/spn.lang
+%%DATADIR%%/langDefs/sql.lang
+%%DATADIR%%/langDefs/sybase.lang
+%%DATADIR%%/langDefs/tcl.lang
+%%DATADIR%%/langDefs/tex.lang
+%%DATADIR%%/langDefs/txt.lang
+%%DATADIR%%/langDefs/vb.lang
+%%DATADIR%%/langDefs/vhd.lang
+%%DATADIR%%/langDefs/xml.lang
+%%DATADIR%%/themes/aqua.style
+%%DATADIR%%/themes/berries-dark.style
+%%DATADIR%%/themes/berries-light.style
+%%DATADIR%%/themes/bipolar.style
+%%DATADIR%%/themes/blacknblue.style
+%%DATADIR%%/themes/blue.style
+%%DATADIR%%/themes/bright.style
+%%DATADIR%%/themes/bright2.style
+%%DATADIR%%/themes/bruised.style
+%%DATADIR%%/themes/bubblegum.style
+%%DATADIR%%/themes/contrast.style
+%%DATADIR%%/themes/darkness.style
+%%DATADIR%%/themes/desert.style
+%%DATADIR%%/themes/dream.style
+%%DATADIR%%/themes/dull.style
+%%DATADIR%%/themes/easter.style
+%%DATADIR%%/themes/emacs.style
+%%DATADIR%%/themes/fluke.style
+%%DATADIR%%/themes/golden.style
+%%DATADIR%%/themes/greenlcd.style
+%%DATADIR%%/themes/greyish.style
+%%DATADIR%%/themes/ide-anjuta.style
+%%DATADIR%%/themes/ide-devcpp.style
+%%DATADIR%%/themes/ide-jbuilder4.style
+%%DATADIR%%/themes/ide-jcreator2.style
+%%DATADIR%%/themes/ide-kdev.style
+%%DATADIR%%/themes/ide-msvcpp.style
+%%DATADIR%%/themes/ide-synedit.style
+%%DATADIR%%/themes/imperial.style
+%%DATADIR%%/themes/kwrite.style
+%%DATADIR%%/themes/matlab.style
+%%DATADIR%%/themes/navy.style
+%%DATADIR%%/themes/neon.style
+%%DATADIR%%/themes/neon2.style
+%%DATADIR%%/themes/night.style
+%%DATADIR%%/themes/nightvision.style
+%%DATADIR%%/themes/peachy.style
+%%DATADIR%%/themes/print.style
+%%DATADIR%%/themes/rand01.style
+%%DATADIR%%/themes/rand02.style
+%%DATADIR%%/themes/slime.style
+%%DATADIR%%/themes/smoke.style
+%%DATADIR%%/themes/typical.style
+%%DATADIR%%/themes/untitled.style
+%%DATADIR%%/themes/untypical.style
+%%DATADIR%%/themes/usable.style
+%%DATADIR%%/themes/vampire.style
+%%DATADIR%%/themes/website.style
+%%DATADIR%%/themes/website2-blue.style
+%%DATADIR%%/themes/website2.style
+%%DATADIR%%/themes/website3-blue.style
+%%DATADIR%%/themes/website3.style
+%%DATADIR%%/themes/whatis.style
+%%DATADIR%%/themes/whitenblue.style
+%%DATADIR%%/themes/whitengrey.style
+@dirrm %%DATADIR%%/themes
+@dirrm %%DATADIR%%/langDefs
+@dirrm %%DATADIR%%/helpmsg
+@dirrm %%DATADIR%%
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%