aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-HaXml/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-06-05 07:05:39 +0800
committerpetef <petef@FreeBSD.org>2002-06-05 07:05:39 +0800
commit37c653c8921467d05b961356410c4ffff00542b0 (patch)
tree35200535a75d07a2f9e7909f568ec22bdf82a3d9 /textproc/hs-HaXml/Makefile
parent20e3e9b2681998fe984b81918623b349e202277a (diff)
downloadfreebsd-ports-gnome-37c653c8921467d05b961356410c4ffff00542b0.tar.gz
freebsd-ports-gnome-37c653c8921467d05b961356410c4ffff00542b0.tar.zst
freebsd-ports-gnome-37c653c8921467d05b961356410c4ffff00542b0.zip
Add haxml 1.05, a collection of utilities for using Haskell and XML
together. PR: 38804 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Diffstat (limited to 'textproc/hs-HaXml/Makefile')
-rw-r--r--textproc/hs-HaXml/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/hs-HaXml/Makefile b/textproc/hs-HaXml/Makefile
new file mode 100644
index 000000000000..714d223171d6
--- /dev/null
+++ b/textproc/hs-HaXml/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: HaXml
+# Date created: 01 June 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+
+PORTNAME= haxml
+PORTVERSION= 1.05
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/HaXml/
+DISTNAME= HaXml-${PORTVERSION}
+
+MAINTAINER= obraun@informatik.unibw-muenchen.de
+
+BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
+
+USE_GMAKE= yes
+
+do-install:
+ @(cd ${WRKSRC} && ${INSTALL_PROGRAM} Canonicalise DrIFT DtdToHaskell Xtract ${PREFIX}/bin)
+ @${MKDIR} ${PREFIX}/lib/haxml
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib/haxml
+.if !defined(NOPORTDOCS)
+ @${RM} -rf ${WRKSRC}/docs/CVS
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC} && ${CP} -R docs/* ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>