aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-citeproc-hs
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-08-03 10:30:07 +0800
committerpgj <pgj@FreeBSD.org>2012-08-03 10:30:07 +0800
commitc375ed37df92a6e58eaf54cf831525f3a49c9629 (patch)
tree8ee3a15fcf61eb9a77ce79ffe7cc567f6e56e480 /textproc/hs-citeproc-hs
parent9c52697bc371ab647ee6cd5811c6ca220c7f6e11 (diff)
downloadfreebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.tar.gz
freebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.tar.zst
freebsd-ports-gnome-c375ed37df92a6e58eaf54cf831525f3a49c9629.zip
- Teach the Haskell Cabal ports to use the new options framework
- Remove some cruft Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc/hs-citeproc-hs')
-rw-r--r--textproc/hs-citeproc-hs/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/hs-citeproc-hs/Makefile b/textproc/hs-citeproc-hs/Makefile
index b6d64a29f41e..34477a87324f 100644
--- a/textproc/hs-citeproc-hs/Makefile
+++ b/textproc/hs-citeproc-hs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= citeproc-hs
PORTVERSION= 0.3.4
+PORTREVISION= 1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,20 +17,22 @@ LICENSE= BSD
USE_CABAL= json mtl pandoc-types>=1.8 utf8-string xml
-OPTIONS= BIBUTILS "Use Chris Putnam's Bibutils" on \
- NETWORK "Use network and HTTP to retrieve CSL file" on
+OPTIONS_DEFINE= BIBUTILS NETWORK
+OPTIONS_DEFAULT= BIBUTILS NETWORK
+
+BIBUTILS_DESC= Use Chris Putnam's Bibutils
+NETWORK_DESC= Use network and HTTP to retrieve CSL file
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_BIBUTILS)
+.if ${PORT_OPTIONS:MBIBUTILS}
CONFIGURE_ARGS+= --flags="bibutils"
USE_CABAL+= hs-bibutils>=0.3
.else
CONFIGURE_ARGS+= --flags="-bibutils"
.endif
-.if defined(WITH_NETWORK)
+.if ${PORT_OPTIONS:MNETWORK}
CONFIGURE_ARGS+= --flags="network"
USE_CABAL+= HTTP>=4000.0.9 network>=2
.else