aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-hs-bibutils/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-16 03:23:21 +0800
committerpgj <pgj@FreeBSD.org>2010-05-16 03:23:21 +0800
commit7ead5a24105efc096e19574f87a56317f55520a8 (patch)
tree068c3149ab0f2b50606ac613fcdcadaea94146f9 /textproc/hs-hs-bibutils/Makefile
parent039087f59f6cad5995600b37bf613ea4d8875477 (diff)
downloadfreebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.tar.gz
freebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.tar.zst
freebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.zip
Haskell bindings to Chris Putnam's bibutils, a library that
interconverts between various bibliography formats using a common MODS-format XML intermediate. WWW: http://code.haskell.org/hs-bibutils
Diffstat (limited to 'textproc/hs-hs-bibutils/Makefile')
-rw-r--r--textproc/hs-hs-bibutils/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/textproc/hs-hs-bibutils/Makefile b/textproc/hs-hs-bibutils/Makefile
new file mode 100644
index 000000000000..37fc4a7feb11
--- /dev/null
+++ b/textproc/hs-hs-bibutils/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: hs-hs-bibutils
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hs-bibutils
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell bindings to bibutils, the bibliography conversion utilities
+
+BUILD_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+RUN_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>