aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-hs-bibutils
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-16 03:23:21 +0800
committerpgj <pgj@FreeBSD.org>2010-05-16 03:23:21 +0800
commit7ead5a24105efc096e19574f87a56317f55520a8 (patch)
tree068c3149ab0f2b50606ac613fcdcadaea94146f9 /textproc/hs-hs-bibutils
parent039087f59f6cad5995600b37bf613ea4d8875477 (diff)
downloadfreebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.tar.gz
freebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.tar.zst
freebsd-ports-gnome-7ead5a24105efc096e19574f87a56317f55520a8.zip
Haskell bindings to Chris Putnam's bibutils, a library that
interconverts between various bibliography formats using a common MODS-format XML intermediate. WWW: http://code.haskell.org/hs-bibutils
Diffstat (limited to 'textproc/hs-hs-bibutils')
-rw-r--r--textproc/hs-hs-bibutils/Makefile19
-rw-r--r--textproc/hs-hs-bibutils/distinfo3
-rw-r--r--textproc/hs-hs-bibutils/pkg-descr14
-rw-r--r--textproc/hs-hs-bibutils/pkg-plist14
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/hs-hs-bibutils/Makefile b/textproc/hs-hs-bibutils/Makefile
new file mode 100644
index 000000000000..37fc4a7feb11
--- /dev/null
+++ b/textproc/hs-hs-bibutils/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: hs-hs-bibutils
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hs-bibutils
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell bindings to bibutils, the bibliography conversion utilities
+
+BUILD_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+RUN_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-hs-bibutils/distinfo b/textproc/hs-hs-bibutils/distinfo
new file mode 100644
index 000000000000..e62df7c21d83
--- /dev/null
+++ b/textproc/hs-hs-bibutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (hs-bibutils-0.3.tar.gz) = 1c17fc71397cd91e7a4fa22eb47bff2e
+SHA256 (hs-bibutils-0.3.tar.gz) = 162e04d8c4187c2edc3b302554efbd3286ac08b9b8bf82844b59f9a954055e5e
+SIZE (hs-bibutils-0.3.tar.gz) = 404384
diff --git a/textproc/hs-hs-bibutils/pkg-descr b/textproc/hs-hs-bibutils/pkg-descr
new file mode 100644
index 000000000000..822de78e8f51
--- /dev/null
+++ b/textproc/hs-hs-bibutils/pkg-descr
@@ -0,0 +1,14 @@
+Haskell bindings to Chris Putnam's bibutils, a library that
+interconverts between various bibliography formats using a common
+MODS-format XML intermediate.
+
+hs-bibutils is available under the GNU GPL license. See the LICENSE file
+for details.
+
+For more details about bibutils, please check:
+<http://www.scripps.edu/~cdputnam/software/bibutils/>.
+
+The original API documentation is available here:
+<http://www.scripps.edu/~cdputnam/software/bibutils/library_specs.html>.
+
+WWW: http://code.haskell.org/hs-bibutils
diff --git a/textproc/hs-hs-bibutils/pkg-plist b/textproc/hs-hs-bibutils/pkg-plist
new file mode 100644
index 000000000000..b8d37e402516
--- /dev/null
+++ b/textproc/hs-hs-bibutils/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Bibutils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old