aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-lhs2tex
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2014-01-10 05:32:12 +0800
committerpgj <pgj@FreeBSD.org>2014-01-10 05:32:12 +0800
commit1e8ecc139a38c58921cfe6dbac98c727b1cefd71 (patch)
tree604f06bea271b71fb7be1993c1c2ba323b4506e1 /textproc/hs-lhs2tex
parent85c277ebe0c60dd6aa5be2bceb4d04e10cdf1b13 (diff)
downloadfreebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.tar.gz
freebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.tar.zst
freebsd-ports-gnome-1e8ecc139a38c58921cfe6dbac98c727b1cefd71.zip
- Stagify lang/ghc and all the Haskell Cabal ports
- Update HACKAGE_SITE to follow changes in upstream - MAKE_ENV now sets LC_ALL and DESTDIR for Haskell Cabal ports - Further minor cosmetical changes: replace USE_GMAKE with USES, get rid of ${DO_NADA}, some refactoring Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc/hs-lhs2tex')
-rw-r--r--textproc/hs-lhs2tex/Makefile1
-rw-r--r--textproc/hs-lhs2tex/files/patch-Setup.hs16
2 files changed, 13 insertions, 4 deletions
diff --git a/textproc/hs-lhs2tex/Makefile b/textproc/hs-lhs2tex/Makefile
index c766ed2bcb35..5330e904329a 100644
--- a/textproc/hs-lhs2tex/Makefile
+++ b/textproc/hs-lhs2tex/Makefile
@@ -19,6 +19,5 @@ EXECUTABLE= lhs2TeX
MAN1= lhs2TeX.1
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-lhs2tex/files/patch-Setup.hs b/textproc/hs-lhs2tex/files/patch-Setup.hs
index aa6c860894fd..df80ba1420b5 100644
--- a/textproc/hs-lhs2tex/files/patch-Setup.hs
+++ b/textproc/hs-lhs2tex/files/patch-Setup.hs
@@ -1,6 +1,6 @@
---- ./Setup.hs.orig 2011-03-17 11:23:52.000000000 +0100
-+++ ./Setup.hs 2011-05-22 14:33:40.000000000 +0200
-@@ -204,7 +204,7 @@
+--- Setup.hs.orig 2012-09-08 22:29:52.000000000 +0100
++++ Setup.hs 2013-12-08 15:55:17.403235103 +0000
+@@ -205,7 +205,7 @@
else docdir (absoluteInstallDirs pd lbi cd) `joinFileName` "doc"
let manDir = if isWindows
then dataPref `joinFileName` "Documentation"
@@ -9,3 +9,13 @@
createDirectoryIfMissing True docDir
installOrdinaryFile v (lhs2texDocDir `joinFileName` "Guide2.pdf") (docDir `joinFileName` "Guide2.pdf")
when (not isWindows) $
+@@ -213,7 +213,8 @@
+ installOrdinaryFile v ("lhs2TeX.1") (manDir `joinFileName` "lhs2TeX.1")
+ -- polytable
+ case (installPolyTable ebi) of
+- Just texmf -> do let texmfDir = texmf
++ Just texmf -> do let CopyTo destdir = cd
++ texmfDir = destdir `joinFileName` texmf
+ ptDir = texmfDir `joinFileName` "tex" `joinFileName` "latex"
+ `joinFileName` "polytable"
+ createDirectoryIfMissing True ptDir