aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-lhs2tex
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
committerashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
commitc7a47a981222b062ac48e4edc5cae32fbed2b9c7 (patch)
treea1af1f5739f0a44d179f6f44b2ea70e07401da25 /textproc/hs-lhs2tex
parent63b87600f00dd6e3a998a1862f7c209aa5e62523 (diff)
downloadfreebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.gz
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.zst
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.zip
- Please welcome GHC 7.0.3
GHC in the ports tree has been updated to 7.0.3 and all other Haskell ports are also updated to their corresponding Haskell Platform versions, or latest versions. We would like to acknowledge the support of the FreeBSD Donations Team and Eotvos Lorand University, Faculty of Informatics who contributed to the server that we used for testing. We would also like to thank all the testers who tested FreeBSD Haskell ports and provided their feedback. PR: ports/156642 Approved by: tabthorpe (mentor) Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc/hs-lhs2tex')
-rw-r--r--textproc/hs-lhs2tex/Makefile47
-rw-r--r--textproc/hs-lhs2tex/distinfo5
-rw-r--r--textproc/hs-lhs2tex/files/patch-Makefile34
-rw-r--r--textproc/hs-lhs2tex/files/patch-MathPoly.lhs11
-rw-r--r--textproc/hs-lhs2tex/files/patch-Setup.hs23
-rw-r--r--textproc/hs-lhs2tex/files/patch-configure66
-rw-r--r--textproc/hs-lhs2tex/pkg-descr5
-rw-r--r--textproc/hs-lhs2tex/pkg-plist4
8 files changed, 55 insertions, 140 deletions
diff --git a/textproc/hs-lhs2tex/Makefile b/textproc/hs-lhs2tex/Makefile
index 2a0697e8b7a0..6e3b8dba09bd 100644
--- a/textproc/hs-lhs2tex/Makefile
+++ b/textproc/hs-lhs2tex/Makefile
@@ -7,44 +7,25 @@
#
PORTNAME= lhs2tex
-PORTVERSION= 1.15
-PORTREVISION= 2
-CATEGORIES= devel haskell
-MASTER_SITES= http://people.cs.uu.nl/andres/${PORTNAME}/
+PORTVERSION= 1.16
+CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A preprocessor to generate LaTeX code from literate Haskell sources
+COMMENT= Preprocessor for typesetting Haskell sources with LaTeX
-BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc \
- mktexlsr:${PORTSDIR}/print/teTeX-base \
- hs-utf8-string>=0.3:${PORTSDIR}/devel/hs-utf8-string
+LICENSE= GPLv2
-RUN_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base
+CABAL_SETUP= Setup.hs
+USE_CABAL= regex-compat
+BUILD_DEPENDS+= mktexlsr:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS+= mktexlsr:${PORTSDIR}/print/teTeX-base
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --datadir=${PREFIX}/share \
- --docdir=${DOCSDIR} \
- --mandir=${MANPREFIX}/man
-
-DOCSDIR=${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-PORTDOCS= *
-DATADIR=${PREFIX}/share/${PORTNAME}-${PORTVERSION}
-PORTDATA= *
-
-.include <bsd.port.pre.mk>
-
-INSTALL_TARGET= install
-
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET+= install-doc
-.endif
-
-.if !defined(NOPORTDATA)
-INSTALL_TARGET+= install-data
-.endif
+STANDALONE= yes
+EXECUTABLE= lhs2TeX
MAN1= lhs2TeX.1
-.include <bsd.port.post.mk>
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-lhs2tex/distinfo b/textproc/hs-lhs2tex/distinfo
index 0910f9c2ae69..5cfbc116227b 100644
--- a/textproc/hs-lhs2tex/distinfo
+++ b/textproc/hs-lhs2tex/distinfo
@@ -1,3 +1,2 @@
-MD5 (lhs2tex-1.15.tar.gz) = 13c886a829e71e895fa172c617f31bd0
-SHA256 (lhs2tex-1.15.tar.gz) = 77f25c1f22823587ceca6eead133a403540319a0ae3bf03a369b3e8c86baf124
-SIZE (lhs2tex-1.15.tar.gz) = 580361
+SHA256 (cabal/lhs2tex-1.16.tar.gz) = aa43ec92e8d7c94213365a7211d605314476977155e36420caa3cfb394f7c76f
+SIZE (cabal/lhs2tex-1.16.tar.gz) = 581362
diff --git a/textproc/hs-lhs2tex/files/patch-Makefile b/textproc/hs-lhs2tex/files/patch-Makefile
deleted file mode 100644
index 08746efe6d38..000000000000
--- a/textproc/hs-lhs2tex/files/patch-Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.orig 2008-10-24 10:50:41.000000000 +0200
-+++ Makefile 2009-03-04 11:19:34.000000000 +0100
-@@ -135,14 +135,9 @@
- print : Lhs2TeX.dvi
- $(DVIPS) -D600 -f Lhs2TeX.dvi | lpr -Pa -Zl
-
--install : bin doc
-+install : bin
- $(MKINSTDIR) $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 lhs2TeX $(DESTDIR)$(bindir)
-- $(MKINSTDIR) $(DESTDIR)$(stydir)
-- $(INSTALL) -m 644 lhs2TeX.sty lhs2TeX.fmt $(DESTDIR)$(stydir)
-- $(INSTALL) -m 644 Library/*.fmt $(DESTDIR)$(stydir)
-- $(MKINSTDIR) $(DESTDIR)$(docdir)
-- $(INSTALL) -m 644 doc/Guide2.pdf $(DESTDIR)$(docdir)
- $(MKINSTDIR) $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 644 lhs2TeX.1 $(DESTDIR)$(mandir)/man1
- ifeq ($(INSTALL_POLYTABLE),yes)
-@@ -158,6 +153,15 @@
- echo "Please update the TeX filename database."
- endif
-
-+install-doc : doc
-+ $(MKINSTDIR) $(DESTDIR)$(docdir)
-+ $(INSTALL) -m 644 doc/Guide2.pdf $(DESTDIR)$(docdir)
-+
-+install-data : bin
-+ $(MKINSTDIR) $(DESTDIR)$(stydir)
-+ $(INSTALL) -m 644 lhs2TeX.sty lhs2TeX.fmt $(DESTDIR)$(stydir)
-+ $(INSTALL) -m 644 Library/*.fmt $(DESTDIR)$(stydir)
-+
- srcdist : INSTALL doc
- if test -d $(DISTDIR); then $(RM) -rf $(DISTDIR); fi
- $(MKINSTDIR) $(DISTDIR)
diff --git a/textproc/hs-lhs2tex/files/patch-MathPoly.lhs b/textproc/hs-lhs2tex/files/patch-MathPoly.lhs
new file mode 100644
index 000000000000..7c4ca99a1acd
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-MathPoly.lhs
@@ -0,0 +1,11 @@
+--- ./MathPoly.lhs.orig 2010-07-22 12:13:20.000000000 +0200
++++ ./MathPoly.lhs 2011-03-27 01:52:26.469094252 +0100
+@@ -358,7 +358,7 @@
+ > (rn,rc) = findrel (n,c) rstack
+ > -- Schritt 3: Zeile auf Stack legen
+ > fstack = (c,l) : rstack
+-> in mkFromTo fstack rn n rc [fromToken $ TeX False (indent (rn,rc) (n,c))] p ls
++> in mkFromTo fstack rn n rc [fromToken $ (TeX False (indent (rn,rc) (n,c))) :: Token] p ls
+ >
+ >
+ > | c `elem` z -> mkFromTo stack n (n ++ "E") c ts rs ls
diff --git a/textproc/hs-lhs2tex/files/patch-Setup.hs b/textproc/hs-lhs2tex/files/patch-Setup.hs
new file mode 100644
index 000000000000..a5ea584380dc
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-Setup.hs
@@ -0,0 +1,23 @@
+--- ./Setup.hs.orig 2010-07-22 12:13:20.000000000 +0200
++++ ./Setup.hs 2011-03-27 01:53:35.109600797 +0100
+@@ -204,7 +204,7 @@
+ else docdir (absoluteInstallDirs pd lbi cd) `joinFileName` "doc"
+ let manDir = if isWindows
+ then dataPref `joinFileName` "Documentation"
+- else datadir (absoluteInstallDirs pd lbi cd) `joinFileName` ".." `joinFileName` "man" `joinFileName` "man1"
++ else prefix (absoluteInstallDirs pd lbi cd) `joinFileName` "man" `joinFileName` "man1"
+ createDirectoryIfMissing True docDir
+ copyFileVerbose v (lhs2texDocDir `joinFileName` "Guide2.pdf") (docDir `joinFileName` "Guide2.pdf")
+ when (not isWindows) $
+@@ -291,9 +291,9 @@
+ do let mProg = lookupProgram (simpleProgram progName) programConf
+ case mProg of
+ Just (ConfiguredProgram { programLocation = UserSpecified p,
+- programArgs = args }) -> return (p,args)
++ programDefaultArgs = args }) -> return (p,args)
+ Just (ConfiguredProgram { programLocation = FoundOnSystem p,
+- programArgs = args }) -> return (p,args)
++ programDefaultArgs = args }) -> return (p,args)
+ _ -> (die (progName ++ " command not found"))
+
+ -- | Run a command in a specific environment and return the output and errors.
diff --git a/textproc/hs-lhs2tex/files/patch-configure b/textproc/hs-lhs2tex/files/patch-configure
deleted file mode 100644
index f4c2b4ae0a39..000000000000
--- a/textproc/hs-lhs2tex/files/patch-configure
+++ /dev/null
@@ -1,66 +0,0 @@
---- ./configure.orig 2009-12-18 13:21:18.000000000 +0100
-+++ ./configure 2010-01-07 19:34:38.000000000 +0100
-@@ -2745,54 +2745,6 @@
- POLYTABLE_INSTALL=yes
- fi
-
--if test "z$POLYTABLE_INSTALL" = "zyes"; then
--
--{ $as_echo "$as_me:$LINENO: checking for the polytable package" >&5
--$as_echo_n "checking for the polytable package... " >&6; }
--if test -x "$KPSEWHICH"; then
-- POLYTABLE="`$KPSEWHICH polytable.sty`"
--fi
--if test -f "$POLYTABLE"; then
-- { $as_echo "$as_me:$LINENO: result: $POLYTABLE" >&5
--$as_echo "$POLYTABLE" >&6; }
-- { $as_echo "$as_me:$LINENO: checking for version of polytable" >&5
--$as_echo_n "checking for version of polytable... " >&6; }
-- POLYTABLE_VERSION=`$GREP " v.* .polytable. package" $POLYTABLE | $SED -e "s/^.*v\(.*\) .polytable. package.*$/\1/"`
-- { $as_echo "$as_me:$LINENO: result: $POLYTABLE_VERSION" >&5
--$as_echo "$POLYTABLE_VERSION" >&6; }
--else
-- { $as_echo "$as_me:$LINENO: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
-- # does polytable need to be installed?
-- { $as_echo "$as_me:$LINENO: checking whether polytable needs to be installed" >&5
--$as_echo_n "checking whether polytable needs to be installed... " >&6; }
-- POLYTABLE_INSTALL=no
-- if test -n $POLYTABLE; then
-- if ( IFS=".";
-- a="$POLYTABLE_VERSION"; b="0.8.2";
-- while test -n "$a$b"
-- do
-- set -- $a; h1="$1"; shift 2>/dev/null; a="$*"
-- set -- $b; h2="$1"; shift 2>/dev/null; b="$*"
-- test -n "$h1" || h1=0; test -n "$h2" || h2=0
-- test ${h1} -eq ${h2} || break
-- done
-- test ${h1} -lt ${h2}
-- )
--then
-- POLYTABLE_INSTALL=yes
--
--fi
--
-- else
-- POLYTABLE_INSTALL=yes
-- fi
-- { $as_echo "$as_me:$LINENO: result: $POLYTABLE_INSTALL" >&5
--$as_echo "$POLYTABLE_INSTALL" >&6; }
--fi
--
- # Extract the first word of "mktexlsr", so it can be a program name with args.
- set dummy mktexlsr; ac_word=$2
- { $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
-@@ -2834,8 +2786,6 @@
-
-
-
--# docdir and expansion
--docdir="$datadir/doc/$PACKAGE_TARNAME-$PACKAGE_VERSION"
-
- stydir="$datadir/$PACKAGE_TARNAME-$PACKAGE_VERSION"
-
diff --git a/textproc/hs-lhs2tex/pkg-descr b/textproc/hs-lhs2tex/pkg-descr
index 9e915cafea0b..0c58501a3309 100644
--- a/textproc/hs-lhs2tex/pkg-descr
+++ b/textproc/hs-lhs2tex/pkg-descr
@@ -1,4 +1,3 @@
-lhs2TeX is a preprocessor to generate LaTeX code from literate Haskell
-sources. It is released under the GPL.
+Preprocessor for typesetting Haskell sources with LaTeX.
-WWW: http://people.cs.uu.nl/andres/
+WWW: http://www.andres-loeh.de/lhs2tex/
diff --git a/textproc/hs-lhs2tex/pkg-plist b/textproc/hs-lhs2tex/pkg-plist
index 17c5274b397d..883595e8b6c6 100644
--- a/textproc/hs-lhs2tex/pkg-plist
+++ b/textproc/hs-lhs2tex/pkg-plist
@@ -1,4 +1,6 @@
-bin/lhs2TeX
+@comment $FreeBSD$
+%%NOPORTDOCS%%%%DOCSDIR%%/doc/Guide2.pdf
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%/doc
share/texmf-local/tex/latex/polytable/lazylist.sty
share/texmf-local/tex/latex/polytable/polytable.sty
@dirrm share/texmf-local/tex/latex/polytable