aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-stringsearch/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
committerpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
commitf203c3895196ffa8b69517527e8c488cc49ada57 (patch)
treed7be6abb9940698d6dc43b1587948a03039a23b5 /textproc/hs-stringsearch/Makefile
parent965f4ecbcd1c9f6296e907af59901feeedfdc42f (diff)
downloadfreebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.gz
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.tar.zst
freebsd-ports-gnome-f203c3895196ffa8b69517527e8c488cc49ada57.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Diffstat (limited to 'textproc/hs-stringsearch/Makefile')
-rw-r--r--textproc/hs-stringsearch/Makefile62
1 files changed, 1 insertions, 61 deletions
diff --git a/textproc/hs-stringsearch/Makefile b/textproc/hs-stringsearch/Makefile
index 071bb790c27b..3fa070e087f6 100644
--- a/textproc/hs-stringsearch/Makefile
+++ b/textproc/hs-stringsearch/Makefile
@@ -8,69 +8,9 @@ PORTNAME= stringsearch
PORTVERSION= 0.2.1.1
PORTREVISION= 4
CATEGORIES= textproc haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/stringsearch/${PORTVERSION}/ \
- http://kerneled.org/tmp/
-PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
COMMENT= Boyer-Moore/Knuth-Morris-Pratt string search library
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-
-GHC_VERSION= 6.10.4
-STRINGSEARCH_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-STRINGSEARCH_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- STRINGSEARCH_VERSION=${STRINGSEARCH_VERSION} \
- STRINGSEARCH_LIBDIR_REL=${STRINGSEARCH_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${STRINGSEARCH_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>