aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/htdig/Makefile
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-10-29 09:19:10 +0800
committerbillf <billf@FreeBSD.org>1999-10-29 09:19:10 +0800
commitecf8e9043bb89f30feb6d9f6e54064daac58d7a1 (patch)
tree9cb57b960b0e5593df3feef19638a6eaa89f7ace /textproc/htdig/Makefile
parent225d8d1bb852f9a884acc38d45332feef81f9a8e (diff)
downloadfreebsd-ports-gnome-ecf8e9043bb89f30feb6d9f6e54064daac58d7a1.tar.gz
freebsd-ports-gnome-ecf8e9043bb89f30feb6d9f6e54064daac58d7a1.tar.zst
freebsd-ports-gnome-ecf8e9043bb89f30feb6d9f6e54064daac58d7a1.zip
Upgrade to 3.1.3
Submitted by: Doug Barton <doug@gorean.org> lots of others who missed PLIST stuff.
Diffstat (limited to 'textproc/htdig/Makefile')
-rw-r--r--textproc/htdig/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index 507a48c42003..02f55c791286 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: htdig
-# Version required: 3.1.2
+# Version required: 3.1.3
# Date created: 18 August 1998
# Whom: Bill Fumerola <billf@chc-chimes.com>
#
# $FreeBSD$
#
-DISTNAME= htdig-3.1.2
+DISTNAME= htdig-3.1.3
CATEGORIES= textproc www
MASTER_SITES= http://www.htdig.org/files/ \
${MASTER_SITE_SUNSITE} \
@@ -16,6 +16,10 @@ MASTER_SITES= http://www.htdig.org/files/ \
ftp://ftp.htdig.org/pub/htdig/
MASTER_SITE_SUBDIR= apps/www/indexing
+PATCH_SITES= http://www.htdig.org/files/contrib/other/
+PATCHFILES= htdig-3.1.3-urlparmbug.patch
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= billf@FreeBSD.org
Y2K= http://www.htdig.org/FAQ.html#q1.7
@@ -26,17 +30,20 @@ CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/www/cgi-bin \
--with-search-dir=${PREFIX}/www/data
BUILD_TARGET= depends all
-# XXX - Please see patches/patch-aa, as it modifies this
-# file too. This is wrong, and one day I'll make sed do
-# everything.
-
post-patch:
- ${MV} ${WRKSRC}/CONFIG.in ${WRKSRC}/CONFIG.in.old
- ${SED} -e 's#htdocs#data#g' \
+ @ ${MV} ${WRKSRC}/CONFIG.in ${WRKSRC}/CONFIG.in.Dist
+ @ ${SED} -e 's#htdocs#data#g' \
+ -e 's#/conf#/etc#' \
+ -e 's#/common#/share/htdig#' \
+ -e 's#/db#/share/htdig#' \
+ ${WRKSRC}/CONFIG.in.Dist > ${WRKSRC}/CONFIG.in
+
+ @ ${MV} ${WRKSRC}/CONFIG ${WRKSRC}/CONFIG.Dist
+ @ ${SED} -e 's#htdocs#data#g' \
-e 's#/conf#/etc#' \
-e 's#/common#/share/htdig#' \
-e 's#/db#/share/htdig#' \
- ${WRKSRC}/CONFIG.in.old > ${WRKSRC}/CONFIG.in
+ ${WRKSRC}/CONFIG.Dist > ${WRKSRC}/CONFIG
.include <bsd.port.mk>