aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/htmlise/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-04 22:49:17 +0800
committerpav <pav@FreeBSD.org>2005-09-04 22:49:17 +0800
commit7a836f8ed2c0c26e8d779ede48c1a7a273ddd3b6 (patch)
treec03b00b6e050d0af7052dbddc1502f24551a81d2 /textproc/htmlise/Makefile
parent3c89645981981c65c31cda28b9587828f0739062 (diff)
downloadfreebsd-ports-gnome-7a836f8ed2c0c26e8d779ede48c1a7a273ddd3b6.tar.gz
freebsd-ports-gnome-7a836f8ed2c0c26e8d779ede48c1a7a273ddd3b6.tar.zst
freebsd-ports-gnome-7a836f8ed2c0c26e8d779ede48c1a7a273ddd3b6.zip
A command line utility that formats plain text from standard input to HTML
PR: ports/85618 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'textproc/htmlise/Makefile')
-rw-r--r--textproc/htmlise/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/htmlise/Makefile b/textproc/htmlise/Makefile
new file mode 100644
index 000000000000..db119bf02b05
--- /dev/null
+++ b/textproc/htmlise/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: htmlise
+# Date created: 2 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlise
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.ex-parrot.com/~chris/stuff/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Formats plain text as HTML
+
+USE_REINPLACE= yes
+
+TABSIZE?= 8
+
+SRC= htmlise tables markup inline
+PLIST_FILES= bin/htmlise
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(TABSIZE\ \)[0-9]*|\1${TABSIZE}|' \
+ ${WRKSRC}/${PORTNAME}.h
+
+do-build:
+.for f in ${SRC}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${SRC:C/(.*)/${WRKSRC}\/\1.o/}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>