aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hyphen
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-07-20 23:21:11 +0800
committerbapt <bapt@FreeBSD.org>2011-07-20 23:21:11 +0800
commit402d15358d5d47aaf46b408b6ca18e10688fd344 (patch)
tree75a29330da5f3d700b5368520dd1b40ac589f6b4 /textproc/hyphen
parent66f8ede3ec6ec0958729682634ec40025842e1ee (diff)
downloadfreebsd-ports-gnome-402d15358d5d47aaf46b408b6ca18e10688fd344.tar.gz
freebsd-ports-gnome-402d15358d5d47aaf46b408b6ca18e10688fd344.tar.zst
freebsd-ports-gnome-402d15358d5d47aaf46b408b6ca18e10688fd344.zip
Add alias for all english locales
Diffstat (limited to 'textproc/hyphen')
-rw-r--r--textproc/hyphen/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/textproc/hyphen/Makefile b/textproc/hyphen/Makefile
index 82aee9280e15..e4a00c1673f5 100644
--- a/textproc/hyphen/Makefile
+++ b/textproc/hyphen/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hyphen
PORTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF/hunspell/Hyphen/2.7/
@@ -21,4 +22,17 @@ USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
+USALIASES= en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK \
+ en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW
+
+.for ALIAS in ${USALIASES}
+PLIST_FILES+= share/hyphen/hyph_${ALIAS}.dic
+.endfor
+
+post-install:
+ @cd ${DATADIR}; \
+ for alias in ${USALIASES}; do \
+ ${LN} -s hyph_en_US.dic hyph_$${alias}.dic ; \
+ done
+
.include <bsd.port.mk>