aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ibus/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-11-04 16:22:29 +0800
committerwen <wen@FreeBSD.org>2010-11-04 16:22:29 +0800
commita254b148ebbea8e858ca9cc2bb96a46ebf8ab583 (patch)
tree49383ec36753ebf3851ea6055c01cbf9a0c9c827 /textproc/ibus/Makefile
parent33d5b557e2b085d493e2282b602493d42298c23c (diff)
downloadfreebsd-ports-gnome-a254b148ebbea8e858ca9cc2bb96a46ebf8ab583.tar.gz
freebsd-ports-gnome-a254b148ebbea8e858ca9cc2bb96a46ebf8ab583.tar.zst
freebsd-ports-gnome-a254b148ebbea8e858ca9cc2bb96a46ebf8ab583.zip
- Update to 1.3.8
PR: ports/149616 Submitted by: Jin-Sih Lin <linpct@gmail.com> Approved by: maintainer
Diffstat (limited to 'textproc/ibus/Makefile')
-rw-r--r--textproc/ibus/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index 52fb33b9237b..7102089c160d 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -6,17 +6,19 @@
#
PORTNAME= ibus
-PORTVERSION= 1.3.5
+PORTVERSION= 1.3.8
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= Intelligent Input Bus for Linux / Unix OS
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus \
+ librsvg2>=2.0:${PORTSDIR}/graphics/librsvg2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
- ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
+ ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
+ librsvg2>=2.0:${PORTSDIR}/graphics/librsvg2
USE_PYTHON= yes
USE_GNOME= pygtk2 gconf2
@@ -29,7 +31,8 @@ INSTALLS_ICONS= yes
GCONF_SCHEMAS= ibus.schemas
OPTIONS= ISOCODES "Use isocodecs" on \
- VALA "Install vala binding" on
+ VALA "Install vala binding" on \
+ GINTRO "Install GObject Introspection data" on
.include <bsd.port.pre.mk>
@@ -57,6 +60,16 @@ CONFIGURE_ARGS+= --disable-vala
PLIST_SUB+= VALA="@comment "
.endif
+.if defined(WITH_GINTRO)
+BUILD_DEPENDS+= gobject-introspection>=0.6.8:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS+= gobject-introspection>=0.6.8:${PORTSDIR}/devel/gobject-introspection
+CONFIGURE_ARGS+= --enable-introspection=yes
+PLIST_SUB+= GINTRO=""
+.else
+CONFIGURE_ARGS+= --enable-introspection=no
+PLIST_SUB+= GINTRO="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/share/xml/iso-codes/|${LOCALBASE}/share/xml/iso-codes/|g' ${WRKSRC}/ibus/lang.py