aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ibus/files
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-11-20 15:22:11 +0800
committerwen <wen@FreeBSD.org>2009-11-20 15:22:11 +0800
commitedda1c8c98601034339a3f289a8ff549b9459b91 (patch)
treee1f943f0f9a2e36b7faeed5ea2acad7edc1ed20a /textproc/ibus/files
parent0a4e69272841777706f0677eab73c573a527ff7c (diff)
downloadfreebsd-ports-gnome-edda1c8c98601034339a3f289a8ff549b9459b91.tar.gz
freebsd-ports-gnome-edda1c8c98601034339a3f289a8ff549b9459b91.tar.zst
freebsd-ports-gnome-edda1c8c98601034339a3f289a8ff549b9459b91.zip
- Update to 1.2.0.20091024
- Fix the crash of ibus-gconf on amd64 systems PR: ports/140663 Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Diffstat (limited to 'textproc/ibus/files')
-rw-r--r--textproc/ibus/files/patch-src_ibusconfigprivate.h20
-rw-r--r--textproc/ibus/files/patch-util_IMdkit_Makefile.in21
2 files changed, 41 insertions, 0 deletions
diff --git a/textproc/ibus/files/patch-src_ibusconfigprivate.h b/textproc/ibus/files/patch-src_ibusconfigprivate.h
new file mode 100644
index 000000000000..356e8602a06d
--- /dev/null
+++ b/textproc/ibus/files/patch-src_ibusconfigprivate.h
@@ -0,0 +1,20 @@
+--- src/ibusconfigprivate.h.orig 2009-11-14 11:44:58.000000000 +0800
++++ src/ibusconfigprivate.h 2009-11-14 11:45:31.000000000 +0800
+@@ -28,7 +28,7 @@
+ g_assert (iter != NULL);
+ g_assert (value != NULL);
+
+- gint type;
++ GType type;
+ IBusMessageIter sub_iter;
+
+ type = ibus_message_iter_get_arg_type (iter);
+@@ -83,7 +83,7 @@
+ if (type == IBUS_TYPE_ARRAY) {
+ GValue v = { 0 };
+ IBusMessageIter sub_iter;
+- gint sub_type;
++ GType sub_type;
+ GValueArray *array;
+
+
diff --git a/textproc/ibus/files/patch-util_IMdkit_Makefile.in b/textproc/ibus/files/patch-util_IMdkit_Makefile.in
new file mode 100644
index 000000000000..7ae1f8c99f69
--- /dev/null
+++ b/textproc/ibus/files/patch-util_IMdkit_Makefile.in
@@ -0,0 +1,21 @@
+--- util/IMdkit/Makefile.in.orig 2009-11-10 13:51:17.000000000 +0800
++++ util/IMdkit/Makefile.in 2009-11-10 14:03:55.000000000 +0800
+@@ -306,6 +306,9 @@
+ IMValues.c \
+ $(NULL)
+
++libIMdkit_la_CFLAGS = \
++ @X11_CFLAGS@
++
+ noinst_HEADERS = \
+ FrameMgr.h \
+ IMdkit.h \
+@@ -396,7 +399,7 @@
+ @am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
+
+ .c.lo:
+-@am__fastdepCC_TRUE@ $(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
++@am__fastdepCC_TRUE@ $(LTCOMPILE) ${libIMdkit_la_CFLAGS} -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@