aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-gtk
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-03-04 19:38:18 +0800
committerdaichi <daichi@FreeBSD.org>2005-03-04 19:38:18 +0800
commite7badae326222207e55c2db855589599e59da059 (patch)
tree20e62c3824b66b0d794469cf89706ea411f3ca3b /textproc/iiimf-gtk
parentfd9019ca0a57f34d2c9dffc06a547161e38f6df0 (diff)
downloadfreebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.tar.gz
freebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.tar.zst
freebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.zip
IIIMF-related ports some changes:
- support CFLAGS of /etc/make.conf - replace absolute path with ${LOCALBASE}, ${PREFIX} and others - replace -pthread flags with ${THREAD*} - m17n fixed of gnome-im-swither - fixed vid krisbot Submitted by: Masanori OZAWA <ozawa@ongs.co.jp>
Diffstat (limited to 'textproc/iiimf-gtk')
-rw-r--r--textproc/iiimf-gtk/Makefile40
-rw-r--r--textproc/iiimf-gtk/files/patch-Makefile2
-rw-r--r--textproc/iiimf-gtk/files/patch-acfiles_check_sys.m438
-rw-r--r--textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.am3
-rw-r--r--textproc/iiimf-gtk/files/patch-iiimgcf_autogen.sh73
-rw-r--r--textproc/iiimf-gtk/files/patch-iiimgcf_configure.ac20
-rw-r--r--textproc/iiimf-gtk/files/patch-iiimgcf_imaux.c2
-rw-r--r--textproc/iiimf-gtk/pkg-plist15
8 files changed, 99 insertions, 94 deletions
diff --git a/textproc/iiimf-gtk/Makefile b/textproc/iiimf-gtk/Makefile
index ece92b38bb2d..2be419361f9f 100644
--- a/textproc/iiimf-gtk/Makefile
+++ b/textproc/iiimf-gtk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
PKGNAMEPREFIX= iiimf-
@@ -24,12 +25,16 @@ USE_X_PREFIX= yes
IIIMF_VER= r12_1-svn2002
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= intltool gtk20
-WANT_AUTOCONF_VER=253
-WANT_AUTOHEADER_VER=253
-WANT_AUTOMAKE_VER=15
-WANT_LIBTOOL_VER=15
+USE_AUTOCONF_VER= 259
+USE_AUTOHEADER_VER= 259
+USE_AUTOMAKE_VER= 19
+WANT_LIBTOOL_VER= 15
+
+AUTOMAKE_ARGS+= --add-missing
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/iiimgcf
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
@@ -44,21 +49,32 @@ IGNORE= "It is supported on FreeBSD 5.3 and later"
IGNORE= "${ARCH} is not support."
.endif
-MAKE_ARGS+= LIBTOOL="${LIBTOOL} --tag=CXX"
+CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib -lintl ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
UPDATE_ARGS+= ACLOCAL=${ACLOCAL} AUTOMAKE=${AUTOMAKE} \
AUTOHEADER=${AUTOHEADER} AUTOCONF=${AUTOCONF} \
- LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE}
+ LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
+ ACLOCAL_DIR="-I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}"
+TLZ_ARGS= --copy --force
post-patch:
- ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${REINPLACE_CMD} -e "s,/usr/lib/im,${LOCALBASE}/lib/im,g" \
${WRKSRC}/../acfiles/im_common.m4
pre-configure:
- (cd ${WRKSRC}/.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles)
- (cd ${WRKSRC}/../acfiles/ && ${TOUCH} ltconfig)
-
-do-configure:
- (cd ${WRKSRC} && ./autogen.sh --prefix=${PREFIX})
+ @cd ${WRKSRC}/.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles
+ @cd ${WRKSRC} && glib-gettextize ${TLZ_ARGS}
+ @cd ${WRKSRC} && intltoolize ${TLZ_ARGS}
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} ${TLZ_ARGS}
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
+ -I ../acfiles -I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}
+ @cd ${WRKSRC} && ${REINPLACE_CMD} \
+ -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
+ -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
+ -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
+ ${LIBTOOLFILES}
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER}
post-install:
${X11BASE}/bin/gtk-query-immodules-2.0 > \
diff --git a/textproc/iiimf-gtk/files/patch-Makefile b/textproc/iiimf-gtk/files/patch-Makefile
index 85df0e345035..bcc2cb24a1c8 100644
--- a/textproc/iiimf-gtk/files/patch-Makefile
+++ b/textproc/iiimf-gtk/files/patch-Makefile
@@ -13,7 +13,7 @@
update-acfiles:
cd acfiles && \
- $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && libtoolize --force --copy && \
-+ $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
++ $(ACLOCAL) $(ACLOCAL_DIR) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
rm -f Makefile.in aclocal.m4
config:
diff --git a/textproc/iiimf-gtk/files/patch-acfiles_check_sys.m4 b/textproc/iiimf-gtk/files/patch-acfiles_check_sys.m4
new file mode 100644
index 000000000000..8626eeae1fd1
--- /dev/null
+++ b/textproc/iiimf-gtk/files/patch-acfiles_check_sys.m4
@@ -0,0 +1,38 @@
+--- acfiles/check_sys.m4.orig Tue Sep 14 13:31:27 2004
++++ acfiles/check_sys.m4 Wed Mar 2 08:39:25 2005
+@@ -203,6 +203,11 @@
+ CXX=${CC}
+ fi
+ ;;
++ cc*:*)
++ COMMON_CFLAGS="${COMMON_CFLAGS} -Wall"
++ SHLIBCFLAGS='-fpic'
++ SHLIBLDFLAGS='-shared'
++ ;;
+ *)
+ DEBUG_CXX_CFLAGS="${DEBUG_CXX_CFLAGS} -g"
+ ;;
+@@ -249,8 +254,8 @@
+ COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
+ ;;
+ *freebsd*)
+- THREAD_LDFLAGS="-pthread"
+- PTHREAD_LIBS=""
++ THREAD_LDFLAGS=""
++ PTHREAD_LIBS="${PTHREAD_LIBS}"
+ ;;
+ esac
+
+@@ -288,9 +293,9 @@
+ THREAD_CXX_CFLAGS="-mt"
+ HAVE_THREAD="uithread"
+ ;;
+- *freebsd*@gcc:*)
+- THREAD_LDFLAGS="-pthread"
+- THREAD_LIBS=""
++ *freebsd*@cc:*|*freebsd*@gcc:*)
++ THREAD_LDFLAGS=""
++ THREAD_LIBS="${PTHREAD_LIBS}"
+ HAVE_THREAD="freebsd-pthread"
+ ;;
+ *linux*)
diff --git a/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.am b/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.am
index 73e32f812d61..7588f7b783df 100644
--- a/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.am
+++ b/textproc/iiimf-gtk/files/patch-iiimgcf_Makefile.am
@@ -3,7 +3,8 @@
@@ -9,14 +9,13 @@
moduledir = $(GTK2_LIBDIR)/gtk-2.0/$(GTK2_BINARY_VERSION)/immodules
- im_iiim_la_CFLAGS = $(SHLIBCFLAGS) $(THREAD_CXX_CFLAGS) $(GTK_CFLAGS)
+-im_iiim_la_CFLAGS = $(SHLIBCFLAGS) $(THREAD_CXX_CFLAGS) $(GTK_CFLAGS)
++im_iiim_la_CFLAGS = $(SHLIBCFLAGS) $(THREAD_CXX_CFLAGS) $(GTK_CFLAGS) -DIMDIR="\"${IMDIR}\""
-im_iiim_la_LDFLAGS = -rpath $(moduledir) -avoid-version -module -no-undefined
+im_iiim_la_LDFLAGS = -rpath $(moduledir) -avoid-version -module -no-undefined \
+ -liiimcf -liiimp
diff --git a/textproc/iiimf-gtk/files/patch-iiimgcf_autogen.sh b/textproc/iiimf-gtk/files/patch-iiimgcf_autogen.sh
deleted file mode 100644
index db71f9c186bd..000000000000
--- a/textproc/iiimf-gtk/files/patch-iiimgcf_autogen.sh
+++ /dev/null
@@ -1,73 +0,0 @@
---- iiimgcf/autogen.sh Thu Dec 11 17:29:28 2003
-+++ iiimgcf/autogen.sh Wed Feb 16 16:48:14 2005
-@@ -12,7 +12,15 @@
-
- DIE=0
-
--(libtool --version) < /dev/null > /dev/null 2>&1 || {
-+LIBTOOL=libtool15
-+INTLTOOLIZE=intltoolize
-+LIBTOOLIZE=libtoolize15
-+ACLOCAL=aclocal15
-+AUTOHEADER=autoheader253
-+AUTOMAKE=automake15
-+AUTOCONF=autoconf253
-+
-+(${LIBTOOL} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have libtool installed to compile $PROJECT."
- echo "Install the appropriate package for your distribution,"
-@@ -30,7 +38,7 @@
- }
-
- (grep "^AC_PROG_INTLTOOL" $srcdir/configure.ac >/dev/null) && {
-- (intltoolize --version) < /dev/null > /dev/null 2>&1 || {
-+ (${INTLTOOLIZE} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: You must have \`intltoolize' installed to compile $PKG_NAME."
- echo "Get ftp://ftp.gnome.org/pub/GNOME/stable/sources/intltool/intltool-0.10.tar.gz"
-@@ -39,7 +47,7 @@
- }
- }
-
--(autoconf --version) < /dev/null > /dev/null 2>&1 || {
-+(${AUTOCONF} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "You must have autoconf installed to compile $PROJECT."
- echo "libtool the appropriate package for your distribution,"
-@@ -48,8 +56,8 @@
- }
-
- have_automake=false
--if automake --version < /dev/null > /dev/null 2>&1 ; then
-- automake_version=`automake --version | grep 'automake (GNU automake)' | sed 's/^[^0-9]*\(.*\)/\1/'`
-+if ${AUTOMAKE} --version < /dev/null > /dev/null 2>&1 ; then
-+ automake_version=`${AUTOMAKE} --version | grep 'automake (GNU automake)' | sed 's/^[^0-9]*\(.*\)/\1/'`
- case $automake_version in
- 1.2*|1.3*|1.4)
- ;;
-@@ -96,19 +104,19 @@
- fi
- if grep "^AC_PROG_INTLTOOL" configure.ac >/dev/null; then
- echo "Running intltoolize..."
-- intltoolize --copy --force --automake
-+ ${INTLTOOLIZE} --copy --force --automake
- fi
-
- # intentionally we don't call "libtoolize --force"
- # to avoid overriding ../acfiles/ltmain.h, which we don't want to happen!
-
--aclocal -I ../acfiles $ACLOCAL_FLAGS
-+${ACLOCAL} -I ../acfiles $ACLOCAL_FLAGS
-
- # optionally feature autoheader
--(autoheader --version) < /dev/null > /dev/null 2>&1 && autoheader
-+(${AUTOHEADER} --version) < /dev/null > /dev/null 2>&1 && ${AUTOHEADER}
-
--automake -a $am_opt
--autoconf
-+${AUTOMAKE} -a $am_opt
-+${AUTOCONF}
- cd $ORIGDIR
-
- if test -z "$AUTOGEN_SUBDIR_MODE"; then
diff --git a/textproc/iiimf-gtk/files/patch-iiimgcf_configure.ac b/textproc/iiimf-gtk/files/patch-iiimgcf_configure.ac
index c96ee88f74af..375a272d8a40 100644
--- a/textproc/iiimf-gtk/files/patch-iiimgcf_configure.ac
+++ b/textproc/iiimf-gtk/files/patch-iiimgcf_configure.ac
@@ -1,19 +1,27 @@
---- iiimgcf/configure.ac Tue Nov 18 12:17:57 2003
-+++ iiimgcf/configure.ac Thu Feb 17 15:26:50 2005
-@@ -63,13 +63,13 @@
+--- iiimgcf/configure.ac.orig Tue Nov 18 12:17:57 2003
++++ iiimgcf/configure.ac Wed Mar 2 22:59:24 2005
+@@ -5,7 +5,6 @@
+ AC_PREREG(2.50)
+ AC_INIT(im-iiim.so, 0.5, im@OpenI18N.org)
+ dnl common initialization
+-AC_CONFIG_AUX_DIR(../acfiles)
+ IM_INIT(..)
+
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
+@@ -63,13 +62,13 @@
COMMON_INCLUDE='-I$(IM_INCLUDEDIR) -I$(IM_INCLUDEDIR)/iiimp'
CFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CFLAGS} \
${DEBUG_CXX_CFLAGS} ${DEBUG_CFLAGS} \
- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include -I/usr/X11R6/include"
++ ${THREAD_COMMON_CXX_CFLAGS} ${CFLAGS}"
CXXFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CXXFLAGS} \
${DEBUG_CXX_CFLAGS} ${DEBUG_CXXFLAGS} \
- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include -I/usr/X11R6/include"
++ ${THREAD_COMMON_CXX_CFLAGS} ${CXXFLAGS}"
-LDFLAGS="${COMMON_LDFLAGS}"
-+LDFLAGS="${COMMON_LDFLAGS} -L/usr/local/lib -L/usr/X11R6/lib"
++LDFLAGS="${COMMON_LDFLAGS} ${LDFLAGS}"
dnl --------------------------------------------------------------------------------
dnl Section 6: compilation test
diff --git a/textproc/iiimf-gtk/files/patch-iiimgcf_imaux.c b/textproc/iiimf-gtk/files/patch-iiimgcf_imaux.c
index ffc17a98f5df..dda9b5a7c069 100644
--- a/textproc/iiimf-gtk/files/patch-iiimgcf_imaux.c
+++ b/textproc/iiimf-gtk/files/patch-iiimgcf_imaux.c
@@ -5,7 +5,7 @@
static void iiim_aux_download (IIIMCF_downloaded_object obj);
-#define AUX_BASE_DIR "/usr/lib/im/"
-+#define AUX_BASE_DIR "/usr/local/lib/im/"
++#define AUX_BASE_DIR IMDIR
#define IS_SPACE(len, ptr) ((0 < (len)) && \
(('\t' == *(p)) || (' ' == *(p))))
diff --git a/textproc/iiimf-gtk/pkg-plist b/textproc/iiimf-gtk/pkg-plist
index 20ba7596cbc3..4aa087166452 100644
--- a/textproc/iiimf-gtk/pkg-plist
+++ b/textproc/iiimf-gtk/pkg-plist
@@ -1,3 +1,18 @@
lib/gtk-2.0/2.4.0/immodules/im-iiim.so
@exec %D/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
@unexec %D/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
+share/locale/ja/LC_MESSAGES/iiimgcf.mo
+@unexec rmdir %D/share/locale/ja/LC_MESSAGES > /dev/null 2>&1 || true
+@unexec rmdir %D/share/locale/ja > /dev/null 2>&1 || true
+share/locale/ko/LC_MESSAGES/iiimgcf.mo
+@unexec rmdir %D/share/locale/ko/LC_MESSAGES > /dev/null 2>&1 || true
+@unexec rmdir %D/share/locale/ko > /dev/null 2>&1 || true
+share/locale/zh_CN/LC_MESSAGES/iiimgcf.mo
+@unexec rmdir %D/share/locale/zh_CN/LC_MESSAGES > /dev/null 2>&1 || true
+@unexec rmdir %D/share/locale/zh_CN > /dev/null 2>&1 || true
+share/locale/zh_TW/LC_MESSAGES/iiimgcf.mo
+@unexec rmdir %D/share/locale/zh_TW/LC_MESSAGES > /dev/null 2>&1 || true
+@unexec rmdir %D/share/locale/zh_TW > /dev/null 2>&1 || true
+share/locale/zh_HK/LC_MESSAGES/iiimgcf.mo
+@unexec rmdir %D/share/locale/zh_HK/LC_MESSAGES > /dev/null 2>&1 || true
+@unexec rmdir %D/share/locale/zh_HK > /dev/null 2>&1 || true