aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-server
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-12 21:11:16 +0800
committermiwi <miwi@FreeBSD.org>2008-01-12 21:11:16 +0800
commite41306140ebc24295f50527b8254a2dfd7686ce4 (patch)
treece4cb1f76cd5f5ad98ac1096c3d6987d0e65c30d /textproc/iiimf-server
parentf7ca25d90a83518ff2f06cae89ca8c9cf70f05a6 (diff)
downloadfreebsd-ports-gnome-e41306140ebc24295f50527b8254a2dfd7686ce4.tar.gz
freebsd-ports-gnome-e41306140ebc24295f50527b8254a2dfd7686ce4.tar.zst
freebsd-ports-gnome-e41306140ebc24295f50527b8254a2dfd7686ce4.zip
- Fix build with gcc 4.2
- S/INSTALLS_SHLIB/USE_LDCONFIG PR: 118937 Submitted by: Pietro Cerutti <gahr@gahr.ch>
Diffstat (limited to 'textproc/iiimf-server')
-rw-r--r--textproc/iiimf-server/Makefile6
-rw-r--r--textproc/iiimf-server/files/patch-iiimsf-src_IMSvrXMLConf.hh11
2 files changed, 12 insertions, 5 deletions
diff --git a/textproc/iiimf-server/Makefile b/textproc/iiimf-server/Makefile
index 989663c5bd4a..8d4c3974f815 100644
--- a/textproc/iiimf-server/Makefile
+++ b/textproc/iiimf-server/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= iiimp.1:${PORTSDIR}/textproc/iiimf-protocol-lib
ONLY_FOR_ARCHS= i386
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_RC_SUBR= iiimd.sh
USE_BZIP2= yes
USE_GMAKE= yes
@@ -37,10 +37,6 @@ BUILDDIR= ${WRKSRC}/iiimsf
IGNORE= is supported on FreeBSD 5.3 and later only
.endif
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if defined(WITH_DEBUG)
CFLAGS+= -g -ggdb -DDEBUG
.endif
diff --git a/textproc/iiimf-server/files/patch-iiimsf-src_IMSvrXMLConf.hh b/textproc/iiimf-server/files/patch-iiimsf-src_IMSvrXMLConf.hh
new file mode 100644
index 000000000000..25fa8eb7c333
--- /dev/null
+++ b/textproc/iiimf-server/files/patch-iiimsf-src_IMSvrXMLConf.hh
@@ -0,0 +1,11 @@
+--- iiimsf/src/IMSvrXMLConf.hh.orig 2007-12-21 19:19:48.000000000 +0100
++++ iiimsf/src/IMSvrXMLConf.hh 2007-12-21 19:20:00.000000000 +0100
+@@ -14,7 +14,7 @@
+
+ IMAuth::access_type get_access_type(xmlChar *key);
+
+- string IMSvrXMLConf::parse_text_node(xmlNodePtr &node);
++ string parse_text_node(xmlNodePtr &node);
+ string parse_hostname_node(xmlNodePtr &node);
+ string parse_port_node(xmlNodePtr &node);
+ string parse_file_node(xmlNodePtr &node);