aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-x/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-29 12:17:02 +0800
committeredwin <edwin@FreeBSD.org>2003-12-29 12:17:02 +0800
commitbe400dd1c736ef23c23574408ebc8c906018cfb3 (patch)
tree187e4066cc3c513689d0f87b8271e10904493cf2 /textproc/iiimf-x/Makefile
parent4023f64d07ade58b6d61d5d85d1586cd40c7f23a (diff)
downloadfreebsd-ports-gnome-be400dd1c736ef23c23574408ebc8c906018cfb3.tar.gz
freebsd-ports-gnome-be400dd1c736ef23c23574408ebc8c906018cfb3.tar.zst
freebsd-ports-gnome-be400dd1c736ef23c23574408ebc8c906018cfb3.zip
New port: iiimf-*
IIIMF stands for Internet/Intranet Input Method Framework. IIIMF is designed to be the next generation of input method framework which provides the following capabilities; * Multiplatform, platform independent. * Multlingual and Full UNICODE support, but satisfactory for native speakers. * Windowing System Independent. * Multiple language engines concurrently run. * Multiuser. * Distributed, lightweight clients and scalable server. * Extensible in multiple means. * Input method protocol efficient enough to be used over low-speed modem connection. * Easy input method engine development with plugin API. * Easy input method enabling with libiiimcf, even on console apps. * Small core part to start from. WWW: http://www.openi18n.org/subgroups/im/IIIMF/ - Kuang-che Wu kcwu@csie.org PR: ports/60087 Submitted by: Kuang-che Wu <kcwu@csie.org>
Diffstat (limited to 'textproc/iiimf-x/Makefile')
-rw-r--r--textproc/iiimf-x/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
new file mode 100644
index 000000000000..381589ee91e6
--- /dev/null
+++ b/textproc/iiimf-x/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: iiimf-x
+# Date created: 6 Dec 2003
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-x
+PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method X Client Framework
+
+LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
+ iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+
+IIIMF_VER= r11_4-1467
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+USE_MOTIF= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+DIRS= iiimxcf/xiiimp.so iiimxcf/htt_xbe
+
+post-patch:
+.for DIR in ${DIRS}
+ ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
+ -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
+ -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
+ -e "s,/usr/lib/im,${LOCALBASE}/lib/im,g" \
+ -e "s,-I\$$(IM_INCLUDEDIR),-I${LOCALBASE}/include/iiimf,g" \
+ ${WRKSRC}/${DIR}/configure
+ ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/Makefile.in \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpAux.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpIM.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpConv.c \
+ ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/csconv.h \
+ ${WRKSRC}/iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp \
+ ${WRKSRC}/iiimxcf/htt_xbe/src/watchdog.c
+.endfor
+
+do-configure:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${SH} configure ${CONFIGURE_ARGS}
+.endfor
+
+do-build:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${GMAKE} all
+.endfor
+
+do-install:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${GMAKE} install
+.endfor
+
+.include <bsd.port.mk>