aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-x
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-02-28 12:17:02 +0800
committerdaichi <daichi@FreeBSD.org>2005-02-28 12:17:02 +0800
commit34372a2a0e3f9c044221130d553f88e81cfe6784 (patch)
treeab3dbe35a6c1f34d8d8a8ac17e2afc63112da562 /textproc/iiimf-x
parente333aa6d280536046fa2038fa60f302d2f150241 (diff)
downloadfreebsd-ports-gnome-34372a2a0e3f9c044221130d553f88e81cfe6784.tar.gz
freebsd-ports-gnome-34372a2a0e3f9c044221130d553f88e81cfe6784.tar.zst
freebsd-ports-gnome-34372a2a0e3f9c044221130d553f88e81cfe6784.zip
IIIMF-related ports: Update to r12_1-svn2002 and bug fixes
PR: ports/77927 Submitted by: Masanori OZAWA <ozawa@ongs.co.jp> Approved by: maintainer Pointed out by: ume, nork, hrs
Diffstat (limited to 'textproc/iiimf-x')
-rw-r--r--textproc/iiimf-x/Makefile49
-rw-r--r--textproc/iiimf-x/distinfo4
-rw-r--r--textproc/iiimf-x/files/patch-Makefile19
-rw-r--r--textproc/iiimf-x/files/patch-acfiles_check_sys.m436
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_autogen.sh93
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac21
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp11
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c13
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in13
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c43
-rw-r--r--textproc/iiimf-x/pkg-plist2
11 files changed, 199 insertions, 105 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
index cbc4446eed24..532538a31a56 100644
--- a/textproc/iiimf-x/Makefile
+++ b/textproc/iiimf-x/Makefile
@@ -10,8 +10,8 @@ PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
CATEGORIES= textproc
MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
PKGNAMEPREFIX= iiimf-
-DISTNAME= im-sdk
-DISTFILES= ${DISTNAME}-src-${IIIMF_VER}.tgz
+DISTNAME= im-sdk-src-${IIIMF_VER}
+EXTRACT_SUFX= .tar.bz2
MAINTAINER= kcwu@csie.org
COMMENT= Internet/Intranet Input Method X Client Framework
@@ -20,34 +20,43 @@ LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
RUN_DEPENDS= ${LOCALBASE}/lib/im/xiiimp.so:${PORTSDIR}/textproc/iiimf-x-lib
-IIIMF_VER= r12_0_1-svn1891
-WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/iiimxcf/htt_xbe
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
-USE_REINPLACE= yes
+IIIMF_VER= r12_1-svn2002
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
USE_XLIB= yes
-USE_AUTOCONF_VER= 259
-USE_AUTOHEADER_VER= 259
-USE_AUTOMAKE_VER= 19
-USE_LIBTOOL_VER= 15
-LIBTOOLFILES= ${WRKSRC}/aclocal.m4
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
+WANT_AUTOCONF_VER=253
+WANT_AUTOHEADER_VER=253
+WANT_AUTOMAKE_VER=15
+WANT_LIBTOOL_VER=15
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/iiimxcf/htt_xbe
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 503000
+IGNORE= "It is supported on FreeBSD 5.3 and later"
+.endif
+
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+IGNORE= "${ARCH} is not support."
.endif
+MAKE_ARGS+= LIBTOOL="${LIBTOOL} --tag=CXX"
+UPDATE_ARGS+= ACLOCAL=${ACLOCAL} AUTOMAKE=${AUTOMAKE} \
+ AUTOHEADER=${AUTOHEADER} AUTOCONF=${AUTOCONF} \
+ LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE}
+
post-patch:
${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
- ${WRKSRC}/../../acfiles/im_common.m4 \
- ${WRKSRC}/configure.ac \
- ${WRKSRC}/lib/IMdkit/common/XIMPublic.cpp \
- ${WRKSRC}/src/watchdog.c
+ ${WRKSRC}/../../acfiles/im_common.m4
pre-configure:
- cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal -I ../../acfiles
- ${TOUCH} ${WRKSRC}/config.h.in
+ (cd ${WRKSRC}/../.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles)
+ (cd ${WRKSRC}/../../acfiles/ && ${TOUCH} ltconfig)
+
+do-configure:
+ (cd ${WRKSRC} && ./autogen.sh --prefix=${PREFIX})
.include <bsd.port.post.mk>
diff --git a/textproc/iiimf-x/distinfo b/textproc/iiimf-x/distinfo
index 29d049a782bc..440e49d16220 100644
--- a/textproc/iiimf-x/distinfo
+++ b/textproc/iiimf-x/distinfo
@@ -1,2 +1,2 @@
-MD5 (im-sdk-src-r12_0_1-svn1891.tgz) = 4e51e4fd07391bd957622db0e89aeefe
-SIZE (im-sdk-src-r12_0_1-svn1891.tgz) = 18206118
+MD5 (im-sdk-src-r12_1-svn2002.tar.bz2) = 51f3f10b11f8d4a206e2b190ec36a32a
+SIZE (im-sdk-src-r12_1-svn2002.tar.bz2) = 18141292
diff --git a/textproc/iiimf-x/files/patch-Makefile b/textproc/iiimf-x/files/patch-Makefile
new file mode 100644
index 000000000000..85df0e345035
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile Thu Apr 8 03:28:00 2004
++++ Makefile Wed Feb 16 14:09:34 2005
+@@ -2,6 +2,7 @@
+ AUTOMAKE = automake
+ AUTOHEADER = autoheader
+ AUTOCONF = autoconf
++LIBTOOLIZE = libtoolize
+
+ CONFIG_CMD = $(ACLOCAL) -I $${acfilesdir} && \
+ $(AUTOHEADER) && \
+@@ -21,7 +22,7 @@
+
+ update-acfiles:
+ cd acfiles && \
+- $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && libtoolize --force --copy && \
++ $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
+ rm -f Makefile.in aclocal.m4
+
+ config:
diff --git a/textproc/iiimf-x/files/patch-acfiles_check_sys.m4 b/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
deleted file mode 100644
index 974f159f9098..000000000000
--- a/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
+++ /dev/null
@@ -1,36 +0,0 @@
---- acfiles/check_sys.m4.orig Thu Aug 12 18:01:23 2004
-+++ acfiles/check_sys.m4 Wed Sep 8 16:15:39 2004
-@@ -74,6 +74,11 @@
- ## Checks for thread library.
- AC_CHECK_LIB(pthread, pthread_create, [ HAVE_LIBPTHREAD="yes" ])
- AC_CHECK_LIB(thread, thr_create, [ HAVE_LIBUITHREAD="yes" ])
-+
-+ case "${target}" in
-+ *freebsd*) HAVE_LIBPTHREAD="yes";;
-+ esac
-+
- if test "X${HAVE_LIBPTHREAD}" = "Xyes" ; then
- HAVE_THREAD="pthread"
- elif test "X${HAVE_LIBUITHREAD}" = "Xyes" ; then
-@@ -210,8 +215,6 @@
- COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
- ;;
- *freebsd*)
-- THREAD_LDFLAGS="-pthread"
-- PTHREAD_LIBS=""
- ;;
- esac
-
-@@ -249,9 +252,9 @@
- THREAD_CXX_CFLAGS="-mt"
- HAVE_THREAD="uithread"
- ;;
-- *freebsd*@gcc:*)
-- THREAD_LDFLAGS="-pthread"
-- THREAD_LIBS=""
-+ *freebsd*)
-+ THREAD_CXX_CFLAGS="${PTHREAD_CFLAGS}"
-+ THREAD_LIBS="${PTHREAD_LIBS}"
- HAVE_THREAD="freebsd-pthread"
- ;;
- *linux*)
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_autogen.sh b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_autogen.sh
new file mode 100644
index 000000000000..f0f4457d5676
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_autogen.sh
@@ -0,0 +1,93 @@
+--- iiimxcf/htt_xbe/autogen.sh Wed Mar 24 04:54:26 2004
++++ iiimxcf/htt_xbe/autogen.sh Wed Feb 16 16:34:40 2005
+@@ -6,6 +6,14 @@
+
+ DIE=0
+
++LIBTOOL=libtool15
++INTLTOOLIZE=intltoolize15
++LIBTOOLIZE=libtoolize15
++ACLOCAL=aclocal15
++AUTOHEADER=autoheader253
++AUTOMAKE=automake15
++AUTOCONF=autoconf253
++
+ ACLOCAL_FLAGS="-I ../../acfiles $ACLOCAL_FLAGS"
+
+ if [ -n "$GNOME2_DIR" ]; then
+@@ -22,7 +30,7 @@
+ exit 1
+ }
+
+-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
++(${AUTOCONF} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`autoconf' installed."
+ echo "Download the appropriate package for your distribution,"
+@@ -31,7 +39,7 @@
+ }
+
+ (grep "^AC_PROG_INTLTOOL" $srcdir/configure.ac >/dev/null) && {
+- (intltoolize --version) < /dev/null > /dev/null 2>&1 || {
++ (${INTLTOOLIZE} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`intltool' installed."
+ echo "You can get it from:"
+@@ -41,7 +49,7 @@
+ }
+
+ (grep "^AM_PROG_LIBTOOL" $srcdir/configure.ac >/dev/null) && {
+- (libtool --version) < /dev/null > /dev/null 2>&1 || {
++ (${LIBTOOL} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`libtool' installed."
+ echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
+@@ -59,7 +67,7 @@
+ }
+ }
+
+-(automake --version) < /dev/null > /dev/null 2>&1 || {
++(${AUTOMAKE} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: You must have \`automake' installed."
+ echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
+@@ -69,7 +77,7 @@
+
+
+ # if no automake, don't bother testing for aclocal
+-test -n "$NO_AUTOMAKE" || (aclocal --version) < /dev/null > /dev/null 2>&1 || {
++test -n "$NO_AUTOMAKE" || (${ACLOCAL} --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "**Error**: Missing \`aclocal'. The version of \`automake'"
+ echo "installed doesn't appear recent enough."
+@@ -114,24 +122,24 @@
+ fi
+ if grep "^AC_PROG_INTLTOOL" configure.ac >/dev/null; then
+ echo "Running intltoolize..."
+- intltoolize --copy --force --automake
++ ${INTLTOOLIZE} --copy --force --automake
+ fi
+ if grep "^AM_PROG_LIBTOOL" configure.ac >/dev/null; then
+ if test -z "$NO_LIBTOOLIZE" ; then
+ echo "Running libtoolize..."
+- libtoolize --force --copy
++ ${LIBTOOLIZE} --force --copy
+ fi
+ fi
+ echo "Running aclocal $aclocalinclude ..."
+- aclocal $aclocalinclude
++ ${ACLOCAL} $aclocalinclude
+ if grep "^AM_CONFIG_HEADER" configure.ac >/dev/null; then
+ echo "Running autoheader..."
+- autoheader
++ ${AUTOHEADER}
+ fi
+ echo "Running automake --gnu $am_opt ..."
+- automake --add-missing --copy --gnu $am_opt
++ ${AUTOMAKE} --add-missing --copy --gnu $am_opt
+ echo "Running autoconf ..."
+- autoconf
++ ${AUTOCONF}
+ )
+ fi
+ done
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac
new file mode 100644
index 000000000000..4a523a953002
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac
@@ -0,0 +1,21 @@
+--- iiimxcf/htt_xbe/configure.ac Wed Mar 24 04:54:26 2004
++++ iiimxcf/htt_xbe/configure.ac Wed Feb 16 19:38:26 2005
+@@ -140,15 +140,15 @@
+ COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} ${DLOPEN_CXX_CFLAGS} -DSUPPORT_R6IM"
+ LIBS="${LIBS} ${DLOPEN_LIBS}"
+
+ CFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CFLAGS} \
+ ${DEBUG_CXX_CFLAGS} ${DEBUG_CFLAGS} \
+- ${THREAD_COMMON_CXX_CFLAGS}"
++ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/X11R6/include"
+
+ CXXFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CXXFLAGS} \
+ ${DEBUG_CXX_CFLAGS} ${DEBUG_CXXFLAGS} \
+- ${THREAD_COMMON_CXX_CFLAGS}"
++ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/X11R6/include"
+
+-LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS}"
++LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS} -L/usr/X11R6/lib"
+
+ dnl --------------------------------------------------------------------------------
+ dnl Section 6: compilation test
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp
new file mode 100644
index 000000000000..293e329921d1
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp
@@ -0,0 +1,11 @@
+--- iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp Wed Mar 24 04:54:26 2004
++++ iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp Wed Feb 16 21:31:00 2005
+@@ -68,7 +68,7 @@
+ #ifdef sun
+ #define XIIIMP_PATH "/usr/openwin/lib/locale/common/xiiimp.so.2"
+ #else /* Linux */
+-#define XIIIMP_PATH "/usr/lib/im/xiiimp.so.2"
++#define XIIIMP_PATH "/usr/local/lib/im/xiiimp.so.2"
+ #endif /* Linux */
+
+ #include <stdio.h>
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c
new file mode 100644
index 000000000000..586641366c0b
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c
@@ -0,0 +1,13 @@
+--- iiimxcf/htt_xbe/lib/IMdkit/r6im/i18nX.c Fri Nov 1 09:15:38 2002
++++ iiimxcf/htt_xbe/lib/IMdkit/r6im/i18nX.c Wed Feb 16 19:33:10 2005
+@@ -389,8 +389,8 @@
+ extern void _Xi18nMessageHandler(XIMS, CARD16,
+ unsigned char*, Bool*);
+ Bool delete = True;
+- unsigned char *packet;
+- int connect_id;
++ unsigned char *packet = NULL;
++ int connect_id = 0;
+
+ if (((XClientMessageEvent *)ev)->message_type ==
+ spec->xim_request) {
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in
deleted file mode 100644
index ce8a106a194e..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IMdkit_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- iiimxcf/htt_xbe/lib/IMdkit/Makefile.in.orig Sat Dec 6 05:14:14 2003
-+++ iiimxcf/htt_xbe/lib/IMdkit/Makefile.in Sat Dec 6 05:52:09 2003
-@@ -74,8 +74,8 @@
- LINKER = @LINKER@
- RANLIB = @RANLIB@
-
--CFLAGS = @CFLAGS@
--CXXFLAGS = @CXXFLAGS@
-+CFLAGS = @CFLAGS@ @X_CFLAGS@
-+CXXFLAGS = @CXXFLAGS@ @X_CFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
-
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
index 4fb312ab1af8..2fe21fde1504 100644
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
@@ -1,42 +1,19 @@
---- iiimxcf/htt_xbe/src/watchdog.c.orig Tue Jul 13 07:25:40 2004
-+++ iiimxcf/htt_xbe/src/watchdog.c Sun Sep 5 05:43:59 2004
-@@ -187,11 +187,15 @@
- * Setup the signal handlers to monitor htt_server, htt_props
- * abnormal termination
- */
-+#if defined(__FreeBSD__)
-+ setsid();
-+#else
- #ifdef SETPGRP_VOID
- grpid = setpgrp();
- #else
- grpid = setpgrp(0, 0);
+--- iiimxcf/htt_xbe/src/watchdog.c Tue Jul 13 08:25:40 2004
++++ iiimxcf/htt_xbe/src/watchdog.c Wed Feb 16 19:12:34 2005
+@@ -81,7 +81,7 @@
#endif
-+#endif
+ #define OPENWIN_MOTIF_PRELOAD_ENV "LD_PRELOAD=/usr/dt/lib/libXm.so.3"
- #ifdef SunOS
- sigset(SIGTERM, clean_up);
-@@ -708,11 +712,15 @@
- */
- sleep(1);
-
-+#if defined(__FreeBSD__)
-+ setsid();
-+#else
- #ifdef SETPGRP_VOID
- setpgrp();
- #else
- setpgrp(0, 0);
- #endif
-+#endif
+-#define IMDIR "/usr/lib/im"
++#define IMDIR "/usr/local/lib/im"
- #ifdef SunOS
- if (flag == OPENWIN_PATH) {
-@@ -744,7 +752,11 @@
+ static void start_htt_server(int *, char *argv[]);
+ static void start_htt_props(int *, char *argv[]);
+@@ -744,7 +744,11 @@
perror("watchdog:fork\n");
exit(errno);
case 0:
-+#if defined(__FreeBSD__)
++#ifdef __FreeBSD__
+ setsid();
+#else
setpgrp();
diff --git a/textproc/iiimf-x/pkg-plist b/textproc/iiimf-x/pkg-plist
index 3254b3e6e5b0..2f8604c6a8e4 100644
--- a/textproc/iiimf-x/pkg-plist
+++ b/textproc/iiimf-x/pkg-plist
@@ -1,2 +1,2 @@
-lib/im/htt_xbe
lib/im/httx
+lib/im/htt_xbe