aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-x
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-14 03:47:13 +0800
committerpav <pav@FreeBSD.org>2004-10-14 03:47:13 +0800
commit6b9e568a7d93f8220a0ae98e0c0f2defe4f158ce (patch)
treea16ddce0eec0b6d47e0e55be55249f93f0520822 /textproc/iiimf-x
parent031000ae9d4869d3605b20df6391a3984827c4fc (diff)
downloadfreebsd-ports-gnome-6b9e568a7d93f8220a0ae98e0c0f2defe4f158ce.tar.gz
freebsd-ports-gnome-6b9e568a7d93f8220a0ae98e0c0f2defe4f158ce.tar.zst
freebsd-ports-gnome-6b9e568a7d93f8220a0ae98e0c0f2defe4f158ce.zip
- Update to r12.0.1
PR: ports/72614 Submitted by: Kuang-che Wu <kcwu@csie.org> (maintainer)
Diffstat (limited to 'textproc/iiimf-x')
-rw-r--r--textproc/iiimf-x/Makefile74
-rw-r--r--textproc/iiimf-x/distinfo4
-rw-r--r--textproc/iiimf-x/files/patch-acfiles_check_sys.m436
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c31
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in22
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c11
-rw-r--r--textproc/iiimf-x/pkg-plist5
7 files changed, 78 insertions, 105 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
index 017f688fd262..cbc4446eed24 100644
--- a/textproc/iiimf-x/Makefile
+++ b/textproc/iiimf-x/Makefile
@@ -5,73 +5,49 @@
# $FreeBSD$
#
-PORTNAME= iiimf-x
-PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
-PORTREVISION= 1
+PORTNAME= x
+PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
CATEGORIES= textproc
-MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
+PKGNAMEPREFIX= iiimf-
DISTNAME= im-sdk
-DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}-src-${IIIMF_VER}.tgz
MAINTAINER= kcwu@csie.org
COMMENT= Internet/Intranet Input Method X Client Framework
LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+RUN_DEPENDS= ${LOCALBASE}/lib/im/xiiimp.so:${PORTSDIR}/textproc/iiimf-x-lib
-IIIMF_VER= r11_4-1467
-WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_XLIB= yes
-INSTALLS_SHLIB= yes
+IIIMF_VER= r12_0_1-svn1891
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/iiimxcf/htt_xbe
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
USE_REINPLACE= yes
-HAS_CONFIGURE= yes
-USE_MOTIF= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
-DIRS= iiimxcf/xiiimp.so iiimxcf/htt_xbe
+USE_XLIB= yes
+USE_AUTOCONF_VER= 259
+USE_AUTOHEADER_VER= 259
+USE_AUTOMAKE_VER= 19
+USE_LIBTOOL_VER= 15
+LIBTOOLFILES= ${WRKSRC}/aclocal.m4
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
post-patch:
-.for DIR in ${DIRS}
- ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
- -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
- -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
- -e "s,/usr/lib/im,${LOCALBASE}/lib/im,g" \
- -e "s,-I\$$(IM_INCLUDEDIR),-I${LOCALBASE}/include/iiimf,g" \
- ${WRKSRC}/${DIR}/configure
${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
- ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/Makefile.in \
- ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpAux.c \
- ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpIM.c \
- ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/iiimpConv.c \
- ${WRKSRC}/iiimxcf/xiiimp.so/iiimp/csconv.h \
- ${WRKSRC}/iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp \
- ${WRKSRC}/iiimxcf/htt_xbe/src/watchdog.c
-.endfor
-
-do-configure:
-.for DIR in ${DIRS}
- cd ${WRKSRC}/${DIR} && ${SH} configure ${CONFIGURE_ARGS}
-.endfor
-
-do-build:
-.for DIR in ${DIRS}
- cd ${WRKSRC}/${DIR} && ${GMAKE} all
-.endfor
-
-do-install:
-.for DIR in ${DIRS}
- cd ${WRKSRC}/${DIR} && ${GMAKE} install
-.endfor
+ ${WRKSRC}/../../acfiles/im_common.m4 \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/lib/IMdkit/common/XIMPublic.cpp \
+ ${WRKSRC}/src/watchdog.c
+
+pre-configure:
+ cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal -I ../../acfiles
+ ${TOUCH} ${WRKSRC}/config.h.in
.include <bsd.port.post.mk>
diff --git a/textproc/iiimf-x/distinfo b/textproc/iiimf-x/distinfo
index 69d32b06e569..29d049a782bc 100644
--- a/textproc/iiimf-x/distinfo
+++ b/textproc/iiimf-x/distinfo
@@ -1,2 +1,2 @@
-MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
-SIZE (im-sdk.r11_4.1467.tar.bz2) = 7253894
+MD5 (im-sdk-src-r12_0_1-svn1891.tgz) = 4e51e4fd07391bd957622db0e89aeefe
+SIZE (im-sdk-src-r12_0_1-svn1891.tgz) = 18206118
diff --git a/textproc/iiimf-x/files/patch-acfiles_check_sys.m4 b/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
new file mode 100644
index 000000000000..974f159f9098
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
@@ -0,0 +1,36 @@
+--- acfiles/check_sys.m4.orig Thu Aug 12 18:01:23 2004
++++ acfiles/check_sys.m4 Wed Sep 8 16:15:39 2004
+@@ -74,6 +74,11 @@
+ ## Checks for thread library.
+ AC_CHECK_LIB(pthread, pthread_create, [ HAVE_LIBPTHREAD="yes" ])
+ AC_CHECK_LIB(thread, thr_create, [ HAVE_LIBUITHREAD="yes" ])
++
++ case "${target}" in
++ *freebsd*) HAVE_LIBPTHREAD="yes";;
++ esac
++
+ if test "X${HAVE_LIBPTHREAD}" = "Xyes" ; then
+ HAVE_THREAD="pthread"
+ elif test "X${HAVE_LIBUITHREAD}" = "Xyes" ; then
+@@ -210,8 +215,6 @@
+ COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
+ ;;
+ *freebsd*)
+- THREAD_LDFLAGS="-pthread"
+- PTHREAD_LIBS=""
+ ;;
+ esac
+
+@@ -249,9 +252,9 @@
+ THREAD_CXX_CFLAGS="-mt"
+ HAVE_THREAD="uithread"
+ ;;
+- *freebsd*@gcc:*)
+- THREAD_LDFLAGS="-pthread"
+- THREAD_LIBS=""
++ *freebsd*)
++ THREAD_CXX_CFLAGS="${PTHREAD_CFLAGS}"
++ THREAD_LIBS="${PTHREAD_LIBS}"
+ HAVE_THREAD="freebsd-pthread"
+ ;;
+ *linux*)
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
index 60dc3b52a363..4fb312ab1af8 100644
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
@@ -1,39 +1,38 @@
---- iiimxcf/htt_xbe/src/watchdog.c.orig Sat Dec 6 05:54:41 2003
-+++ iiimxcf/htt_xbe/src/watchdog.c Sat Dec 6 06:01:13 2003
-@@ -187,7 +187,11 @@
+--- iiimxcf/htt_xbe/src/watchdog.c.orig Tue Jul 13 07:25:40 2004
++++ iiimxcf/htt_xbe/src/watchdog.c Sun Sep 5 05:43:59 2004
+@@ -187,11 +187,15 @@
* Setup the signal handlers to monitor htt_server, htt_props
* abnormal termination
*/
+#if defined(__FreeBSD__)
+ setsid();
+#else
+ #ifdef SETPGRP_VOID
grpid = setpgrp();
+ #else
+ grpid = setpgrp(0, 0);
+ #endif
+#endif
#ifdef SunOS
sigset(SIGTERM, clean_up);
-@@ -309,7 +313,7 @@
- XChangeProperty(display, httw_id, class_atom, XA_STRING, 8,
- PropModeReplace, "htt", strlen("htt"));
-
-- XSetWMProtocols(display, httw_id, &htt_save_atom, 3);
-+ XSetWMProtocols(display, httw_id, htt_save_atom, 3);
-
- XSelectInput(display, httw_id, PropertyChangeMask | StructureNotifyMask);
- XSetSelectionOwner(display, htt_atom, httw_id, CurrentTime);
-@@ -703,7 +707,11 @@
- * most of the cases
+@@ -708,11 +712,15 @@
*/
sleep(1);
+
+#if defined(__FreeBSD__)
+ setsid();
+#else
+ #ifdef SETPGRP_VOID
setpgrp();
+ #else
+ setpgrp(0, 0);
+ #endif
+#endif
+
#ifdef SunOS
if (flag == OPENWIN_PATH) {
- putenv(OPENWIN_MOTIF_PRELOAD_ENV);
-@@ -734,7 +742,11 @@
+@@ -744,7 +752,11 @@
perror("watchdog:fork\n");
exit(errno);
case 0:
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in
deleted file mode 100644
index bacced162b1d..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- iiimxcf/xiiimp.so/iiimp/Makefile.in.orig Sun Dec 7 20:00:38 2003
-+++ iiimxcf/xiiimp.so/iiimp/Makefile.in Sun Dec 7 20:01:19 2003
-@@ -138,8 +138,7 @@
- # you have to add the following by yourself to check undefined symbols.
- # -Wl,-z -Wl,defs
- xiiimp_la_LIBADD = $(X_LIBS) \
-- $(IM_LIBDIR)/iiimcf/libiiimcf.la \
-- $(IM_LIBDIR)/iiimp/libiiimp.la \
-+ -L$(prefix)/lib -liiimcf -liiimp \
- $(DLOPEN_LIBS) $(THREAD_LIBS)
-
- xiiimp_la_SOURCES = \
-@@ -190,8 +189,7 @@
- CONFIG_CLEAN_FILES =
- LTLIBRARIES = $(module_LTLIBRARIES)
-
--xiiimp_la_DEPENDENCIES = $(IM_LIBDIR)/iiimcf/libiiimcf.la \
-- $(IM_LIBDIR)/iiimp/libiiimp.la
-+xiiimp_la_DEPENDENCIES =
- am_xiiimp_la_OBJECTS = xiiimp_la-genutil.lo xiiimp_la-KeyMap.lo \
- xiiimp_la-guiIMLookup.lo xiiimp_la-XeIMWrap.lo \
- xiiimp_la-guiIMPre.lo xiiimp_la-lookup.lo xiiimp_la-XimpConv.lo \
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c b/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
deleted file mode 100644
index 06b9e60c1d75..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- iiimxcf/xiiimp.so/iiimp/iiimpAux.c.orig Sat Dec 6 04:07:05 2003
-+++ iiimxcf/xiiimp.so/iiimp/iiimpAux.c Sat Dec 6 04:07:42 2003
-@@ -61,7 +61,7 @@
- #include <strings.h>
- #include <ctype.h>
- #include <sys/param.h>
--#ifndef linux
-+#if !defined(linux) && !defined(__FreeBSD__)
- #include <synch.h>
- #endif
-
diff --git a/textproc/iiimf-x/pkg-plist b/textproc/iiimf-x/pkg-plist
index a3f00a8c9dfb..3254b3e6e5b0 100644
--- a/textproc/iiimf-x/pkg-plist
+++ b/textproc/iiimf-x/pkg-plist
@@ -1,7 +1,2 @@
-lib/im/xiiimp.so.2
-lib/im/xiiimp.so
-lib/im/xiiimp.la
-lib/im/xiiimp.a
lib/im/htt_xbe
lib/im/httx
-@dirrm lib/im