aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/info2html
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-25 23:51:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-25 23:51:09 +0800
commit72a5d0b09943e8a3eb48809bf318f336b9906603 (patch)
tree0bfd18ca605d355e4c7bde149bcf88ecc8c5061c /textproc/info2html
parent2c9cbe560a48f5264e2662ff3a309b53b8deaff4 (diff)
downloadfreebsd-ports-gnome-72a5d0b09943e8a3eb48809bf318f336b9906603.tar.gz
freebsd-ports-gnome-72a5d0b09943e8a3eb48809bf318f336b9906603.tar.zst
freebsd-ports-gnome-72a5d0b09943e8a3eb48809bf318f336b9906603.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'textproc/info2html')
-rw-r--r--textproc/info2html/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/info2html/Makefile b/textproc/info2html/Makefile
index ac1451989507..e475ccad49de 100644
--- a/textproc/info2html/Makefile
+++ b/textproc/info2html/Makefile
@@ -10,13 +10,16 @@ EXTRACT_SUFX= .tar
MAINTAINER= wenheping@gmail.com
COMMENT= Translate GNU info files into HTML pages
+USES= shebangfix
NO_BUILD= yes
+
PLIST_FILES= bin/info2html bin/infocat bin/info2html.css bin/info2html.conf
+SHEBANG_FILES= info2html infocat
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/info2html ${LOCALBASE}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/infocat ${LOCALBASE}/bin
- ${INSTALL_DATA} ${WRKSRC}/info2html.conf ${LOCALBASE}/bin
- ${INSTALL_DATA} ${WRKSRC}/info2html.css ${LOCALBASE}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/info2html ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/infocat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/info2html.conf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/info2html.css ${STAGEDIR}${PREFIX}/bin
+
.include <bsd.port.mk>