aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iso8879/Makefile
diff options
context:
space:
mode:
authorjfieber <jfieber@FreeBSD.org>1997-06-23 05:01:28 +0800
committerjfieber <jfieber@FreeBSD.org>1997-06-23 05:01:28 +0800
commit4edce6969296eb1f09f4b2c507d2e8f8fe5c86f3 (patch)
tree080b1ff13b69d84b208886e6886abbd5dc8a8d39 /textproc/iso8879/Makefile
parentc2fd0294a926f74d4b54c46f2220b0bf97919939 (diff)
downloadfreebsd-ports-gnome-4edce6969296eb1f09f4b2c507d2e8f8fe5c86f3.tar.gz
freebsd-ports-gnome-4edce6969296eb1f09f4b2c507d2e8f8fe5c86f3.tar.zst
freebsd-ports-gnome-4edce6969296eb1f09f4b2c507d2e8f8fe5c86f3.zip
Supplementary materials from ISO 8879:1986, specifically
general character entity definitions used by numerous SGML DTDs including DocBook and our version of Linuxdoc.
Diffstat (limited to 'textproc/iso8879/Makefile')
-rw-r--r--textproc/iso8879/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/iso8879/Makefile b/textproc/iso8879/Makefile
new file mode 100644
index 000000000000..471944a6d116
--- /dev/null
+++ b/textproc/iso8879/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: iso8879
+# Version required: 1.0
+# Date created: June 19, 1997
+# Whom: jfieber
+#
+# $Id$
+#
+
+DISTNAME= iso8879-1.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.sil.org/sgml/
+
+MAINTAINER= jfieber@FreeBSD.ORG
+
+DISTFILES= isoENTS.zip
+
+NO_MTREE= yes
+NO_EXTRACT= yes
+NO_BUILD= yes
+NO_PATCH= yes
+NO_CONFIGURE= yes
+NO_WRKDIR= yes
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+INSTDIR= ${PREFIX}/share/sgml/iso8879/
+
+pre-install:
+ @[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
+
+do-install:
+ @unzip -a -q -o -d ${INSTDIR} ${DISTDIR}/${DISTFILES}
+ @${INSTALL_DATA} ${FILESDIR}/catalog ${INSTDIR}/catalog
+ @chmod ${SHAREMODE} ${INSTDIR}/*
+ @chown -R ${SHAREOWN}.${SHAREGRP} ${INSTDIR}
+
+.include <bsd.port.mk>