aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/jakarta-poi
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-05-26 00:33:57 +0800
committerhq <hq@FreeBSD.org>2005-05-26 00:33:57 +0800
commit6242b1080764777969f6fdcb0fb46c969a4ac26b (patch)
tree4469104dd380126d5a282135f7d9414ca711cec7 /textproc/jakarta-poi
parente1db04d6bbb0d8ee0d4d86cf99c6c5cc16aaa28e (diff)
downloadfreebsd-ports-gnome-6242b1080764777969f6fdcb0fb46c969a4ac26b.tar.gz
freebsd-ports-gnome-6242b1080764777969f6fdcb0fb46c969a4ac26b.tar.zst
freebsd-ports-gnome-6242b1080764777969f6fdcb0fb46c969a4ac26b.zip
The POI project consists of APIs for manipulating various file formats based
upon Microsoft's OLE 2 Compound Document format using pure Java. In short, you can read and write MS Excel files using Java. Soon, you'll be able to read and write Word files using Java. POI is your Java Excel solution as well as your Word Excel solution. However, we have a complete API for porting other OLE 2 Compound Document formats and welcome others to participate. WWW: http://jakarta.apache.org/poi/ PR: 78327 Submitted by: Anton Yudin <toha@toha.org.ua>
Diffstat (limited to 'textproc/jakarta-poi')
-rw-r--r--textproc/jakarta-poi/Makefile53
-rw-r--r--textproc/jakarta-poi/distinfo2
-rw-r--r--textproc/jakarta-poi/pkg-descr8
3 files changed, 63 insertions, 0 deletions
diff --git a/textproc/jakarta-poi/Makefile b/textproc/jakarta-poi/Makefile
new file mode 100644
index 000000000000..0bfa53d083a8
--- /dev/null
+++ b/textproc/jakarta-poi/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: Jakarta POI API
+# Date created: Wed Mar 2 22:01:02 EET 2005
+# Whom: Anton Yudin <toha@toha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poi
+PORTVERSION= 2.5.1
+CATEGORIES= textproc devel java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/release/src
+PKGNAMEPREFIX= jakarta-
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}-final-20040804
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= Java API To Access Microsoft Format Files
+
+BUILD_DEPENDS= ${JAVALIBDIR}/xalan.jar:${PORTSDIR}/textproc/xalan-j
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+USE_JIKES= no
+
+NO_WRKSUBDIR= yes
+
+DSTAMP= `date +%Y%m%d`
+
+USE_ANT= yes
+MAKE_ENV+= ANT_INCLUDE_SHARED_JARS=YES
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+ALL_TARGET= jar
+JARFILE= ${PORTNAME}-${PORTVERSION}-final-${DSTAMP}.jar
+DESTJARFILE= ${PORTNAME}.jar
+
+PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
+ @${INSTALL_DATA} ${WRKSRC}/build/dist/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+ @${ECHO_MSG} " [ DONE ]"
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/docs/apidocs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/jakarta-poi/distinfo b/textproc/jakarta-poi/distinfo
new file mode 100644
index 000000000000..0008667aa5d6
--- /dev/null
+++ b/textproc/jakarta-poi/distinfo
@@ -0,0 +1,2 @@
+MD5 (poi-src-2.5.1-final-20040804.tar.gz) = d80052119b2d6746f103d49f915b0ad8
+SIZE (poi-src-2.5.1-final-20040804.tar.gz) = 6870414
diff --git a/textproc/jakarta-poi/pkg-descr b/textproc/jakarta-poi/pkg-descr
new file mode 100644
index 000000000000..d7e1374c28cd
--- /dev/null
+++ b/textproc/jakarta-poi/pkg-descr
@@ -0,0 +1,8 @@
+The POI project consists of APIs for manipulating various file formats based
+upon Microsoft's OLE 2 Compound Document format using pure Java. In short, you
+can read and write MS Excel files using Java. Soon, you'll be able to read and
+write Word files using Java. POI is your Java Excel solution as well as your
+Word Excel solution. However, we have a complete API for porting other OLE 2
+Compound Document formats and welcome others to participate.
+
+WWW: http://jakarta.apache.org/poi/