aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/kdiff3/Makefile
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-06-07 22:28:45 +0800
committermarkus <markus@FreeBSD.org>2004-06-07 22:28:45 +0800
commitcbe40423b7d9e9a1fc6eac77cc2ddc7b5bead3b0 (patch)
tree220b5e8d5aa9b49805d60f7d793635fd8ed9963c /textproc/kdiff3/Makefile
parentee3adb9d17d311837bed6ead27d72b28d03f0c47 (diff)
downloadfreebsd-ports-gnome-cbe40423b7d9e9a1fc6eac77cc2ddc7b5bead3b0.tar.gz
freebsd-ports-gnome-cbe40423b7d9e9a1fc6eac77cc2ddc7b5bead3b0.tar.zst
freebsd-ports-gnome-cbe40423b7d9e9a1fc6eac77cc2ddc7b5bead3b0.zip
- Update to version 0.9.84
- Don't use Makefile.kde anymore - Respect CFLAGS PR: ports/67581 Submitted by: Heiner Eichmann <h.eichmann@gmx.de>
Diffstat (limited to 'textproc/kdiff3/Makefile')
-rw-r--r--textproc/kdiff3/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index e99ce95800a3..d45292634590 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kdiff3
-PORTVERSION= 0.9.83
-PORTREVISION= 1
+PORTVERSION= 0.9.84
CATEGORIES= textproc kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +14,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= h.eichmann@gmx.de
COMMENT= A KDE3 graphical frontend for diff
-CONFIGURE_ARGS+= --program-transform-name=s,^,,
-
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
USE_LIBTOOL_VER= 13
+USE_REINPLACE= yes
+
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
MAN1= kdiff3.1
@@ -28,6 +28,8 @@ pre-configure:
${TOUCH} ${WRKSRC}/${i}
.endfor
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>