aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/kmfl-sil-yi
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-03 01:25:47 +0800
committermiwi <miwi@FreeBSD.org>2009-09-03 01:25:47 +0800
commitf2acab5080253776cb8186362d7c612edec494b3 (patch)
tree36d9582021d5a4d37538f9f875c3687df82e4314 /textproc/kmfl-sil-yi
parentd52d90986b71b536a240af296d84e5b766145d7f (diff)
downloadfreebsd-ports-gnome-f2acab5080253776cb8186362d7c612edec494b3.tar.gz
freebsd-ports-gnome-f2acab5080253776cb8186362d7c612edec494b3.tar.zst
freebsd-ports-gnome-f2acab5080253776cb8186362d7c612edec494b3.zip
This is a keyboard for input of the standardized Yi script of southwestern
China with Unicode Yi fonts. It is written in Keyman keyboard language and developed by SIL Non-Roman Script Initiative (NRSI). To keyboard a Yi syllable, you should type the Pinyin romanization for that syllable, followed by a space. For keyboarding punctuation, use the usual punctuation keystrokes. The keyboard is compatible with Yi range as defined in Unicode 3.0 and it does not provide keystrokes for the Yi Radicals which were added to Unicode 3.2 (U+A4A2..U+A4A3, U+A4B4, U+A4C1, U+A4C5). WWW: http://scripts.sil.org/SILYI_home PR: ports/138448 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Diffstat (limited to 'textproc/kmfl-sil-yi')
-rw-r--r--textproc/kmfl-sil-yi/Makefile49
-rw-r--r--textproc/kmfl-sil-yi/distinfo3
-rw-r--r--textproc/kmfl-sil-yi/files/patch-SourceFiles::Yi7.kmn17
-rw-r--r--textproc/kmfl-sil-yi/pkg-descr13
4 files changed, 82 insertions, 0 deletions
diff --git a/textproc/kmfl-sil-yi/Makefile b/textproc/kmfl-sil-yi/Makefile
new file mode 100644
index 000000000000..b5c0ff8f660a
--- /dev/null
+++ b/textproc/kmfl-sil-yi/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: scim-kmfl-sil-yi
+# Date created: 1 September 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-kmfl-sil-yi
+PORTVERSION= 20020903
+CATEGORIES= textproc
+MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=SILYi12OFL_Src&filename=/ \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/kmfl/
+DISTNAME= SILYiOFL1.2Src
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= SCIM KMFL IMEngine Unicode keyboard for standardized Yi script
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+WRKSRC= ${WRKDIR}
+USE_DOS2UNIX= SourceFiles/Yi7.kmn
+NO_BUILD= yes
+USE_ZIP= yes
+
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PLIST_FILES= ${SCIM_KMFL_DIR}/Yi7.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/YiPinYin.bmp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+ @${ECHO_MSG}
+ @${ECHO_MSG} " At the moment, this keyboard has no documentation."
+ @${ECHO_MSG} " As a general rule, type the Pinyin romanization for"
+ @${ECHO_MSG} " that syllable, followed by a space. For punctuation,"
+ @${ECHO_MSG} " try usual punctuation keystrokes."
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/kmfl-sil-yi/distinfo b/textproc/kmfl-sil-yi/distinfo
new file mode 100644
index 000000000000..ac88e485ae99
--- /dev/null
+++ b/textproc/kmfl-sil-yi/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/SILYiOFL1.2Src.zip) = 9565edac15ec019b935d7a8e0a841968
+SHA256 (kmfl/SILYiOFL1.2Src.zip) = 7733011014f3a4ad77456d668db318d78f19ca03613dd6857cf80cf3a0ef3245
+SIZE (kmfl/SILYiOFL1.2Src.zip) = 2627553
diff --git a/textproc/kmfl-sil-yi/files/patch-SourceFiles::Yi7.kmn b/textproc/kmfl-sil-yi/files/patch-SourceFiles::Yi7.kmn
new file mode 100644
index 000000000000..bb5fa6b87bbc
--- /dev/null
+++ b/textproc/kmfl-sil-yi/files/patch-SourceFiles::Yi7.kmn
@@ -0,0 +1,17 @@
+--- SourceFiles/Yi7.kmn.orig 2009-09-01 17:32:24.000000000 +0200
++++ SourceFiles/Yi7.kmn 2009-09-01 17:32:20.000000000 +0200
+@@ -8,10 +8,12 @@
+ c this software is licensed under the SIL Open Font License
+ c http://scripts.sil.org/OFL
+
+-NAME "Yi"
+-BITMAP YiPinYin
++NAME "SIL Yi 20020903"
++BITMAP YiPinYin.bmp
+ VERSION 6.0
+ HOTKEY "^+P"
++MESSAGE "This software is licensed under the SIL Open Font License (http://scripts.sil.org/OFL)"
++store(&author) "Andy Eatough"
+
+ begin Unicode> use(Unicode Group)
+
diff --git a/textproc/kmfl-sil-yi/pkg-descr b/textproc/kmfl-sil-yi/pkg-descr
new file mode 100644
index 000000000000..2a8a4dfe70e5
--- /dev/null
+++ b/textproc/kmfl-sil-yi/pkg-descr
@@ -0,0 +1,13 @@
+This is a keyboard for input of the standardized Yi script of southwestern
+China with Unicode Yi fonts. It is written in Keyman keyboard language and
+developed by SIL Non-Roman Script Initiative (NRSI).
+
+To keyboard a Yi syllable, you should type the Pinyin romanization for that
+syllable, followed by a space. For keyboarding punctuation, use the usual
+punctuation keystrokes.
+
+The keyboard is compatible with Yi range as defined in Unicode 3.0 and it does
+not provide keystrokes for the Yi Radicals which were added to Unicode 3.2
+(U+A4A2..U+A4A3, U+A4B4, U+A4C1, U+A4C5).
+
+WWW: http://scripts.sil.org/SILYI_home