aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libextractor
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2005-11-11 13:09:45 +0800
committerkevlo <kevlo@FreeBSD.org>2005-11-11 13:09:45 +0800
commit035e1bc6cc3eb956cd6f28da353955d01d68ea12 (patch)
tree84d779f31a05edca44c17c6e49818850d2ed64db /textproc/libextractor
parent8583ee2e075bac03b2fe383debbd6ef143669ed3 (diff)
downloadfreebsd-ports-gnome-035e1bc6cc3eb956cd6f28da353955d01d68ea12.tar.gz
freebsd-ports-gnome-035e1bc6cc3eb956cd6f28da353955d01d68ea12.tar.zst
freebsd-ports-gnome-035e1bc6cc3eb956cd6f28da353955d01d68ea12.zip
- Fix double free() bug.
- Bump PORTREVISION. PR: ports/88748 Submitted by: Vasil Dimov
Diffstat (limited to 'textproc/libextractor')
-rw-r--r--textproc/libextractor/Makefile2
-rw-r--r--textproc/libextractor/files/patch-src::main::extractor.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index ef5dc243dca5..04dfe8915cfd 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libextractor
PORTVERSION= 0.5.6a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://gnunet.org/libextractor/download/ \
${MASTER_SITE_GNU}
diff --git a/textproc/libextractor/files/patch-src::main::extractor.c b/textproc/libextractor/files/patch-src::main::extractor.c
new file mode 100644
index 000000000000..818479c30ce3
--- /dev/null
+++ b/textproc/libextractor/files/patch-src::main::extractor.c
@@ -0,0 +1,14 @@
+--- src/main/extractor.c.orig Fri Nov 11 04:54:19 2005
++++ src/main/extractor.c Fri Nov 11 04:55:27 2005
+@@ -246,8 +246,10 @@
+
+ void __attribute__ ((destructor)) le_ltdl_fini(void) {
+ lt_dlsetsearchpath(old_dlsearchpath);
+- if (old_dlsearchpath != NULL)
++ if (old_dlsearchpath != NULL) {
+ free(old_dlsearchpath);
++ old_dlsearchpath = NULL;
++ }
+ #ifdef MINGW
+ ShutdownWinEnv();
+ #endif