aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libguess
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2012-05-13 15:21:12 +0800
committermva <mva@FreeBSD.org>2012-05-13 15:21:12 +0800
commit76ee7c44c24297ee23bd0397e92abfd80ddd15ee (patch)
tree6748670743923a180fd5e683113fc4a5513d3f47 /textproc/libguess
parent0048247346007c3512bde5b7c512aa828a36b8a3 (diff)
downloadfreebsd-ports-gnome-76ee7c44c24297ee23bd0397e92abfd80ddd15ee.tar.gz
freebsd-ports-gnome-76ee7c44c24297ee23bd0397e92abfd80ddd15ee.tar.zst
freebsd-ports-gnome-76ee7c44c24297ee23bd0397e92abfd80ddd15ee.zip
A high-speed character set detection library.
libguess employs discrete-finite automata to deduce the character set of the input buffer. The advantage of this is that all character sets can be checked in parallel, and quickly. Right now, libguess passes a byte to each DFA on the same pass, meaning that the winning character set can be deduced as efficiently as possible. libguess is fully reentrant, using only local stack memory for DFA operations. WWW: http://www.atheme.org/project/libguess PR: ports/167686 Submitted by: William Grzybowski <william88@gmail.com>
Diffstat (limited to 'textproc/libguess')
-rw-r--r--textproc/libguess/Makefile27
-rw-r--r--textproc/libguess/distinfo2
-rw-r--r--textproc/libguess/pkg-descr11
-rw-r--r--textproc/libguess/pkg-plist6
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/libguess/Makefile b/textproc/libguess/Makefile
new file mode 100644
index 000000000000..6c29b003b9b1
--- /dev/null
+++ b/textproc/libguess/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libguess
+# Date created: 04 May 2012
+# Whom: William Grzybowski
+#
+# $FreeBSD$
+#
+
+PORTNAME= libguess
+PORTVERSION= 1.1
+CATEGORIES= devel textproc
+MASTER_SITES= http://distfiles.atheme.org/
+
+MAINTAINER= william88@gmail.com
+COMMENT= A high-speed character set detection library
+
+LIB_DEPENDS= mowgli.2:${PORTSDIR}/devel/libmowgli
+
+USE_GNOME= gnomehack pkgconfig
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${DESTDIR}$${libdir}/pkgconfig|$${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/textproc/libguess/distinfo b/textproc/libguess/distinfo
new file mode 100644
index 000000000000..5190d2cc6dd1
--- /dev/null
+++ b/textproc/libguess/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libguess-1.1.tar.gz) = e3c9ad3102c9447c591131674135795fb012e073d92e887a2b05c9bbbcbe913f
+SIZE (libguess-1.1.tar.gz) = 95349
diff --git a/textproc/libguess/pkg-descr b/textproc/libguess/pkg-descr
new file mode 100644
index 000000000000..293007826dd5
--- /dev/null
+++ b/textproc/libguess/pkg-descr
@@ -0,0 +1,11 @@
+A high-speed character set detection library.
+
+libguess employs discrete-finite automata to deduce the character set
+of the input buffer. The advantage of this is that all character sets
+can be checked in parallel, and quickly. Right now, libguess passes a
+byte to each DFA on the same pass, meaning that the winning character
+set can be deduced as efficiently as possible.
+
+libguess is fully reentrant, using only local stack memory for DFA operations.
+
+WWW: http://www.atheme.org/project/libguess
diff --git a/textproc/libguess/pkg-plist b/textproc/libguess/pkg-plist
new file mode 100644
index 000000000000..6b42e45866c3
--- /dev/null
+++ b/textproc/libguess/pkg-plist
@@ -0,0 +1,6 @@
+lib/libguess.so.1.0.0
+libdata/pkgconfig/libguess.pc
+lib/libguess.so.1
+lib/libguess.so
+include/libguess/libguess.h
+@dirrm include/libguess