aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libroxml
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-21 05:48:42 +0800
committerpawel <pawel@FreeBSD.org>2011-10-21 05:48:42 +0800
commit6fd24f9a35392de4606567a4ad54636274fb90c7 (patch)
tree68e957a6e7f248a0d4c954b34b62dd3e72798011 /textproc/libroxml
parent9c1cdff7ffe93213fa965d24e4bf19856f32fb4e (diff)
downloadfreebsd-ports-gnome-6fd24f9a35392de4606567a4ad54636274fb90c7.tar.gz
freebsd-ports-gnome-6fd24f9a35392de4606567a4ad54636274fb90c7.tar.zst
freebsd-ports-gnome-6fd24f9a35392de4606567a4ad54636274fb90c7.zip
- Update to version 2.1.1
- Add LICENSE PR: ports/161507 Submitted by: maintainer
Diffstat (limited to 'textproc/libroxml')
-rw-r--r--textproc/libroxml/Makefile7
-rw-r--r--textproc/libroxml/distinfo4
-rw-r--r--textproc/libroxml/files/patch-Makefile11
-rw-r--r--textproc/libroxml/files/patch-inc_roxml-types.h11
4 files changed, 13 insertions, 20 deletions
diff --git a/textproc/libroxml/Makefile b/textproc/libroxml/Makefile
index 0da4141475b2..3f6acd3929db 100644
--- a/textproc/libroxml/Makefile
+++ b/textproc/libroxml/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= libroxml
-PORTVERSION= 2.0.3
+PORTVERSION= 2.1.1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
MAINTAINER= gaod@hychen.org
COMMENT= A minimum, easy-to-use, C implementation for xml file parsing
+LICENSE= LGPL21
+
PROJECTHOST= libroxml
USE_GMAKE= yes
@@ -25,7 +27,8 @@ PLIST_FILES= bin/roxml \
lib/libroxml.so \
lib/libroxml.so.0 \
lib/libroxml.a \
- include/roxml.h
+ include/roxml.h \
+ libdata/pkgconfig/libroxml.pc
pre-build:
@cd ${WRKSRC} && ${GMAKE} clean
diff --git a/textproc/libroxml/distinfo b/textproc/libroxml/distinfo
index 03f950c75f7e..44e0617daf78 100644
--- a/textproc/libroxml/distinfo
+++ b/textproc/libroxml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libroxml-2.0.3.tar.gz) = 9963c2042367e73472682ec074eec831c4a0e0203558d152898c60a814dc3c7e
-SIZE (libroxml-2.0.3.tar.gz) = 89730
+SHA256 (libroxml-2.1.1.tar.gz) = e4e91b610614d6cb1204ac9abbb417368fe84654c7de58134b436cfd00f1a244
+SIZE (libroxml-2.1.1.tar.gz) = 154630
diff --git a/textproc/libroxml/files/patch-Makefile b/textproc/libroxml/files/patch-Makefile
index 2c3ebfe7cc22..160eb6f450ec 100644
--- a/textproc/libroxml/files/patch-Makefile
+++ b/textproc/libroxml/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2010-03-20 07:47:37.000000000 +0800
-+++ Makefile 2010-04-16 18:56:26.000000000 +0800
-@@ -111,25 +111,13 @@
+--- Makefile.orig 2011-10-12 06:48:52.000000000 +0800
++++ Makefile 2011-10-12 06:54:09.000000000 +0800
+@@ -140,25 +140,14 @@
$E - $(MAKE) -C $(abspath fuse.xml)
.PHONY: install
@@ -19,8 +19,8 @@
- $E install -D $(INC) $(DESTDIR)/usr/include
- $E install -D LGPL.txt $(DESTDIR)/usr/share/doc/libroxml/
- $E install -D docs/roxml.1 $(DESTDIR)/usr/share/man/man1/
-- $E install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
-- $E install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
+- $E [ ! -d docs/man/man3 ] || install -D docs/man/man3/* $(DESTDIR)/usr/share/man/man3/
+- $E [ ! -d docs/html ] || install -D docs/html/* $(DESTDIR)/usr/share/doc/libroxml/html/
- $E install -m644 libroxml.pc $(DESTDIR)/usr/lib/pkgconfig
- $E cp -d $(TARGET_LN) $(DESTDIR)/usr/lib
+install:
@@ -30,6 +30,7 @@
+ $E install $(INC) $(DESTDIR)/include
+ $E install docs/roxml.1 $(DESTDIR)/man/man1/
+ $E install $(TARGET_LN) $(DESTDIR)/lib
++ $E install -m644 libroxml.pc $(DESTDIR)/libdata/pkgconfig
.PHONY: uninstall
uninstall:
diff --git a/textproc/libroxml/files/patch-inc_roxml-types.h b/textproc/libroxml/files/patch-inc_roxml-types.h
deleted file mode 100644
index 04131a373281..000000000000
--- a/textproc/libroxml/files/patch-inc_roxml-types.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- inc/roxml-types.h.orig 2011-07-11 10:28:59.000000000 +0800
-+++ inc/roxml-types.h 2011-07-11 10:29:10.000000000 +0800
-@@ -27,6 +27,8 @@
- #include "roxml_win32_native.h"
- #endif
-
-+#include <pthread.h>
-+
- /** \typedef roxml_parse_func
- *
- * \brief parser callback functions