aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libtre
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2007-07-18 21:15:15 +0800
committerjkoshy <jkoshy@FreeBSD.org>2007-07-18 21:15:15 +0800
commit71a9bddf6f866c3b9a71c218006cea7359e63316 (patch)
tree16ec1bed62220200dca6542567db941d54567fdb /textproc/libtre
parentac8503035a2fc6917e933fa8c8b4de908e668f5e (diff)
downloadfreebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.tar.gz
freebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.tar.zst
freebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.zip
Upgrade to v0.7.5.
Upstream changes include: - A new swedish translation. - A '-q' option for agrep(1). - Various bug fixes. The port now uses OPTIONS for configuration. It currently supports two configuration knobs: "NLS" turns on native language support. "OPTIMIZED_CFLAGS" compiles the port with aggressive optimization. PR: ports/113441 Submitted by: bf <bf2006a at yahoo dot com>
Diffstat (limited to 'textproc/libtre')
-rw-r--r--textproc/libtre/Makefile38
-rw-r--r--textproc/libtre/distinfo6
-rw-r--r--textproc/libtre/pkg-plist4
3 files changed, 21 insertions, 27 deletions
diff --git a/textproc/libtre/Makefile b/textproc/libtre/Makefile
index 13292aab9d50..b5983e3de793 100644
--- a/textproc/libtre/Makefile
+++ b/textproc/libtre/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= libtre
-PORTVERSION= 0.7.4
-PORTREVISION= 1
+PORTVERSION= 0.7.5
CATEGORIES= textproc
MASTER_SITES= http://laurikari.net/tre/ \
${MASTER_SITE_LOCAL}
@@ -22,22 +21,28 @@ CONFLICTS= glimpse-4* # agrep(1)
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_GETOPT_LONG= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --enable-static --mandir=${PREFIX}/man
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= agrep.1
+MANCOMPRESSED= no
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+OPTIONS= NLS "native language support" off \
+ OPTIMIZED_CFLAGS "append optimization flags to CFLAGS" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -46,17 +51,6 @@ CFLAGS+= -Wuninitialized -ffast-math -finline-functions \
-fforce-mem -fforce-addr -O3
.endif
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
- @${ECHO_MSG} "===> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
-.endif
- @${ECHO_MSG} '===>'
-
-post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -65,4 +59,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/libtre/distinfo b/textproc/libtre/distinfo
index 342389b62cbe..0a7bf7698ea7 100644
--- a/textproc/libtre/distinfo
+++ b/textproc/libtre/distinfo
@@ -1,3 +1,3 @@
-MD5 (tre-0.7.4.tar.bz2) = 8b4bfb078f2cc9e01f37d3d251672f75
-SHA256 (tre-0.7.4.tar.bz2) = 0d55b4bc0a9594c433f2657de9bf4610a1553776f42d317a065929d1c4e91f66
-SIZE (tre-0.7.4.tar.bz2) = 387358
+MD5 (tre-0.7.5.tar.bz2) = e72e5c94008865cf720992a0b25d6e89
+SHA256 (tre-0.7.5.tar.bz2) = 030f25e6e4c1714df013105494bc5e24b3e0acc65887158a52a03efd8e0759aa
+SIZE (tre-0.7.5.tar.bz2) = 396346
diff --git a/textproc/libtre/pkg-plist b/textproc/libtre/pkg-plist
index f06b1e71c42a..19bc8e58514e 100644
--- a/textproc/libtre/pkg-plist
+++ b/textproc/libtre/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/agrep
include/tre/regex.h
include/tre/tre-config.h
@@ -8,7 +7,8 @@ lib/libtre.so
lib/libtre.so.6
libdata/pkgconfig/tre.pc
%%NLS%%share/locale/fi/LC_MESSAGES/tre.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/tre.mo
%%PORTDOCS%%%%DOCSDIR%%/tre-api.html
%%PORTDOCS%%%%DOCSDIR%%/tre-syntax.html
-@dirrm include/tre
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/tre