aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-02-27 02:55:37 +0800
committersobomax <sobomax@FreeBSD.org>2002-02-27 02:55:37 +0800
commit890409f6c6f0cf7338d66ea18c11c85dc4e03a4d (patch)
tree8ee17493de5497bee9eeda2b43bee760710b823b /textproc/libxml2/Makefile
parentf2917e3854081887855125d27fc2e91fec50a261 (diff)
downloadfreebsd-ports-gnome-890409f6c6f0cf7338d66ea18c11c85dc4e03a4d.tar.gz
freebsd-ports-gnome-890409f6c6f0cf7338d66ea18c11c85dc4e03a4d.tar.zst
freebsd-ports-gnome-890409f6c6f0cf7338d66ea18c11c85dc4e03a4d.zip
Update to 2.4.16.
PR: 35002 Submitted by: Lev Serebryakov <lev@serebryakov.spb.ru>
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 6e06573b024f..6f2ddaa7bde5 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.4.13
+PORTVERSION= 2.4.16
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxml
@@ -19,7 +19,6 @@ RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-
CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -28,6 +27,22 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN4= libxml.4
+.if !defined(WITHOUT_PYTHON)
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON:=""
+.else
+CONFIGURE_ARGS+= --without-python
+PLIST_SUB+= PYTHON:="@comment "
+PKGNAMESUFFIX= -nopython
+.endif
+
+.if !defined(WITHOUT_PYTHON)
+pre-extract:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you don't want Python support, add WITHOUT_PYTHON=yes to command line"
+ @${ECHO_MSG} ""
+.endif
+
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'