aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2001-08-26 08:55:06 +0800
committermi <mi@FreeBSD.org>2001-08-26 08:55:06 +0800
commitb0726f1e220f112556c4c8fc8c29c1395be1b8b7 (patch)
tree7ebeed7fcb9a893aade0282916b286052caa0cad /textproc/libxml2/Makefile
parent250418cdbee1c3ed818465fe20ae39eb3bffcf97 (diff)
downloadfreebsd-ports-gnome-b0726f1e220f112556c4c8fc8c29c1395be1b8b7.tar.gz
freebsd-ports-gnome-b0726f1e220f112556c4c8fc8c29c1395be1b8b7.tar.zst
freebsd-ports-gnome-b0726f1e220f112556c4c8fc8c29c1395be1b8b7.zip
Upgrade from 2.4.1 to 2.4.2... I let the maintainers know a couple of
days ago, but the entire maintership (gnome@) is quiet... Reviewed by: maintainers' silence
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 17c559278d7a..9d7711d963e1 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxml
@@ -17,14 +17,17 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+MAKE_FLAGS+= LIBTOOL="${LIBTOOL}" -ELIBTOOL
+.if defined(MAKE_JOBS)
+MAKE_FLAGS+= AM_MAKEFLAGS=-j${MAKE_JOBS}
+.endif
CONFIGURE_ARGS= --with-iconv \
--with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgiconv"
+ LIBS="-L${LOCALBASE}/lib"
MAN1= xml2-config.1 xmllint.1
MAN4= libxml.4
@@ -33,4 +36,9 @@ pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+post-patch:
+ @${PERL} -pi -e 's/([^g])iconv.h/\1giconv.h/g;' \
+ -e 's/-liconv/-lgiconv/g' ${WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/include/libxml/encoding.h
+
.include <bsd.port.mk>