aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-30 22:31:53 +0800
committerswills <swills@FreeBSD.org>2012-09-30 22:31:53 +0800
commit52779ae1060b15f81759f646f3753495120c440f (patch)
tree53b9212778d940e65ef3243377241dc7751137f8 /textproc/libxml2
parentd6c5702249aa87d3c561664cdac8193b247086d1 (diff)
downloadfreebsd-ports-gnome-52779ae1060b15f81759f646f3753495120c440f.tar.gz
freebsd-ports-gnome-52779ae1060b15f81759f646f3753495120c440f.tar.zst
freebsd-ports-gnome-52779ae1060b15f81759f646f3753495120c440f.zip
- Revert previous change to add -pthread since libxml2 is not threaded, but is
thread-safe, so -pthread is not needed here, but in threaded programs that use libxml2 Pointed out by: ale@ Discussed with: marcus, kwm Pointyhat to: swills
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile11
-rw-r--r--textproc/libxml2/files/extra-patch-threads11
2 files changed, 1 insertions, 21 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 4945f6259e5f..570504fcc3e5 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -13,7 +13,7 @@
PORTNAME= libxml2
PORTVERSION= 2.7.8
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://gd.tuwien.ac.at/pub/libxml/ \
ftp://xmlsoft.org/libxml2/
@@ -54,11 +54,6 @@ CONFIGURE_ARGS+= --without-schemas
.if defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --without-threads
-.else
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-threads
.endif
.if defined(WITH_MEM_DEBUG)
@@ -74,10 +69,6 @@ CONFIGURE_ARGS+= --with-thread-alloc
.endif
post-patch:
-.if !defined(WITHOUT_THREADS)
- @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
- ${WRKSRC}/xml2-config.in
-.endif
.for d in . doc doc/devhelp doc/examples
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||' \
${WRKSRC}/${d}/Makefile.in
diff --git a/textproc/libxml2/files/extra-patch-threads b/textproc/libxml2/files/extra-patch-threads
deleted file mode 100644
index d7f46b142367..000000000000
--- a/textproc/libxml2/files/extra-patch-threads
+++ /dev/null
@@ -1,11 +0,0 @@
---- xml2-config.in.orig 2012-09-08 17:23:54.000000000 +0000
-+++ xml2-config.in 2012-09-08 17:26:22.000000000 +0000
-@@ -91,7 +91,7 @@
- echo @XML_LIBDIR@ @XML_LIBS@
- fi
- else
-- echo @XML_LIBDIR@ @XML_LIBS@ @WIN32_EXTRA_LIBADD@
-+ echo @XML_LIBDIR@ @XML_LIBS@ @WIN32_EXTRA_LIBADD@ %%PTHREAD_LIBS%%
- fi
- ;;
-