aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-11-03 06:49:26 +0800
committerkwm <kwm@FreeBSD.org>2011-11-03 06:49:26 +0800
commit53358e526af4e241d396ac670910f4af4f85e09b (patch)
tree6b18002e2cda618062c5d48747d14c98b5546466 /textproc/libxml2
parenta8bd5c8b86674732191b00e3bad940d1b637d717 (diff)
downloadfreebsd-ports-gnome-53358e526af4e241d396ac670910f4af4f85e09b.tar.gz
freebsd-ports-gnome-53358e526af4e241d396ac670910f4af4f85e09b.tar.zst
freebsd-ports-gnome-53358e526af4e241d396ac670910f4af4f85e09b.zip
Do the WITH_FBSD10_FIX manualy, because it doesn't do the right thing (yet).
This should unbreak the python bindings. Reported by: miwi and pointyhat (via pav)
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 31c113df02f7..ae151bd6d170 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -32,7 +32,7 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomehack pkgconfig
USE_LDCONFIG= yes
-WITH_FBSD10_FIX=yes
+#WITH_FBSD10_FIX=yes
CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
@@ -75,10 +75,13 @@ post-patch:
's|/etc/xml/catalog|${LOCALBASE}/share/xml/catalog|g; \
s|/etc/sgml/catalog|${LOCALBASE}/share/sgml/catalog|g' ${WRKSRC}/${f}
.endfor
-
-pre-build:
- @${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
- ${WRKSRC}/configure ${WRKSRC}/config.h.in
+# manual patch because WITH_FBSD10_FIX break the python bindings
+ ${FIND} ${WRKSRC} -type f -name configure \
+ -exec ${SH} -c " \
+ mtime=\$$(date -r \$$(stat -f '%m' \$$0) '+%Y%m%d%H%M.%S'); \
+ ${SED} -i '.batman' -e 's|freebsd1\*)|freebsd1.\*)|g' \
+ -e 's|freebsd\[123\]\*)|freebsd[123].*)|g' \$$0; \
+ touch -mt \$$mtime \$$0" {} \; || /usr/bin/true
.include <bsd.port.mk>